Feedback and Bug Reports for Porteus v2.1 RC2

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
donald
Full of knowledge
Full of knowledge
Posts: 1116
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#106 by donald » 26 Jul 2013, 10:06

@Ahau
Ahau wrote: To test my fix, su to root and run:

Code: Select all

gpasswd -d guest plugdev
that will remove guest from the plugdev group. Now you should get a popup prompting for root password before udisks will allow you to unmount disks that were not mounted by guest. If this works, I'll see about a fix for 2.2 so we can get thorough testing on it.
Your fix works partly.If the permission is given once (to mount sda2 for example),
then "guest" is also able to mount sda3,4,5 etc, without beeing asked for the
root-Pw again. (the same for umount)
In General:
what i am looking for is this:
I start the system,log in as root,umount partitions which should not be accessible
for guest,-- this should survive a shutdown/reboot.Unmounted Partitions
(by root) should not at all be visible for "guest".(no Icon) 8)

User avatar
Saman
Black ninja
Black ninja
Posts: 32
Joined: 18 May 2013, 20:31
Distribution: Porteus 2.1 RC1 KDE / LXDE
Location: Iran

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#107 by Saman » 27 Jul 2013, 03:44

Hi,

It seems that deb2xzm command is not working, please advise!

p.s. I am using Porteus 2.1 KDE
All these, I can not bear to witness any longer. Can not the kingdom of salvation take me home?
-Cliff Burton R.I.P.-

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#108 by fanthom » 27 Jul 2013, 07:26

@Saman
please post an url to the deb package so i can check myself

thanks
Please add [Solved] to your thread title if the solution was found.

don570
Contributor
Contributor
Posts: 99
Joined: 01 Jun 2012, 00:37
Location: Ontario

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#109 by don570 » 27 Jul 2013, 20:12

I wrote a script to extract debian packages (among others)
I believe I used undeb script.
viewtopic.php?f=53&t=1313

User avatar
solnyshok
White ninja
White ninja
Posts: 16
Joined: 28 Jul 2013, 16:18
Distribution: Porteus 2.1x64 @64GB microSDHC
Location: Riga, Latvia

suspend works only when USB stick is pulled out

Post#110 by solnyshok » 30 Jul 2013, 06:58

Hi, I boot MATE/LXDE/XFCE from USB with copy2ram params, no save file. If USB is mounted, or even unmounted (but physically still inside USB slot) suspend doesn't work - or, actually, looks like nothing happens, but when I pull out USB stick, laptop immediately suspends. Is that by design?

Another, smaller issue, is that even though I set in power management settings to "ask" when power button is pressed, it immediately switches off my laptop. I have to go via "menu"->"shutdown"->suspend.

Tonio
Contributor
Contributor
Posts: 266
Joined: 28 Dec 2010, 16:37
Distribution: Slackware,porteus,FreeBSD,Slax
Location: 127.0.0.1

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#111 by Tonio » 30 Jul 2013, 16:20

KDE4 i486 with libreoffice.

LibreOffice Crashes when using presenter. Copy and paste some text, tried to change from 32pt font to smaller font and program crashed :(
Other than this crash, most other things work great and are looking beautifully! Great Job folks :) developers, programmers, & all porteus users working to make porteus better and one of the best pocket linux system available.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Wrong colours on youtube on flash videos

Post#112 by Rava » 01 Aug 2013, 07:31

Wrong colours on youtube on flash videos

System: XFCe Porteus 2.1 rc2, x86-64, FlashPlayer is: 11.2.202.285
nVidia driver used: nVidia-304.88-porteus-v2.1-rc2-x86_64-1ftm.xzm

Same issue like described on other pages:
https://answers.launchpad.net/ubuntu/+s ... ion/192181
https://bugbase.adobe.com/index.cfm?eve ... id=3077076

Most recognized error are the blue faces.

I put this in my cat /etc/adobe/mms.cfg , and it worked until reboot, now it won't work anymore:

Code: Select all

EnableLinuxHWVideoDecode = 0
I also have to disable "enable hardware acceleration" in the flash player settings (right click on a video: "Settings ..."), after reloading the video page the error vanishes.

Anything we can do to get rid of this error without the need of the user doing anything? To be included in 2.1 finale...
Cheers!
Yours Rava

neko
Contributor
Contributor
Posts: 862
Joined: 09 Feb 2013, 09:55
Distribution: APorteus-FVWM-ja-x86_64.iso
Location: japan

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#113 by neko » 01 Aug 2013, 08:50

[Porteus-LXDE-v2.1-rc2-i486.iso]
X driver modesetting is degraded.
[/usr/lib/xorg/modules/drivers/modesetting_drv.la,modesetting_drv.so in 002-xorg]

On netbook MSI u180 (cpu:Atom N2800),
Porteus-LXDE-v2.1-rc2-i486.iso can not be booted,
but Porteus-LXDE-v2.1-rc1.5-i486.iso can be booted.

/usr/lib/xorg/modules/drivers/modesetting_drv.* of v2.1-rc2 are replaced ones of v2.1-rc1.5.
Then the modefied Porteus-LXDE-v2.1-rc2-i486.iso can be booted on Atom N2800.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#114 by fanthom » 01 Aug 2013, 11:02

@Saman
any chance to get a deb archive which does not convert to xzm?

@solnyshok
tested on my laptop and i can suspend when usb is plugged. please check if disabling 'laptop-mode-tools' helps:

Code: Select all

sh /etc/rc.d/rc.laptop-mode stop
@Rava
i would like to avoid quirks as they may work for one hardware but not for other. disabling flash HW accel globally is a bad idea as probably only small percentage of nVidia users are affected by this bug. you need to fix this issue locally. try to add:

Code: Select all

"OverrideGPUValidation=true"
to mms.cfg as per:
https://bugs.launchpad.net/ubuntu/+sour ... bug/967091

@neko
confirmed this bug and will be downgrading to modesetting-0.7.0
thanks a lot.

@all porteus users
brokenman is still on holiday and hamza just went on it but will try to push 2.1 final early next week. it's a last chance to report bugs so please do not hesitate to do it if you find them.

thanks
Please add [Solved] to your thread title if the solution was found.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#115 by Rava » 01 Aug 2013, 11:29

There is an issue, at least since 2.0 finale, and also in 2.1 rc1 and 2.1 rc2.

All versions: XFCe, x86-64
All systems with Dual Core CPU, nVidia card, 2.1 rc2 had nVidia-304.88-porteus-v2.1 driver.

The systems have either 3 GB of RAM or 3 1/2 GB of RAM (actually, that machine has technically 4 GB or RAM, but the BIOS only supports 3 1/2 GB, only the RAM tester that got shipped with older Porteus could see 4 GB of RAM and test all RAM, all other x86-64 Linux OS I tried so far only sees what BIOS tells them: 3 1/2 GB, and not 4 GB... Is there a startup tweak that could tell Porteus that there is 4 GB of RAM?)

Anyhow, back to the bug.
As you can see above, the hardware is quite well equipped, and usually the system runs just fine.
But at times, when I open, like, 3 or such new tabs in FFx, the whole system freezes. All I could do this time it happened, was pressing CTRL+ALT+F8, this gets me to my virtual console 8 (yes, I tweaked Porteus so that I have the virtual terminals 1-6 and 8-12, since we all have these Fx keys on our keyboards...)
When log into "virtual terminal 8" as root, this is run there via my own /etc/profile.local :

Code: Select all

tail -fn 25 /var/log/messages
So, I get to see the most recent /var/log/messages, even when X is no longer reacting.

I could upload the camera made screenshot, but there is nothing interesting to see:

Code: Select all

August  1 09:45:31 porteus -- MARK --
August  1 10:05:52 porteus acpid: client 1996[0:1000] has disconnected
August  1 10:08:58 porteus acpid: client 1996[0:1000] has disconnected 
The freeze happened approx between 10:00 and 10:05 ...
I tried to kill FFx via virtual console, but all I typed in any of the open and running virtual consoles was not even showing as I typed it, even after waiting for some time; and sure was not executed.
The USB stick that has the Porteus files on it started blinking continuously, even after I shut down the PC with pressing the Power Button >4 seconds the USB stick still was blinking continuously, only after I pulled it out and plugged it into again (it was connected via a 4 port USB hub) the USB stick stopped blinking, starting Porteus anew went just fine... (I am typing from that very machine / the very same USB Porteus media)

What can I do to capture more interesting logs to investigate this freezing behaviour better? Or will there be none, since /var/log/messages shows nothing...
Cheers!
Yours Rava

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#116 by fanthom » 02 Aug 2013, 17:37

@Rava
looks like a GPU driver bug. please try to recreate and save /var/log/dmesg and /var/log/Xorg.0.log somewhere then upload to pastebin.com.
you could also try to recreate it using nouveau to confirm it's nVidia driver fault.
Please add [Solved] to your thread title if the solution was found.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#117 by Rava » 02 Aug 2013, 21:17

fanthom wrote:looks like a GPU driver bug. please try to recreate and save /var/log/dmesg and /var/log/Xorg.0.log somewhere then upload to pastebin.com.
you could also try to recreate it using nouveau to confirm it's nVidia driver fault.
How could I put only these files on my USB stick, while the system is running?
Cause trying to save them when it freezes might again fail...

I know there is one console program that could split one file on the terminal's screen, and also in a different file, but I forgot which one that was, or which parameter did the trick...
Cheers!
Yours Rava

n2prtsusr
White ninja
White ninja
Posts: 14
Joined: 12 Nov 2012, 02:33
Distribution: Porteus 2.1 lxde 130809
Location: us

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#118 by n2prtsusr » 03 Aug 2013, 05:46

Is there a way to disable the screen blanking after 10 minutes,
or a setting in mplayerto override while mplayer is used?
I saw kiosk has the ability to override blanking, wondering if possible.
I don't use changes, I recreate module with setting in it.
I've been trying different types of settings the last couple of days.
The last thing I can come up with is a shortcut on desktop to change
the setting for blanking(have not done this yet), but would like to know
if there is a more permanent way of changing the setting

thanks in advance

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#119 by fanthom » 03 Aug 2013, 07:54

@Rava
i thought you could switch to VT2 -> login as root -> copy them on your stick?

@n2prtsusr
DPMS is enabled by default so you could create /etc/X11/xorg.conf (run 'xconf' script in runlevel 3) and then add "DPMS" "false" in monitor section or (in case you are using porteus on different PCs) edit /opt/porteus-scripts/xorg/gui-autostart and add following code:

Code: Select all

xset -dpms
xset s 0
Please add [Solved] to your thread title if the solution was found.

n2prtsusr
White ninja
White ninja
Posts: 14
Joined: 12 Nov 2012, 02:33
Distribution: Porteus 2.1 lxde 130809
Location: us

Re: Feedback and Bug Reports for Porteus v2.1 RC2

Post#120 by n2prtsusr » 03 Aug 2013, 17:46

@fanthom

PERFECT!
Thank you VERY much

Post Reply