Problem with bulgarian phonetic layout

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
Shnureaga
Ronin
Ronin
Posts: 2
Joined: 04 Jul 2013, 13:23
Distribution: Porteus v2.0 32-bit Razor-qt
Location: Bulgaria

Problem with bulgarian phonetic layout

Post#1 by Shnureaga » 04 Jul 2013, 13:41

Hi, i am new to Porteus, but i like it very much and i can tell that in one week it became my favorite home OS :) I double boot WIN7 + Porteus, but lately it is a lot more of this awesome and blazing fast and simple OS :) So...

I tried to install and use my language layout - bulgarian phonetic but with no luck. The point is that there are 2 variants but none of them works. There are 2 kinds of entering letters in bulgarian - BDS and PHONETIC, but even i choose the phonetic it works as BDS. PLease help, i need to can write in my phonetic, because starting to learn BDS will sound like to sit in front of PC for the first time in my life :D

http://prikachi.com/images/750/6293750g.jpg
http://prikachi.com/images/751/6293751e.jpg

I have a little experience with linux and looked over the internet for solution but no luck...

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Problem with bulgarian phonetic layout

Post#2 by francois » 04 Jul 2013, 23:09

Welcome on the porteus forum. :D

With the terminal (in command mode) use the following command:

Code: Select all

setxkbmap bg
This should make the job. Than, just make a script of it. And put it in the autostart folder, so that you get the correct keyboard layout automatically at bootup.

If you have further questions just ask them. We wil happily provide some answers.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Problem with bulgarian phonetic layout

Post#3 by brokenman » 05 Jul 2013, 00:45

The Qxkb is a little buggy but it was the best choice of a bad set of options. Using setxkb as described will upset qxkb (The flag may not change) but it should work.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Shnureaga
Ronin
Ronin
Posts: 2
Joined: 04 Jul 2013, 13:23
Distribution: Porteus v2.0 32-bit Razor-qt
Location: Bulgaria

Re: Problem with bulgarian phonetic layout

Post#4 by Shnureaga » 05 Jul 2013, 00:55

Yes, exactly. With a friend we struggled a lot and after 2-3 reinstalls i can write in phonetic, but the damn flag is not present anymore.... the icon is just US or BG, but not the flag of the language.... ?!

It is not a big deal but it is annoying and makes me angry....... are you bulgarians? the two who answered me?

User avatar
francois
Contributor
Contributor
Posts: 4901
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Problem with bulgarian phonetic layout

Post#5 by francois » 06 Jul 2013, 03:49

I am quebecer (speaking french) from Canada (Québec). I had some issues from time to time with being able to access what we call the canadian multilingual (bilingual) keyboard. setxkbmap ca command saved my life for years. I do not know hungarian.

Salut. :)

Edit: Don't care so much about the flag. Usually once booted up the flag does not correspond when I use setxkbmap in the autostart folder. However, after a few toggle between us and ca keyboard it will be concordant with the flag.
Voltaire: Le mieux est l'ennemi du bien.

Post Reply