Default keyboard layout

Non release banter
Post Reply
User avatar
Distorted
White ninja
White ninja
Posts: 5
Joined: 12 Jan 2011, 18:41
Location: Belgium

Default keyboard layout

Post#1 by Distorted » 19 Jan 2011, 16:41

Is it possible to change the default keyboard layout? I hate to change the layout every time i boot up.

User avatar
francois
Contributor
Contributor
Posts: 4937
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Default keyboard layout

Post#2 by francois » 19 Jan 2011, 16:49

From memory, in the control panel, right click on the us flag. Then go into configure to get panels, the right one being permitting changes of the keyboard options. Delete or use arrows provided to get you preffered keyboard on top.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
Distorted
White ninja
White ninja
Posts: 5
Joined: 12 Jan 2011, 18:41
Location: Belgium

Re: Default keyboard layout

Post#3 by Distorted » 19 Jan 2011, 19:14

Did you now just explain how to change the layout? Basically i want to set my settings in a way that when i even use the Always Fresh option on startup it uses the keyboad layout i want it to use.

crashman
Contributor
Contributor
Posts: 118
Joined: 28 Dec 2010, 17:03
Location: Poland

Re: Default keyboard layout

Post#4 by crashman » 19 Jan 2011, 20:09

@Distorted
You can use 'Language-selection-tool' - create your nationale.lzm package and put to base system.

User avatar
KSA_ARAB
Black ninja
Black ninja
Posts: 52
Joined: 29 Dec 2010, 00:54
Location: Saudi Arabia
Contact:

Re: Default keyboard layout

Post#5 by KSA_ARAB » 19 Jan 2011, 20:32

from terminal execute this and replace XX by your language layout

Code: Select all

setxkbmap -layout us,XX -option "grp:alt_shift_toggle"
then you can change by Alt+Shift.

or save this to execute it automatically when boot

Code: Select all

echo "setxkbmap -layout us,XX -option "grp:alt_shift_toggle"" >> /etc/rc.d/rc.local 

User avatar
Distorted
White ninja
White ninja
Posts: 5
Joined: 12 Jan 2011, 18:41
Location: Belgium

Re: Default keyboard layout

Post#6 by Distorted » 20 Jan 2011, 15:04

tnx alot :)

User avatar
wread
Module Guard
Module Guard
Posts: 1064
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: Default keyboard layout

Post#7 by wread » 22 Jan 2011, 02:31

Eleganter ist to save /mnt/live/memory/changes/root/.kde/share/kxkbrc in /mnt/sdxx/porteus/rootcopy/root/.kde/share/kxkbrc after you configure keyboards according to your taste!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
Toto
Ronin
Ronin
Posts: 2
Joined: 29 Dec 2010, 16:29
Location: France, MONT DE MARSAN

Re: Default keyboard layout

Post#8 by Toto » 22 Jan 2011, 13:57

wread wrote:Eleganter ist to save /mnt/live/memory/changes/root/.kde/share/kxkbrc in /mnt/sdxx/porteus/rootcopy/root/.kde/share/kxkbrc after you configure keyboards according to your taste!
You can also change this file after extracting KDE module and recreate this....

Personally, I use this solution to get a azerty keyboard with always fresh option.

User avatar
Blaze
Moderator
Moderator
Posts: 1383
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: Default keyboard layout

Post#9 by Blaze » 22 Jan 2011, 20:42

Open /root/.kde/share/config/kxkbrc

And edit it. For example:

Code: Select all

[Layout]
DisplayNames=us,ru
IndicatorOnly=false
LayoutList=us,ru
Model=pc104
ResetOldOptions=true
ShowFlag=true
ShowSingle=false
SwitchMode=Global
Use=true
Open /root/.kde/share/config/kdeglobals

Find

Code: Select all

"Switch to Next Keyboard Layout=..."
Replace with

Code: Select all

Switch to Next Keyboard Layout=Alt+Shift_L;Alt+Shift_R
Linux porteus 4.12.7-porteus #1 SMP PREEMPT Sun Aug 13 17:38:30 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
Distorted
White ninja
White ninja
Posts: 5
Joined: 12 Jan 2011, 18:41
Location: Belgium

Re: Default keyboard layout

Post#10 by Distorted » 23 Jan 2011, 19:42

I still have a problem with this subject, when i restart, even when i keep the changes, they layout is still wrong, when i look in the settings everything looks how it has to be but i have to reaply it in order for it to work.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Default keyboard layout

Post#11 by fanthom » 23 Jan 2011, 20:08

@Distorted
That's because KDE and LXDE settings overrides each other. Please remove one desktop or set the same settings for both.

Lxde: /root/.config/autostart/xkb.desktop
KDE-3: /root/.kde/share/config/kxkbrc
KDE-4: /root/.kde4/share/config/kxkbrc
Please add [Solved] to your thread title if the solution was found.

Post Reply