Feedback and Bug Reports for Porteus v2.1 RC1

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
User avatar
brokenman
Site Admin
Site Admin
Posts: 5455
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Feedback and Bug Reports for Porteus v2.1 RC1

Post#106 by brokenman » 05 Jul 2013, 23:07

Regarding the wget error on SSL, on mate-v2.1rc2 I don't get this error. I've installed ca-certificates and the self-signed certificate check now passes. While it is not ideal to use a self signed certificate (leaves one open to man in middle attack) it is commonly used because of ease of installation. The company in question (godaddy) has stringent checks in place when self signing.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: Feedback and Bug Reports for Porteus v2.1 RC1

Post#107 by Rava » 06 Jul 2013, 02:00

brokenman wrote:I've installed ca-certificates and the self-signed certificate check now passes.
Is it documented somewhere how to install them ? :)

___________________________________________________________
Hamza wrote:Thanks for providing the download link. According to my logs, you have chosen 32bit and not 64bit.
It took at times more than one mouse click till the part was visually activazed (like: printing)
But I selected x86-64 and then selected i586 and re-selected x86-64 several times, and in the end, at least the colour of the icon in the browser page told me I had x86-64 selected...

Using Porteus 2.0 x86-64, with FFx 22.0, used pbuild to upgrade FFx...
Hamza wrote:I have built an ISO using the same configuration than you and here is the link I'm getting:
Thanks a lot... but still... why the glitch when I try to create the module?
Cheers!
Yours Rava

User avatar
Saman
Black ninja
Black ninja
Posts: 32
Joined: 18 May 2013, 20:31
Distribution: Porteus 2.1 RC1 KDE / LXDE
Location: Iran

Re: Feedback and Bug Reports for Porteus v2.1 RC1

Post#108 by Saman » 06 Jul 2013, 03:49

brokenman wrote:
meanwhile, that patch was not useful for the lxde
Saman this was not a patch but a completely new lxde module. Please replace it with the old one. Can you confirm that you still get the errors after doing this and you are certain you are in a clean environment?

If you still have the errors please run the porteus-system-info from the menu or from console: xpsinfo and upload the log somewhere so we can take a look. Thanks for testing.
Sorry, That was my mistake, now it is working like a charm, thank you :)
All these, I can not bear to witness any longer. Can not the kingdom of salvation take me home?
-Cliff Burton R.I.P.-

User avatar
brokenman
Site Admin
Site Admin
Posts: 5455
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Feedback and Bug Reports for Porteus v2.1 RC1

Post#109 by brokenman » 06 Jul 2013, 03:53

Is it documented somewhere how to install them ?
Not yet. You can installpkg ca-certificates via slackyd. After that (if needed) you can update the ca-certificates: update-ca-certificates

I'm trying to recreate this bug on the build page, but i always get the correct link. Even after clicking many times between 64 and 32. Using Firefox 21.0 here.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Saman
Black ninja
Black ninja
Posts: 32
Joined: 18 May 2013, 20:31
Distribution: Porteus 2.1 RC1 KDE / LXDE
Location: Iran

Re: Feedback and Bug Reports for Porteus v2.1 RC1

Post#110 by Saman » 06 Jul 2013, 04:00

Ahau wrote:@Saman, the lack of mp3 support should be fixed in my RC1.5 module (as brokenman said, it's a replacement and not a patch, so the older module should be removed entirely -- my apologies for not being very clear on that). Also, what kind of crazy notifications are you getting from the volume + and - keys? I did add support for them (it was lacking previously) but it should open up a simple progress bar showing the current volume level. If possible, please try to get a screenshot of the error or let me know what the text was.
.
Dear Ahau,

Thanks for the update on LXDE :beer:
About those crazy notifications, no screenshot facility was provided via the previous version but as a result of that error I could see 3~4 notifications on the screen at once.
All these, I can not bear to witness any longer. Can not the kingdom of salvation take me home?
-Cliff Burton R.I.P.-

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: Feedback and Bug Reports for Porteus v2.1 RC1

Post#111 by Rava » 06 Jul 2013, 04:57

brokenman wrote:I'm trying to recreate this bug on the build page, but i always get the correct link. Even after clicking many times between 64 and 32. Using Firefox 21.0 here.
Dunno if it could be an issue of FFx 22.0..

I realized only in this version that all cache folders got moved from
/home/user/.mozilla/firefox/[random].default/ to /home/user/.cache/mozilla/firefox/[random].default/ :

Code: Select all

Cache  (directory)
OfflineCache (directory)
_CACHE_CLEAN_
safebrowsing (directory)
startupCache (directory)
thumbnails (directory)
But that should not alter FFx's behaviour..

Maybe the issue was because I used "Private Mode" (New Private Window) in FFx? (Sorry I forgot to tell you folks this small, but probably important part... :oops: )
Cheers!
Yours Rava

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Feedback and Bug Reports for Porteus v2.1 RC1

Post#112 by Hamza » 07 Jul 2013, 23:07

@Rava
Please try again.
NjVFQzY2Rg==

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: Feedback and Bug Reports for Porteus v2.1 RC1

Post#113 by Rava » 11 Jul 2013, 05:29

Hamza wrote:@Rava
Please try again.
Tried, and worked fine. :)
Cheers!
Yours Rava

Post Reply