Sound card issues

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
miguipda
Samurai
Samurai
Posts: 157
Joined: 12 Jun 2012, 18:21
Location: france

Sound card issues

Post#1 by miguipda » 26 Apr 2013, 16:50

Hi,

sorry to tell you that and also because I did wrote which text I got on the popup windows when it asked me the root password but I still lost my sound card.

Then after having reinstaled a new Porteus v2.0 64 bits because I previously lost my sound card I get it back working with a new installation (of course).
Even if I though it cames from some last installed modules. It appeared it was not the reason.

But now after having received a popup window I was so busy I spontaneously give the requested root password and since this moment I lost my sound card.

What work ?
This command line gives me this answer :
aplay -l | grep card
card 0: NVidia [HDA NVidia], device 0: ALC889A Analog [ALC889A Analog]
card 0: NVidia [HDA NVidia], device 1: ALC889A Digital [ALC889A Digital]
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]

The phonon Control Panel window show me the HDA NVidia as available and the two other are in grey.

The speakers works well by testing them with this command line :
speaker-test -Dplug:front -c2

I tried this method but it does not work.
http://www.linuxquestions.org/questions ... re-934598/

As my sound card is in grey I tried to use the alsactl to restore or initiate it. I can not select the sound card number then could not select it to get it back.

I also though it could be possible via the PSC. It said that some card are detected then it is not necessary to use this PSC sound card settings tool but if not working I must post a thread in this forum.
This is why I come back to ask the facility to manage sound cards on computers.

Sincerely thanks if you could help me to install back the driver of my sound cards.

Have a good night,

Miguipda :-)

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Sound card issues

Post#2 by fanthom » 26 Apr 2013, 17:28

please delete ~/.kde4/share/config/phonondevicesrc and reboot porteus.

also - how is it happening that you get these messages? is there any way of recreating this?
Please add [Solved] to your thread title if the solution was found.

miguipda
Samurai
Samurai
Posts: 157
Joined: 12 Jun 2012, 18:21
Location: france

Re: Sound card issues

Post#3 by miguipda » 27 Apr 2013, 16:01

Dear fanthom,

I removed the file you gave to me :
~/.kde4/share/config/phonondevicesrc

I reboot but still did not get back the sound.
Kmixer icon stay empty in the system tray bar and now the Phonon (via the System Settings - Multimedia window just display the first item "HDA NVidia" that was previously also avaiable (without sound).
It means it just removed the two next grey (unavailable) items (NVidia) in the list and I still did not get back sound.

Also - I was so quickly answer to the popup window (by giving the root password) I forgot how did I get it and then still could not reproduce the effect. I promise that if I may found it back I will tell you as soon as possible but I currently try to get back the sound.

And as said I do not know which command could I use (via PSC or PPM or command line) to get it back working.

I though that you could may be tell me which file could I copy (from somewhere) by considering the fact the sound works perfecty in Always Fresh mode.
I also thoug to delete the guest acount and create a new one but I also did not saw the kuser (in the System Settings window).
I then think it could be interresting you consider those two needs : user management and hardware (like sound cards) management in the System Settings windows.

I saty in touch by hoping you could tell me how getting back the sound (card).

Have a nice day,

Miguipda ;-)

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Sound card issues

Post#4 by fanthom » 27 Apr 2013, 23:35

unfortunately phonondevicesrc is the only config file i'm aware of which could fix your issue.
please rename .kde4 folder to .kde4-old and copy original one from /mnt/live/memory/images/004-kde.xzm then logout and login back. you'll loose your all kde4 settings but hopefully it will bring your sound back.

if that won help then you have to start again (no changes and no extra modules) and watch carefully which modules you are adding/which settings you are tweaking.
let us know if you find the reason.
Please add [Solved] to your thread title if the solution was found.

miguipda
Samurai
Samurai
Posts: 157
Joined: 12 Jun 2012, 18:21
Location: france

Re: Sound card issues

Post#5 by miguipda » 07 May 2013, 20:08

Hi,

sorry to tell you that but I made what you proposed (as renaming the current .kde4 to old name and copy from source).
After a reboot it well lost all my kde4 changes but never gave me back the sound.

I thing I still will need to reinstall all the porteus... :evil:
If I do that I will pay attention next time I will got the popup window that generate this error and will let you know it.

Have a good night,

Miguipda ;-)

miguipda
Samurai
Samurai
Posts: 157
Joined: 12 Jun 2012, 18:21
Location: france

Re: Sound card issues

Post#6 by miguipda » 06 Jun 2013, 21:02

Dear fanthom and other Porteus managers,

please be tolerant to this answer because as I already installed back three times my Porteus computer ;-) I do not really want to test if the popup windows I now received is well the reason of my sound card problem I previously had.

To remember you I previously explained I two times (on different installation) got a popup windows asking me the root password to make an action. I spontaneously answered because I trust Porteus but in those two times I gave the root password without check the proposed command it want to run.

As now I received a popup window I suspect to be the same message (because I just remember there was something like the same parameters shown here below) I let you know it could come from this but I do not really want to test it back otherwize I could need to install it back again.

The popup windows asked the root password to run the given command :
/usr/sbin/usermod -Glp guest

It came afte or during I was printing a file to a network printer connected in local to my router.

I do not really know what this could do but may be it could help you to know where came the problem.

Sincerely thanks and I hope I gave you a bug that could help other Porteus Users.

Have a good night,

Miguipda ;-)

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Sound card issues

Post#7 by brokenman » 07 Jun 2013, 02:09

Thanks. Looks like we may need to add guest to a group in order to print in some cases.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Sound card issues

Post#8 by Ahau » 07 Jun 2013, 06:10

hi miguipda,

What packages did you install and what else did you have to do in order to get your printer installed? This is a pretty serious bug somewhere in the works. Yes, I do believe guest needs to be added to the 'lp' group for Porteus. However -- the command you listed there, "/usr/sbin/usermod -Glp guest" is really, really bad and I'd like to track down the cause of it and get that reported upstream. When you run this command, it adds guest to the lp group but removes guest from every other group!

I checked, and one of the groups that guest normally belongs to is 'audio', and getting dropped from this group is almost surely why you were having troubles with your sound card (and lots of other stuff, I'm guessing).

Very nice catch on this! Hopefully this will be the end of your troubles.
Please take a look at our online documentation, here. Suggestions are welcome!

miguipda
Samurai
Samurai
Posts: 157
Joined: 12 Jun 2012, 18:21
Location: france

Re: Sound card issues

Post#9 by miguipda » 07 Jun 2013, 07:08

Dear Ahau,

please find here below the list of the installed packages.
I could say that HPLIP service is running because it stay in the systray panel (below at right on the desktop). May be is it it that check if all is ok and end the popup window.

If I well remember I just connected to the network printer by configuring the cups web page.

Have a nice day,

Miguipda ;-)

List of installed packages :
=======================

Code: Select all

-rw-r--r-- 1 root root      4096 May 12 15:42 002-xorg_130301-alldesktops.xzm
-rw-r--r-- 1 root root  25153536 May 12 15:43 006-firefox_130309-alldesktops.xzm
-rw-r--r-- 1 root root   9256960 Apr  1 13:06 PyQt-4.9.1-x86_64-3.xzm
-rw-r--r-- 1 root root  86339584 May 12 19:08 VirtualBox-4.2.12-Porteus-2.0-x64-full-1.xzm
-rw-r--r-- 1 root root   4378624 Apr  1 13:06 aaa_portlibs-2.0-x86_64-1ftm.xzm
-rw-r--r-- 1 root root    114688 Apr  1 13:06 aalib-1.4rc5-x86_64-3.xzm
-rw-r--r-- 1 root root  16576512 May 18 20:16 arduino-1.0.4-x86_64.xzm
-rw-r--r-- 1 root root    548864 Apr  1 14:29 aspell-0.60.6-x86_64-1.xzm
-rw-r--r-- 1 root root     86016 Apr  1 13:06 babl-0.1.10-x86_64-1.xzm
-rw-r--r-- 1 root root   7843840 Apr  1 13:27 boost-1.49.0-x86_64-3.xzm
-rw-r--r-- 1 root root   1167360 May 18 20:16 btsync-1.0.132-x86_64.xzm
-rw-r--r-- 1 root root     69632 Apr  7 14:35 celt-0.11.3-x86_64-1ponce.xzm
-rw-r--r-- 1 root root    643072 Apr  1 13:39 clucene-2.3.3.4-x86_64-1.xzm
-rw-r--r-- 1 root root   1875968 Apr  1 13:07 db44-4.4.20-x86_64-3.xzm
-rw-r--r-- 1 root root    131072 Apr  1 13:07 dbus-python-1.1.0-x86_64-1.xzm                                                                                                            
-rw-r--r-- 1 root root    217088 Oct 28  2012 dukto-5.0-x86_64-1prt.xzm                                                                                                                 
-rw-r--r-- 1 root root   4395008 Apr  7 14:35 ffmpeg-1.0.1-x86_64-2sl.xzm                                                                                                               
-rw-r--r-- 1 root root   1171456 Apr  1 14:02 fftw-3.2.2-x86_64-1.xzm                                                                                                                   
-rw-r--r-- 1 root root   3743744 Apr  1 14:58 geany-1.23-x86_64-1sl.xzm                                                                                                                 
-rw-r--r-- 1 root root    544768 Apr  1 13:07 gegl-0.2.0-x86_64-1.xzm                                                                                                                   
-rw-r--r-- 1 root root  11583488 Apr  1 13:07 ghostscript-9.05-x86_64-3.xzm                                                                                                             
-rw-r--r-- 1 root root  16646144 Apr  1 13:07 gimp-2.8.2-x86_64-1.xzm                                                                                                                   
-rw-r--r-- 1 root root   1552384 Apr  1 13:27 gst-plugins-base-0.10.36-x86_64-2.xzm                                                                                                     
-rw-r--r-- 1 root root   1662976 Apr  1 13:27 gstreamer-0.10.36-x86_64-1.xzm                                                                                                            
-rw-r--r-- 1 root root  13139968 Apr  1 13:08 hplip-3.12.9-x86_64-1.xzm                                                                                                                 
-rw-r--r-- 1 root root    118784 Apr  1 13:08 ilmbase-1.0.2-x86_64-1.xzm                                                                                                                
-rw-r--r-- 1 root root   6774784 Apr  1 14:02 imagemagick-6.7.7_10-x86_64-1.xzm
-rw-r--r-- 1 root root    155648 Apr  1 13:08 jasper-1.900.1-x86_64-3.xzm
-rw-r--r-- 1 root root   1294336 Apr  1 13:47 kdiff3-0.9.97-x86_64-1sl.xzm
-rw-r--r-- 1 root root    524288 Jul  8  2012 komparator-4:0.6-x86_64-1.xzm
-rw-r--r-- 1 root root    348160 Apr  1 13:53 krename-4.0.9-x86_64-2cf.xzm
-rw-r--r-- 1 root root   5058560 Apr  1 13:39 krusader-2.4.0_beta3-x86_64-1cf.xzm
-rw-r--r-- 1 root root     16384 Apr  1 13:27 libaio-0.3.109-x86_64-1.xzm
-rw-r--r-- 1 root root    237568 Apr  7 14:35 libdc1394-2.2.0-x86_64-2sl.xzm
-rw-r--r-- 1 root root   1363968 Apr  1 13:08 libgphoto2-2.4.14-x86_64-2.xzm
-rw-r--r-- 1 root root     36864 Apr  7 14:35 libgsm-1.0.13-x86_64-3sl.xzm
-rw-r--r-- 1 root root     57344 Apr  1 13:08 libieee1284-0.2.11-x86_64-3.xzm
-rw-r--r-- 1 root root    262144 Apr  1 13:27 libiodbc-3.52.7-x86_64-2.xzm
-rw-r--r-- 1 root root    118784 Apr  1 13:08 libnl-1.1-x86_64-1.xzm
-rw-r--r-- 1 root root 128045056 Apr  1 13:30 libreoffice-4.0.1-x86_64-1alien.xzm
-rw-r--r-- 1 root root    335872 Apr  1 13:30 libtheora-1.1.1-x86_64-1.xzm
-rw-r--r-- 1 root root    131072 Apr  1 13:30 libvisual-0.4.0-x86_64-3.xzm
-rw-r--r-- 1 root root    770048 Apr  1 13:08 libwmf-0.2.8.4-x86_64-5.xzm
-rw-r--r-- 1 root root    266240 Apr  1 14:29 lua-5.1.5-x86_64-3sl.xzm
-rw-r--r-- 1 root root   5165056 Apr  1 14:10 luckybackup-0.4.7-x86_64-1dj.xzm
-rw-r--r-- 1 root root    192512 Apr  1 13:30 mhash-0.9.9.9-x86_64-3.xzm
-rw-r--r-- 1 root root  18350080 Apr  1 13:31 mysql-5.5.29-x86_64-1_slack14.0.xzm
-rw-r--r-- 1 root root  29515776 Mar  7 15:42 nVidia-310.32-porteus-v2.0-x86_64-1ftm.xzm
-rw-r--r-- 1 root root    163840 Apr  1 13:31 neon-0.29.6-x86_64-2.xzm
-rw-r--r-- 1 root root   1454080 Apr  1 13:08 net-snmp-5.6.1-x86_64-5.xzm
-rw-r--r-- 1 root root     20480 Apr  1 13:08 notify-python-0.1.1-x86_64-3.xzm
-rw-r--r-- 1 root root   3055616 Apr  1 13:08 openexr-1.7.0-x86_64-1.xzm
-rw-r--r-- 1 root root  39374848 Apr  1 13:32 openjre-7u17_b02-x86_64-2sl.xzm
-rw-r--r-- 1 root root    192512 Apr  7 14:35 orc-0.4.16-x86_64-2sl.xzm
-rw-r--r-- 1 root root   1818624 Apr  1 13:57 p7zip-9.20.1-x86_64-1sl.xzm
-rw-r--r-- 1 root root   7847936 Apr  6 08:51 peazip-4.9.1-x86_64-1hz.xzm
-rw-r--r-- 1 root root    397312 Apr  1 13:08 pil-1.1.7-x86_64-2.xzm
-rw-r--r-- 1 root root    745472 Apr  1 14:29 podofo-0.9.1-x86_64-2ponce.xzm
-rw-r--r-- 1 root root     45056 Apr  1 13:08 pycairo-1.8.10-x86_64-2.xzm
-rw-r--r-- 1 root root    454656 Apr  1 13:08 pygobject-2.28.6-x86_64-2.xzm
-rw-r--r-- 1 root root   1961984 Apr  1 13:08 pygtk-2.24.0-x86_64-1.xzm
-rw-r--r-- 1 root root  12378112 Apr  1 13:08 python-2.7.3-x86_64-2.xzm
-rw-r--r-- 1 root root    356352 Apr  1 13:32 raptor2-2.0.8-x86_64-1.xzm
-rw-r--r-- 1 root root    294912 Apr  1 13:32 rasqal-0.9.29-x86_64-1.xzm
-rw-r--r-- 1 root root    307200 Apr  1 13:32 redland-1.0.15-x86_64-4.xzm
-rw-r--r-- 1 root root     94208 Apr  7 14:35 rtmpdump-2.4-x86_64-1gv.xzm
-rw-r--r-- 1 root root   3522560 Apr  1 13:08 sane-1.0.22-x86_64-5.xzm
-rw-r--r-- 1 root root    606208 Apr  7 14:35 schroedinger-1.0.11-x86_64-2sl.xzm
-rw-r--r-- 1 root root  48422912 Apr  1 14:30 scribus-1.4.2-x86_64-1sl.xzm
-rw-r--r-- 1 root root    409600 Apr  1 13:08 sip-4.13.2-x86_64-2.xzm
-rw-r--r-- 1 root root  50360320 Apr 12 14:57 skype_static-4.1.0.20-x86_64-3sl.xzm
-rw-r--r-- 1 root root    598016 Apr  1 13:39 soprano-2.7.6-x86_64-1.xzm
-rw-r--r-- 1 root root    528384 Apr  7 14:35 speex-1.2rc1-x86_64-2ponce.xzm
-rw-r--r-- 1 root root    438272 Apr  1 14:15 sudo-1.8.6p7-x86_64-1_slack14.0.xzm
-rw-r--r-- 1 root root   1146880 Apr  1 13:08 tcl-8.5.11-x86_64-1.xzm
-rw-r--r-- 1 root root   1155072 Apr  1 13:08 tk-8.5.11-x86_64-1.xzm
-rw-r--r-- 1 root root   2043904 Apr  1 14:15 truecrypt-7.1a-x86_64-2alien.xzm
-rw-r--r-- 1 root root     81920 Apr  7 14:35 vo-aacenc-0.1.2-x86_64-2sl.xzm
-rw-r--r-- 1 root root     69632 Apr  7 14:35 vo-amrwbenc-0.1.2-x86_64-2sl.xzm
-rw-r--r-- 1 root root  37040128 Jul  8  2012 xmind-3.2.1.201011212218-x86_64-1_SBo.xzm
-rw-r--r-- 1 root root   1720320 Apr  1 13:08 xsane-0.998-x86_64-2.xzm
Last edited by Hamza on 09 Jun 2013, 21:44, edited 1 time in total.
Reason: Added CODE tag

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Sound card issues

Post#10 by Ahau » 07 Jun 2013, 16:20

Yes, hplip appears to be the culprit:

https://bugs.launchpad.net/hplip/+bug/1112306
https://bugs.gentoo.org/show_bug.cgi?id=449272

I may have to create a customized patch to correct this in slackware, or it may have been fixed upstream by HP, so I'll check out the newer code from slackware -current to see if this has already been fixed.

Many thanks!
Please take a look at our online documentation, here. Suggestions are welcome!

miguipda
Samurai
Samurai
Posts: 157
Joined: 12 Jun 2012, 18:21
Location: france

Re: Sound card issues

Post#11 by miguipda » 08 Jun 2013, 10:18

Hi,

I just print now and realize when this popup windo appear.

When the printer was started and I still did not have print anything it display the popup window may be when the printer have finished to prapare itself.
Then I realized that I forgot to tell you this printer is also connected on the computer USB port in cas of the router on which this printer is connected by ethernet port is not running.

Have a nice day,

Miguipda ;-)

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Sound card issues

Post#12 by Hamza » 09 Jun 2013, 21:43

Please use CODE Tag.
NjVFQzY2Rg==

Post Reply