Disabling Screensaver doesn't work

Post bug reports related to either the kiosk ISO or the kiosk wizard here.
Post Reply
qbicdesign
White ninja
White ninja
Posts: 12
Joined: 24 Mar 2013, 20:40
Distribution: Ubuntu
Location: Estonia

Disabling Screensaver doesn't work

Post#1 by qbicdesign » 28 Mar 2013, 11:00

I ran the kiosk wizard, choosing to disable screensaver , but after 10 or 15mins of inactivity the screen goes blank - this seems to be the default behaviour in many distros.
How can I stop that from happening?

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Disabling Screensaver doesn't work

Post#2 by Ahau » 28 Mar 2013, 15:04

If you have access to a terminal inside your kiosk, run:

Code: Select all

xset q
and among the output you should see something like this:

Code: Select all

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Also check the DPMS settings there. You should be able to disable the screensaver with:

Code: Select all

xset s off
and turn off all dpms settings with:

Code: Select all

xset -dpms
see 'man xset' for more tips/options.

I haven't used kiosk much myself so I'm not sure if this would be the best solution (maybe fanthom or brokenman can jump in here) but I imagine you could write a script, such as /opt/noscreensaver, which would run the xset commands to disable the power settings you want off, and then add a .desktop file to the autostart directory for your user (or /etc/xdg/autostart for all users) that runs your /opt/noscreensaver script whenever x loads.

For some reason, at least some of the desktop environment power management tools seem to handle their settings independently of those you manage with xset, and I'm not really sure why that is. I've been meaning to look into it but other things have distracted me :)
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Disabling Screensaver doesn't work

Post#3 by brokenman » 29 Mar 2013, 02:25

Code: Select all

sed -i '/setterm/s/^/# /' $ktmp/003/etc/rc.d/rc.M
sed -i 's^/usr/sbin/acpid^#/usr/sbin/acpid^g' $ktmp/003/etc/rc.d/rc.M
Above is the codeblock for disabling screensaver in rc.M
It is disabling acpid and using setterm to disable.

During the wizard creation you can open a separate console (after screensaver option) and delve into /tmp/kiosk-creator/003 and add whatever you need to the file structure. You can enter an 003/etc/xdg/autostart command, an rc.local file or .desktop file.

EDIT: Fanthom has pointed out that xset is not available in the stock ISO so this would need to be added before adding the call in rc.M
How do i become super user?
Wear your underpants on the outside and put on a cape.

Andy
White ninja
White ninja
Posts: 10
Joined: 12 Aug 2013, 08:31
Distribution: Kiosk Edition 2.1
Location: Switzerland

Re: Disabling Screensaver doesn't work

Post#4 by Andy » 12 Aug 2013, 08:57

Sorry for my Nooby-Question..
Which file i have to change that this may work?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Disabling Screensaver doesn't work

Post#5 by fanthom » 12 Aug 2013, 10:18

this function is a part of 'power management' in 2.1 wizard so there is no need to enable it manually.
Please add [Solved] to your thread title if the solution was found.

Andy
White ninja
White ninja
Posts: 10
Joined: 12 Aug 2013, 08:31
Distribution: Kiosk Edition 2.1
Location: Switzerland

Re: Disabling Screensaver doesn't work

Post#6 by Andy » 12 Aug 2013, 12:42

Thank you for your feedback.
In the Wizard i chose to Disable DPMS.. Do I have to activate it?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Disabling Screensaver doesn't work

Post#7 by fanthom » 12 Aug 2013, 15:22

yes - disabling DPMS is key.
Please add [Solved] to your thread title if the solution was found.

my1002
White ninja
White ninja
Posts: 6
Joined: 10 Jul 2013, 07:39
Distribution: centos
Location: malaysia

Re: Disabling Screensaver doesn't work

Post#8 by my1002 » 19 Aug 2013, 05:30

I choose Disable DPMS in the wizard, but the screen goes blank after a few minutes...
Want to confirm, do i need to choose that option, or just use the default?

Post Reply