autoset KEYBOARD at boot

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
testsforknowledge
Black ninja
Black ninja
Posts: 42
Joined: 07 Jan 2013, 16:44
Distribution: PORTEUS
Location: slovenia

autoset KEYBOARD at boot

Post#1 by testsforknowledge » 28 Mar 2013, 06:56

everytime i boot, i have to click SLOVENIAN language, because we have y-z mixed on keyboard.
How to auto set this at boot?

in console it works with: (but icon beside clock does not change)
setxkbmap -model pc104 -layout si,si

cheatcode so far not working ...
kmap=si (placed in line APPEND in porteus.cfg, in section COPY2RAM from where i boot)

still trying, bit if someone has some idea ...

User avatar
francois
Contributor
Contributor
Posts: 4937
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: autoset KEYBOARD at boot

Post#2 by francois » 28 Mar 2013, 11:12

1) Here is my menu.lst:

Code: Select all

title porteus v10_32 on sda7/32bit_v12
kernel (hd0,6)/32bit_v12/boot/vmlinuz from_dev=/dev/sda7 from_dir=/32bit_v12/porteus changes=/mnt/sda7/32bit_v12/1.2_cfg toroot kmap=ca autoexec=xconf;telinit~4
initrd=(hd0,6)/32bit_v12/boot/initrd.xz
boot
If not there is a bug or si is not an option for kmap. Try in command line:

Code: Select all

root@porteus:~/Desktop# setxkbmap si
root@porteus:~/Desktop#

2) You can achieve the same result with command line or script ( e.g. here file called canadian-french.sh, with executable rights):
setxkbmap ca (for me)
setxkbmap si (for you)

Put the script in /root/.kde3/Autostart folder, so your keyboard settings be there at bootup.
Voltaire: Le mieux est l'ennemi du bien.

testsforknowledge
Black ninja
Black ninja
Posts: 42
Joined: 07 Jan 2013, 16:44
Distribution: PORTEUS
Location: slovenia

Re: autoset KEYBOARD at boot

Post#3 by testsforknowledge » 28 Mar 2013, 14:28

Does icon - flag of your country show? with me it works just FLAG stays US, not ours - Slovenian

i used:
APPEND initrd=/boot/initrd.xz vga=791 kmap=si lang=si copy2ram

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: autoset KEYBOARD at boot

Post#4 by Hamza » 28 Mar 2013, 15:10

You must be running X server in order to use 'setxkbmap' command.
NjVFQzY2Rg==

User avatar
fanthom
Site Admin
Site Admin
Posts: 4565
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: autoset KEYBOARD at boot

Post#5 by fanthom » 28 Mar 2013, 18:40

@testsforknowledge
this is a bug in qxkb application used in razor (brokenman is already aware of this afair). 'kmap=si' cheatcode will still work regardless of US flag being still shown in the sys tray so please stick to it.

@Hamza
'kmap=' cheatcode operates when Xorg session is active (part of /opt/porteus-scripts/xorg/paths)
Please add [Solved] to your thread title if the solution was found.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: autoset KEYBOARD at boot

Post#6 by brokenman » 29 Mar 2013, 02:34

Yes this is an upstream qxkb bug, but it was the lesser of evils regarding what's available. Please boot to Razorqt desktop without adding kmap cheat, then right click on the flag and choose to remove one language and add you own. Push it to the top of the list. Save your session via the Porteus Settings Centre and you should be good to go.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply