[SOLVED] Automount USB HDD - Does not work

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
miguipda
Samurai
Samurai
Posts: 157
Joined: 12 Jun 2012, 18:21
Location: france

[SOLVED] Automount USB HDD - Does not work

Post#1 by miguipda » 17 Mar 2013, 10:43

Hi,

in the new Porteus 2.0-64 when I connect a USB key it does not mount it automatically. Then I goes to the settings and for removable Devices I selected them (visible in the list when connected) as automount at connection.

But it does not work.

I also tried to mount in a terminal as root...
Does not work.

How to solve this really not interesting problem ... :-(

Sincerely thanks and have a nice day,

Miguipda ;-)

User avatar
fanthom
Site Admin
Site Admin
Posts: 4567
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Automount USB HDD - Does not work

Post#2 by fanthom » 17 Mar 2013, 10:56

which desktop (please fill this info in your profile so i wont have to ask this question again)?
is your flash stick formatted?
please post an error you are getting in terminal when trying to mount it as root and also output of 'dmesg | tail -n50'.

thanks
Please add [Solved] to your thread title if the solution was found.

miguipda
Samurai
Samurai
Posts: 157
Joined: 12 Jun 2012, 18:21
Location: france

Re: Automount USB HDD - Does not work

Post#3 by miguipda » 20 Mar 2013, 17:30

Hi,

here is the evolution of the problem.

1) When I insert a USB Key it create the good name on /media and the sdb1 exist on /dev
2) I created manually /mnt/sdb1 as root to mount it and I got this error :
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

3) When I use an external HDD with its own power supply then I could mount this kind of external HDD and be able to use it. But a simple USB Key can not be mounted automatically or manually.

Then I removed all my modules and tried again. Nothing changed.
Now I presume it comes from the fact I tried to install the possibility to write in chinese where I got a bad downloaded package and solved it succefully manually. But I am still not able to write chinese. And I currently try to solve this USB Key real problem. May be Ahau could tell me which files was maybe changed and I need to set it back to got this USB Key automoun/mount available.

Sincerely thanks for your help and have a good night.

Miguipda ;-)

==============

Following your remarks :
> which desktop (please fill this info in your profile so i wont have to ask this question again)?
I am on KDE

> is your flash stick formatted?
Of course I use it since many days and still work on Windoz

> please post an error you are getting in terminal when trying to mount it as root and also output of 'dmesg | tail -n50'.

Code: Select all

[   12.651611] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   12.651623] Bluetooth: BNEP filters: protocol multicast
[   12.651650] Bluetooth: BNEP socket layer initialized
[   13.259125] Adding 3148116k swap on /dev/sda3.  Priority:1 extents:1 across:3148116k 
[   13.643526] NET: Registered protocol family 10
[   34.892666] ata1.00: configured for UDMA/133
[   34.892684] ata1: EH complete
[   34.965212] EXT4-fs (sda1): re-mounted. Opts: commit=0
[   35.383197] EXT4-fs (sda4): re-mounted. Opts: commit=0
[  215.248051] usb 1-3: new high-speed USB device number 4 using ehci_hcd
[  215.364416] scsi6 : usb-storage 1-3:1.3
[  215.418461] usblp 1-3:1.1: usblp0: USB Bidirectional printer dev 4 if 1 alt 0 proto 2 vid 0x03F0 pid 0x5111
[  215.418588] usbcore: registered new interface driver usblp
[  216.368825] scsi 6:0:0:0: Direct-Access     HP       Photosmart 3210  1.00 PQ: 0 ANSI: 2
[  216.371181] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[  319.767126] sd 6:0:0:0: [sdb] 15659007 512-byte logical blocks: (8.01 GB/7.46 GiB)
[  319.768241] sd 6:0:0:0: [sdb] No Caching mode page present
[  319.768251] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[  319.770609] sd 6:0:0:0: [sdb] No Caching mode page present
[  319.770620] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[  319.793029]  sdb: sdb1
[  323.589707] FAT-fs (sdb1): Unrecognized mount option "iocharset=" or missing value
[  326.695700] FAT-fs (sdb1): Unrecognized mount option "iocharset=" or missing value
[  414.999336] sdb: detected capacity change from 8017411584 to 0
[  440.112716] sd 6:0:0:0: [sdb] 15659007 512-byte logical blocks: (8.01 GB/7.46 GiB)
[  440.113842] sd 6:0:0:0: [sdb] No Caching mode page present
[  440.113857] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[  440.116215] sd 6:0:0:0: [sdb] No Caching mode page present
[  440.116230] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[  440.128713]  sdb: sdb1
[  443.627274] FAT-fs (sdb1): Unrecognized mount option "iocharset=" or missing value
[  455.874716] usb 1-3: USB disconnect, device number 4
[  455.875178] usblp0: removed
[  483.863048] usb 1-6: new high-speed USB device number 5 using ehci_hcd
[  483.979789] scsi7 : usb-storage 1-6:1.0
[  484.984359] scsi 7:0:0:0: Direct-Access     ChipBank SD/MM Reader     4080 PQ: 0 ANSI: 2
[  484.986236] sd 7:0:0:0: [sdb] 15659008 512-byte logical blocks: (8.01 GB/7.46 GiB)
[  484.987243] sd 7:0:0:0: [sdb] Write Protect is off
[  484.987261] sd 7:0:0:0: [sdb] Mode Sense: 0b 00 00 08
[  484.988272] sd 7:0:0:0: [sdb] No Caching mode page present
[  484.988288] sd 7:0:0:0: [sdb] Assuming drive cache: write through
[  484.992215] sd 7:0:0:0: [sdb] No Caching mode page present
[  484.992226] sd 7:0:0:0: [sdb] Assuming drive cache: write through
[  484.993110]  sdb: sdb1
[  484.997233] sd 7:0:0:0: [sdb] No Caching mode page present
[  484.997244] sd 7:0:0:0: [sdb] Assuming drive cache: write through
[  484.997253] sd 7:0:0:0: [sdb] Attached SCSI removable disk
[  485.486684] FAT-fs (sdb1): Unrecognized mount option "iocharset=" or missing value
[  510.317332] FAT-fs (sdb1): Unrecognized mount option "iocharset=" or missing value
[  572.568102] FAT-fs (sdb1): Unrecognized mount option "iocharset=" or missing value
Last edited by Hamza on 20 Mar 2013, 18:15, edited 1 time in total.
Reason: Added CODE tag

User avatar
fanthom
Site Admin
Site Admin
Posts: 4567
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Automount USB HDD - Does not work

Post#4 by fanthom » 20 Mar 2013, 18:20

Code: Select all

[ 485.486684] FAT-fs (sdb1): Unrecognized mount option "iocharset=" or missing value
when you mount your stick "by hand" then you must either provide iocharset value or skip this option completely.
utf8 is default and it should support also chinese.
please create /tmp/usb and try to mount like that (without extra arguments):

Code: Select all

mount /dev/sdb1 /tmp/usb
btw: please show me output of 'cat /etc/fstab' and 'cat /proc/cmdline',
thanks
Please add [Solved] to your thread title if the solution was found.

miguipda
Samurai
Samurai
Posts: 157
Joined: 12 Jun 2012, 18:21
Location: france

Re: Automount USB HDD - Does not work

Post#5 by miguipda » 23 Mar 2013, 09:22

Hi,

I also tried via the USB port of my printer that was previously supported. I got the same error.
It means in Dolphin it display a red message on top telling : "Could not enter folder /media/55D6-3E1E." And underscore are added to this name each time it tries to mount it.

As previously explained I already manually created a folder on /called sdb1 to tried to mount it manually.
Then I tried the same test you ask me here by creating and mountng it to the /tmp/usb.
I got the same error :
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Please fin here the requested files content.

With pleasure to read you with a solution. ;-)

Have a nice day,


Miguipda ;-)


cat /etc/fstab

Code: Select all

# Do not edit this file as fstab is recreated automatically during every boot.
# Please use /etc/rc.d/rc.local or sysvinit scripts if you want to mount/unmount drive,
# filesystem or network share.

# System mounts:
aufs / aufs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
devtmpfs /dev devtmpfs defaults 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0

# Device partitions:
/dev/sda1 /mnt/sda1 ext3 noatime,nodiratime,suid,dev,exec,async 0 0
/dev/sda2 /mnt/sda2 ntfs noatime,nodiratime,suid,dev,exec,async 0 0
/dev/sda4 /mnt/sda4 ext4 noatime,nodiratime,suid,dev,exec,async 0 0

# Swap partitions:
/dev/sda3 none swap sw,pri=1 0 0



cat /proc/cmdline
quiet initrd=initrd.xz changes=/porteus  BOOT_IMAGE=vmlinuz

User avatar
fanthom
Site Admin
Site Admin
Posts: 4567
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Automount USB HDD - Does not work

Post#6 by fanthom » 23 Mar 2013, 09:43

@miguipda

i think this error is caused by old locales-*.xzm module generated by porteus-1.2.
please remove this old module and create new one in porteus-2.0.
if that wont help then please boot in 'always fresh' mode and check once again (some settings could persist in your changes).

note to everybody:
- when you upgrade between major porteus releases (1.x->2.x, 2.x -> 3.x) then you must upgrade your ALL existing modules.
you should also start with fresh save.dat as settings may not be compatible anymore.
- when you upgrade between minor porteus releases (2.x -> 2.x) then everything should work out of the box but still some incompatibility may happen.

thanks
Please add [Solved] to your thread title if the solution was found.

miguipda
Samurai
Samurai
Posts: 157
Joined: 12 Jun 2012, 18:21
Location: france

Re: Automount USB HDD - Does not work

Post#7 by miguipda » 27 Mar 2013, 18:31

Hi,

I all reainstalled to start with a new situation and then get it back working.

Have a giid night.

Miguipda ;-)

P.S. : You may then delete this post

Post Reply