[SOLVED] Automount USB stick

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
DilbertLinux
White ninja
White ninja
Posts: 12
Joined: 17 Jan 2011, 20:43
Location: USA

[SOLVED] Automount USB stick

Post#1 by DilbertLinux » 06 Mar 2013, 19:11

Is there a way to get Porteus 2.0 to auto mount USB flash drives that are plugged in after boot up?

Can't seem to find a way to do this.

Thanks
Last edited by DilbertLinux on 12 Mar 2013, 14:03, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Automount USB stick

Post#2 by fanthom » 06 Mar 2013, 19:21

hi DilbertLinux,

i'm guessing that are you booting with copy2ram cheatcode - is it?
if yes then please add 'noeject' cheatcode (read /boot/docs/cheatcodes.txt for description).

EDIT:\\
seems that i did not read initial post carefully enough :oops:
Please add [Solved] to your thread title if the solution was found.

DilbertLinux
White ninja
White ninja
Posts: 12
Joined: 17 Jan 2011, 20:43
Location: USA

Re: Automount USB stick

Post#3 by DilbertLinux » 06 Mar 2013, 19:39

I am booting from CD.

But I need to be able to plug a USB stick in and have it auto mount it so a program I am running can use it. Is a little pain to have to manually mount the USB stick each time I plug it in. (and this has to be used by some people that aren't use to Linux)

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Automount USB stick

Post#4 by brokenman » 06 Mar 2013, 21:13

Please post which desktop you are using (KDE4, Razor, LXDE or xfce) and we will be able to better assist you. For example KDE has an association with external drives and an option of what to do when they are plugged in. You can have an icon appear on the desktop or have it automount. At least this was the case in the 3.5x line.
How do i become super user?
Wear your underpants on the outside and put on a cape.

DilbertLinux
White ninja
White ninja
Posts: 12
Joined: 17 Jan 2011, 20:43
Location: USA

Re: Automount USB stick

Post#5 by DilbertLinux » 07 Mar 2013, 13:37

I am using the Razor desktop.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Automount USB stick

Post#6 by brokenman » 08 Mar 2013, 01:03

In that case spacefm (file manager) can handle the mounting. Please plugin your device and then click on the little mount icon in the bottom right panel to mount the device. Then open spacefm via the menu or by double clicking on a desktop icon. In the left column right click on the device you wish to have automounted and look under the mount options for the mount options. If you are saving your changes then this devices will always be automounted when it is plugged in.
How do i become super user?
Wear your underpants on the outside and put on a cape.

DilbertLinux
White ninja
White ninja
Posts: 12
Joined: 17 Jan 2011, 20:43
Location: USA

Re: Automount USB stick

Post#7 by DilbertLinux » 08 Mar 2013, 15:20

Since I am booting from a CD I don't save changes. Is there a away to tell spaceFM to auto mount any USB stick that is plugged into the machine?

Thanks for the responses

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Automount USB stick

Post#8 by brokenman » 09 Mar 2013, 00:37

I believe if you start spacefm as a daemon it will automount external devices:

Code: Select all

spacefm -d
http://ignorantguru.github.com/spacefm/ ... daemonmode

I can't confirm this until i return to my Razorqt desktop.
How do i become super user?
Wear your underpants on the outside and put on a cape.

DilbertLinux
White ninja
White ninja
Posts: 12
Joined: 17 Jan 2011, 20:43
Location: USA

Re: Automount USB stick

Post#9 by DilbertLinux » 12 Mar 2013, 14:02

Thanks for the info brokenman was able to figure out the issue. I boot into root and the udevil tool used to point things by spaceFM is not configure to let root mount drives. So I updated the udevil.config file to so allow_groups = plugdev, root
So now when the user plugs a USB stick into the computer it get auto mounted.

Thanks,
:D

Post Reply