Intel HD4000 Performance

Here you can post about your various experiences with PC hardware. You can also post about hardware that is not compatible with the linux kernel or not recommended for use with Porteus.
Post Reply
jesmith
Black ninja
Black ninja
Posts: 31
Joined: 16 Jan 2012, 18:48
Location: USA

Intel HD4000 Performance

Post#1 by jesmith » 27 Nov 2012, 19:26

I'm trying to get an Intel HD 4000 (Sandy Bridge) system performing well. Running Porteus 1.2, it is functional, but performance is terrible. (3D openGL stuff.) Looking at the Xorg.0.log file, I see that the intel drivers are 2.15.0, which corresponds to the Q1 2011 release from Intel. So my gut tells me the first thing I need to do is catch up to Q4 2012's software.

Is the right thing to do to download everything listed here http://intellinuxgraphics.org/2012Q4.html and try to get it to compile? Or is there some shortcut I can take?

Thanks in advance.
-Joshua

User avatar
fanthom
Site Admin
Site Admin
Posts: 4548
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Intel HD4000 Performance

Post#2 by fanthom » 27 Nov 2012, 19:39

he jesmith,

i have a bad news:
1) afaik SandyBridge has HD3000 (HD4000 sappeared in IvyBridge)
2) xf86-video-intel is responsible for 2D stuff while you need 3D driver for OpenGL so you would have to upgrade mesa package.
3) mesa upgrade is not possible without bumping other components like libdrm
4) we can't upgrade libdrm in porteus-1.2 as other 2D drivers wont compile against it

possible solutions:
a) wait on first RC of porteus-2.0 which will have mesa-8.0.4 and latest 2D drivers
b) try slax-7 and check performance on it as it has latest components already

sorry about that.

EDIT:\\
if you do not care about booting porteus on other PC's then you could take a risk and upgrade components mentioned in the posted link but i think xorg-server-1.9.5 may be too old for them anyway.
Please add [Solved] to your thread title if the solution was found.

jesmith
Black ninja
Black ninja
Posts: 31
Joined: 16 Jan 2012, 18:48
Location: USA

Re: Intel HD4000 Performance

Post#3 by jesmith » 27 Nov 2012, 19:49

Thanks so much for the quick response. Sounds like the first thing I need to do is test on the right hardware! (I was just assuming that the recent mobo I was using would have HD4K. D'oh!)

Then, after that, I'll see how bad it sucks (presumably, quite bad, but we'll see).

And if it does suck, then I'll grab Slax7, to see how performance is. I'm actually still using Slax in production, but I've been hoping to switch to Porteus because it has taken Tomas so long to migrate to new kernels and such. Kind of ironic that he's ahead of Porteus now :)

Any ETA for 2.0-RC?

jesmith
Black ninja
Black ninja
Posts: 31
Joined: 16 Jan 2012, 18:48
Location: USA

Re: Intel HD4000 Performance

Post#4 by jesmith » 27 Nov 2012, 20:49

I found Slax7 RC2, and determined that I was mistaken, and I *do* have ivybridge graphics hardware.

In Slax7 RC2, the performance issues are gone, and comparing the output of glxinfo, it is clear why. Whereas Porteus 1.2 says:

Code: Select all

OpenGL renderer string: Software Rasterizer
Slax7 RC2 says:

Code: Select all

OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Desktop x86/MMX/SSE2
So, what's the ETA for Porteus 2.0?

User avatar
Hamza
Warlord
Warlord
Posts: 1846
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Intel HD4000 Performance

Post#5 by Hamza » 27 Nov 2012, 21:26

fanthom wrote:few weeks
NjVFQzY2Rg==

Post Reply