[SOLVED] Disable tap-to-click?

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
AnarisBell
White ninja
White ninja
Posts: 5
Joined: 13 Nov 2012, 06:36
Distribution: Porteus 2.1
Location: Canada

[SOLVED] Disable tap-to-click?

Post#1 by AnarisBell » 13 Nov 2012, 06:46

Hi there everyone! I'm new to the whole Linux thing and have run through a ton of different distros to try to find one that works well with my old netbook. I think I've finally found that in Porteus, it's the only one that hasn't thrown an install error, or not worked with my Dell wifi adapter, or any other number of things.

My only thing now is, I can't seem to find how to disable tap-to-click on my touchpad. I looked through the other topics a bit and the how-to sections of the forum but can't find it. I'm writing a novel, and sometimes my palms will hit the touchpad while I'm typing and move my cursor in the middle of the sentence. This is a sad dealbreaker for me if I can't disable this, as it's driving me insane and I had it disabled on Windows and on other Linux distros. It's hopefully something simple I'm overlooking.

Thanks so much in advance for any help! :)
Last edited by AnarisBell on 20 Nov 2012, 00:35, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4616
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Disable tap-to-click?

Post#2 by fanthom » 13 Nov 2012, 23:51

hi AnarisBell,

please run in terminal 'synclient TapButton1=0'

if you are interested in disabling a touchpad completely then please run 'synclient TouchPadOff=1' command. if that wont help then please try 'rmmod psmouse'.

to reverse to original behaviour please run: 'synclient TapButton1=1', 'synclient TouchPadOff=0' or 'modprobe psmouse' accordingly.

Cheers
Please add [Solved] to your thread title if the solution was found.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5571
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Disable tap-to-click?

Post#3 by brokenman » 14 Nov 2012, 00:23

Let me know if this works out for you. There are various options including one to disable the touchpad while the keyboard is working and 3 seconds after you stop typing.
How do i become super user?
Wear your underpants on the outside and put on a cape.

AnarisBell
White ninja
White ninja
Posts: 5
Joined: 13 Nov 2012, 06:36
Distribution: Porteus 2.1
Location: Canada

Re: Disable tap-to-click?

Post#4 by AnarisBell » 20 Nov 2012, 00:32

Thanks so much for your replies! I haven't had time to work on my book the last few days so TBH I forgot about this thread! Oops :)
fanthom wrote:hi AnarisBell,

please run in terminal 'synclient TapButton1=0'
This actually worked perfectly, thanks so much! I won't need to do this after every reboot, will I?
brokenman wrote:Let me know if this works out for you. There are various options including one to disable the touchpad while the keyboard is working and 3 seconds after you stop typing.
But I'm curious about this setting, where would I find this?

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: [SOLVED] Disable tap-to-click?

Post#5 by Hamza » 20 Nov 2012, 14:38

Add it into /etc/rc.d/rc.local :)
NjVFQzY2Rg==

User avatar
brokenman
Site Admin
Site Admin
Posts: 5571
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: [SOLVED] Disable tap-to-click?

Post#6 by brokenman » 20 Nov 2012, 14:55

How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply