LMMS for 32bit

If you are looking for a specific 32-bit package and you can't find it in any of the 32-bit repos, please post a request for it here.
Post Reply
FrosTr
White ninja
White ninja
Posts: 7
Joined: 08 Nov 2012, 12:12
Location: Brasil

LMMS for 32bit

Post#1 by FrosTr » 08 Nov 2012, 12:31

I've tried to put LMMS unsuccessfully in Porteus 32bit, cause it always looks for glibc2.15, and when i installed it, my system broke.
if someone can create a module, it would be of much help

User avatar
wread
Module Guard
Module Guard
Posts: 1065
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: LMMS for 32bit

Post#2 by wread » 10 Nov 2012, 03:23

Hi FrosTr!
I compiled LMMS in 32-bit kde4; here is a snapshot.

The problem is that I don't know how to use it, so I can't say if it is ok. The first run caused my kwin to crash, although it recovers from it. It seems to me this application is not stable yet.
Image

Anyway I uploaded it to mediafire so you can download and test it. You will need Fourier-transform module version 3, which I also compiled besides lmms.

http://www.mediafire.com/?c216scwjc1f3d

Good luck!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

FrosTr
White ninja
White ninja
Posts: 7
Joined: 08 Nov 2012, 12:12
Location: Brasil

Re: LMMS for 32bit

Post#3 by FrosTr » 10 Nov 2012, 11:32

thank you very much! now i have all the apps i need, thanks!

User avatar
wread
Module Guard
Module Guard
Posts: 1065
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: LMMS for 32bit

Post#4 by wread » 25 Nov 2012, 16:28

Hi!
Regarding the crash of kwin I mentioned earlier, it was caused by a missing library: libartsc.so in my kde4-32-bits version.
This library was included in 004-tde of the Trinity edition, and was needed by other applications (gnome-mplayer for instance, contained in 002-xorg). So I made a patch to append 002-xorg with the missing library. Now gnome-mplayer plays and LMMS wont crash my kdm. Here is the patch: http://www.mediafire.com/?1rceok835q5l0o7

Now you can enjoy a stable LMMS, and your Gnome-player plays too! :D
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

Post Reply