NTFS "umlaut" problem - proper mount options needed?

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
att
Contributor
Contributor
Posts: 131
Joined: 28 Dec 2010, 17:09

NTFS "umlaut" problem - proper mount options needed?

Post#1 by att » 03 Oct 2012, 10:09

Hello,

I have a problem: When downloading files to an NTFS-Filesystem, I sometimes get an Error:

"ntfs-3g[3943]: Could not convert filename to Unicode: 'S02E20 - Die Mõnnerrunde.part3.rar': Invalid or incomplete multibyte or wide character "

What can I do to mount some NTFS-filesystem properly so all umlauts and special chars are going to be "just being used" - or - being converted properly?

Also, when mounting a Windows7 installation on /dev/sda1, it never seems to be able to display the umlauts correctly. "Startmenü" never appears under Linux as such,
"midnight commander" outputs: "Startmen??"

It's a german computer.
Any help?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: NTFS "umlaut" problem - proper mount options needed?

Post#2 by fanthom » 03 Oct 2012, 16:03

hi att,

try to use "Language setup" from "Porteus Settings Center" and choose "de_DE.utf8" as the system encoding then make sure you select "automount of Windows filesystems with localization support".
(iocharset applies to FATx/iso9660 only).

let me know if that helped.
Please add [Solved] to your thread title if the solution was found.

att
Contributor
Contributor
Posts: 131
Joined: 28 Dec 2010, 17:09

Re: NTFS "umlaut" problem - proper mount options needed?

Post#3 by att » 03 Oct 2012, 18:25

Nice, but how would I mount it manually to get this to work?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: NTFS "umlaut" problem - proper mount options needed?

Post#4 by fanthom » 03 Oct 2012, 20:25

@att

not sure what you mean...

please put localization module created by LST in your /porteus/modules and reboot.
after getting back to the GUI your NTFS partitions should display everything correctly.
Please add [Solved] to your thread title if the solution was found.

att
Contributor
Contributor
Posts: 131
Joined: 28 Dec 2010, 17:09

Re: NTFS "umlaut" problem - proper mount options needed?

Post#5 by att » 04 Oct 2012, 10:04

I mean I cannot reboot the machine, so I am trying to manually mount a NTFS partition so all special chars are displayed and handled correctly.
ntfs-3g /dev/sda1 /mnt/sda1 -o ...... -> what shall I do ?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: NTFS "umlaut" problem - proper mount options needed?

Post#6 by fanthom » 04 Oct 2012, 10:48

@att
if you cannot reboot the PC then please unpack the LST module to /tmp/work and copy it's content to '/'.
if you can exit GUI then please run 'init 3' -> login -> go back to GUI with 'init 4' command.

if you cannot exit GUI then just exit shell and open it again then run 'locale' and make sure it shows "de_DE.UTF-8".
if you get UTF-8 encoding then you can remount all ntfs partitions with

Code: Select all

mount -o remount /dev/sdXY
if you wont get UTF-8 encoding as default then you can still try to mount manually:

Code: Select all

ntfs-3g /dev/sdXY /mnt/sdXY -o locale=de_DE.UTF-8
but i doubt it will work so reeboot may be required.

Good luck!
Please add [Solved] to your thread title if the solution was found.

Post Reply