gimp 2.8.0

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
feng
Black ninja
Black ninja
Posts: 62
Joined: 18 Jan 2011, 15:51
Location: internet

gimp 2.8.0

Post#1 by feng » 12 Aug 2012, 08:47

Hi!

i am running porteus v1.2 XFCE.
i tried to install gimp 2.8.0, right now i have the following files in my modules directory.

aalib-1.4rc5-i486-3.xzm
babl-0.1.10-i486-1sl.xzm
ffmpeg-0.7.12-i686-1sl.xzm
gegl-0.2.0-i486-1sl.xzm
ghostscript-9.02-i486-1_slack13.37.xzm
gimp-2.8.0-i486-1.xzm
imlib2-1.4.5-i486-1sl.xzm
jasper-1.900.1-i486-3.xzm
rtmpdump-2.3-i686-1sl.xzm


i got error messages while i tried to load gimp:

Code: Select all

root@porteus:~# gimp
GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/exr-load.so' load error: libIlmImf.so.6: cannot open shared object file: No such file or directory
GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/exr-save.so' load error: libIlmImf.so.6: cannot open shared object file: No such file or directory
GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/ff-load.so' load error: libva-0.32.0.2.so.1: cannot open shared object file: No such file or directory
and a popup box:

Code: Select all

GLib version too old (micro mismatch)

GIMP requires GLib version 2.30.2 or later.

Somhow you or your software packager managed to install GIMP with an older GLib version.

Please upgrade to GLib version 2.30.2 or later.
and ckeck dependencies

Code: Select all

root@porteus:~# slackyd -d "gimp"

Checking gimp-2.8.0-i486-1: done.

Found 1 missing dependencies:
libpoppler-glib.so.8 required by:
 --> Package: gimp-2.8.0-i486-1 (/usr/lib/gimp/2.0/plug-ins/file-pdf-load)

Searching libpoppler-glib.so.8: nothing found.

Nothing to do.
it seems it's not possible to run gimp 2.8.0 ?

beny
Full of knowledge
Full of knowledge
Posts: 730
Joined: 02 Jan 2011, 11:33
Location: italy

Re: gimp 2.8.0

Post#2 by beny » 12 Aug 2012, 10:28

hi feng, you have to upgrade a lot of software to run gimp, so i think you can use the old gimp version and wait for the new porteus edition based on slackware 14 that have all the mentioned software at the last version.imho

feng
Black ninja
Black ninja
Posts: 62
Joined: 18 Jan 2011, 15:51
Location: internet

Re: gimp 2.8.0

Post#3 by feng » 12 Aug 2012, 14:42

hi beny, thanks.

User avatar
wread
Module Guard
Module Guard
Posts: 1096
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: gimp 2.8.0

Post#4 by wread » 12 Aug 2012, 20:22

@feng: Must it be 2.8.0? I have posted 2.6.11 that works ok on Porteus. Did you try it in XFace?
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

feng
Black ninja
Black ninja
Posts: 62
Joined: 18 Jan 2011, 15:51
Location: internet

Re: gimp 2.8.0

Post#5 by feng » 13 Aug 2012, 03:59

wread wrote:@feng: Must it be 2.8.0? I have posted 2.6.11 that works ok on Porteus. Did you try it in XFace?
hi wread,

i have tried gimp 2.6.11 the one you made that it can not open jpg file.


==========

i found gimp 2.6.11-3.txz from slackware have no problem to open jpg file.

Post Reply