slackyd: a simple but efficient package manager

Non release banter
User avatar
brokenman
Site Admin
Site Admin
Posts: 5574
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: slackyd: a simple but efficient package manager

Post#46 by brokenman » 06 Jan 2013, 12:15

PPM is also affcted. It will eventually find the right repo (it browses repos until it finds a working one). You can speed things up by opening /etc/ppm/slacky.conf and switching the order of REPO=
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
francois
Contributor
Contributor
Posts: 5080
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: slackyd: a simple but efficient package manager

Post#47 by francois » 23 Dec 2013, 02:21

rnport wrote:Slackyd is a great tool. But it does not give sizes of packages it is going to download. Is there any way to know the sizes? Also, can we save the list of required packages to download them later ?

Code: Select all

root@porteus:~# slackyd -w ruby

> ruby-1.9.3_p484-x86_64-1_slack14.0.txz
:: ruby (Interpreted object-oriented scripting language)
::
:: Ruby is an interpreted scripting language for quick and easy
:: object-oriented programming.  It has many features to process text
:: files and to do system management tasks (as in Perl).  It is simple,
:: straight-forward, and extensible.
::
:: Visit the Ruby project online at http://www.ruby-lang.org/
::
> Status: Not installed.
> Location: [slackware] ./patches/packages
> Size Compressed: 4552 KB
> Size Decompressed: 36220 KB
> Package conflict with: not available.
> Packages suggest: not available.
> Packages required: not available.
****************************************************************************************************************************************************************************
People working regularly with slackyd with deep knowledge or simply with good tricks with this wonderfull tool should give them here. I will then rearange the information in the first post of this thread.

Real thanks. :D
Voltaire: Le mieux est l'ennemi du bien.

User avatar
francois
Contributor
Contributor
Posts: 5080
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: slackyd: a simple but efficient package manager

Post#48 by francois » 09 May 2014, 01:24

The links to the packages of slackyd have been updated for porteus 3.0. Useful as a crude alternative to usm.
Voltaire: Le mieux est l'ennemi du bien.

Bogomips
Full of knowledge
Full of knowledge
Posts: 2563
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: slackyd: a simple but efficient package manager

Post#49 by Bogomips » 25 Jul 2014, 00:11

Question for Slackyd afficionados.
    1. USM made subdirectory for VLC and packages it depends upon:

      Code: Select all

      guest@porteus:~$ ls -1  vlc-2.1.4 
      guile-2.0.9-i486-1.txz
      libtasn1-3.6-i486-1_slack14.1.txz
      libunistring-0.9.3-i486-1.txz
      python-2.7.5-i486-1.txz
      tcl-8.6.1-i486-1.txz
      tk-8.6.1-i486-1.txz
      vlc-2.1.4-i486-1alien.txz
      
    2. Kate activated and has

      Code: Select all

      tcl-8.6.1-i486-1.txz
      tk-8.6.1-i486-1.txz
      
      in xzm. python-2.7.5-i486-1.xzm also activated, and followed by vlc-2.1.4-i486-1alien.xzm activation.
    3. slackyd -d reports:

      Code: Select all

      Found 6 missing dependencies:
      libgnome-keyring.so.0 required by:
       --> Package: NetworkManager-openvpn-0.9.8.4-i486-1ftm (/usr/libexec/nm-openvpn-auth-dialog)
       --> Package: NetworkManager-pptp-0.9.8.4-i486-1ftm (/usr/libexec/nm-pptp-auth-dialog)
      libaa.so.1 required by:
       --> Package: vlc-2.1.4-i486-1alien (/usr/lib/vlc/plugins/video_output/libaa_plugin.so)
      libcaca.so.0 required by:
       --> Package: vlc-2.1.4-i486-1alien (/usr/lib/vlc/plugins/video_output/libcaca_plugin.so)
      libgnutls.so.28 required by:
       --> Package: vlc-2.1.4-i486-1alien (/usr/lib/vlc/plugins/misc/libgnutls_plugin.so)
       --> Package: vlc-2.1.4-i486-1alien (/usr/lib/vlc/plugins/access/liblibvnc_plugin.so)
      libp11-kit.so.0 required by:
       --> Package: vlc-2.1.4-i486-1alien (/usr/lib/vlc/plugins/misc/libgnutls_plugin.so)
       --> Package: vlc-2.1.4-i486-1alien (/usr/lib/vlc/plugins/access/liblibvnc_plugin.so)
      libsmbclient.so.0 required by:
       --> Package: vlc-2.1.4-i486-1alien (/usr/lib/vlc/plugins/access/libaccess_smb_plugin.so)
      
      1. vlc-2.1.4-i486-1alien.xzm deactivated.
      2. Module containing vlc (+ dependencies) with browser plugin npapi (+ dependency gc-7.4.0-i486-1sl.txz) put together and activated:

        Code: Select all

        guest@porteus:~$ ls -1 *.txz
        gc-7.4.0-i486-1sl.txz
        guile-2.0.9-i486-1.txz
        libtasn1-3.6-i486-1_slack14.1.txz
        libunistring-0.9.3-i486-1.txz
        npapi-vlc-20140226-i486-1alien.txz
        vlc-2.1.4-i486-1alien.txz
        
        guest@porteus:~$ mkdir kte_vlc
        guest@porteus:~$ ls -1 *.txz|xargs -i tar xJf {} -C kte_vlc
        guest@porteus:~$ du -sh kte_vlc                            
        111M    kte_vlc
        guest@porteus:~$ sudo dir2xzm  kte_vlc kte_vlc.xzm
        
      3. slackyd -d reports:

        Code: Select all

        ...
        Checking usm-3.1.0-noarch-2: done.
        Checking utempter-1.1.5-i486-1: done.
        Checking util-linux-2.21.2-i486-6: done.
        Checking v4l-utils-0.9.5-i486-1ftm: done.
        Checking vamps-0.99.2-i486-1ftm: done.
        Checking vo-aacenc-0.1.3-i486-1ftm: done.
        Checking vo-amrwbenc-0.1.3-i486-1ftm: done.
        Checking vorbis-tools-1.4.0-i486-1ftm: done.
        Checking vte-0.28.2-i486-2: done.
        Checking wacomtablet-2.0-i486-1ftm: done.
        Checking wavpack-4.60.1-i486-1: done.
        Checking webfs-1.21-i486-1ftm: done.
        Checking wget-1.14-i486-2: done.
        ...
        
        Found 1 missing dependencies:
        libgnome-keyring.so.0 required by:
         --> Package: NetworkManager-openvpn-0.9.8.4-i486-1ftm (/usr/libexec/nm-openvpn-auth-dialog)
         --> Package: NetworkManager-pptp-0.9.8.4-i486-1ftm (/usr/libexec/nm-pptp-auth-dialog)
        
        Package vlc-2.1.4-i486-1alien does not feature among those being checked.
      4. Verified thru

        Code: Select all

        guest@porteus:~$ ldd /usr/lib/vlc/plugins/video_output/libaa_plugin.so
                linux-gate.so.1 (0xb7772000)
                libvlccore.so.7 => /usr/lib/libvlccore.so.7 (0xb766a000)
                libidn.so.11 => /usr/lib/libidn.so.11 (0xb7638000)
                libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0xb75ee000)
                librt.so.1 => /lib/librt.so.1 (0xb75e5000)
                libpthread.so.0 => /lib/libpthread.so.0 (0xb75ca000)
                libSM.so.6 => /usr/lib/libSM.so.6 (0xb75c2000)
                libuuid.so.1 => /lib/libuuid.so.1 (0xb75be000)
                libICE.so.6 => /usr/lib/libICE.so.6 (0xb75a5000)
                libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb7585000)
                libXau.so.6 => /usr/lib/libXau.so.6 (0xb7582000)
                libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb757b000)
                libdl.so.2 => /lib/libdl.so.2 (0xb7576000)
                libaa.so.1 => not found
                libslang.so.2 => /usr/lib/libslang.so.2 (0xb7455000)
                libm.so.6 => /lib/libm.so.6 (0xb7413000)
                libX11.so.6 => /usr/lib/libX11.so.6 (0xb72db000)
                libgpm.so.2 => /lib/libgpm.so.2 (0xb72d5000)
                libc.so.6 => /lib/libc.so.6 (0xb714a000)
                /lib/ld-linux.so.2 (0xb7773000)
                libncurses.so.5 => /lib/libncurses.so.5 (0xb70fc000)
                
        guest@porteus:~$ ldd /usr/lib/vlc/plugins/video_output/libcaca_plugin.so
                linux-gate.so.1 (0xb76f8000)
                libvlccore.so.7 => /usr/lib/libvlccore.so.7 (0xb75ef000)
                libidn.so.11 => /usr/lib/libidn.so.11 (0xb75bd000)
                libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0xb7573000)
                librt.so.1 => /lib/librt.so.1 (0xb756a000)
                libpthread.so.0 => /lib/libpthread.so.0 (0xb754f000)
                libcaca.so.0 => not found
                libslang.so.2 => /usr/lib/libslang.so.2 (0xb742e000)
                libncursesw.so.5 => /lib/libncursesw.so.5 (0xb73cd000)
                ....
                libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb6d32000)
                libnvidia-tls.so.304.121 => /usr/lib/tls/libnvidia-tls.so.304.121 (0xb6d2e000)
                libnvidia-glcore.so.304.121 => /usr/lib/libnvidia-glcore.so.304.121 (0xb5028000)
        
        guest@porteus:~$ ldd /usr/lib/vlc/plugins/misc/libgnutls_plugin.so
                linux-gate.so.1 (0xb77cf000)
                libvlccore.so.7 => /usr/lib/libvlccore.so.7 (0xb76c4000)
                libidn.so.11 => /usr/lib/libidn.so.11 (0xb7692000)
                libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0xb7648000)
                libm.so.6 => /lib/libm.so.6 (0xb7606000)
                libgnutls.so.28 => not found
                librt.so.1 => /lib/librt.so.1 (0xb75fc000)
                libz.so.1 => /lib/libz.so.1 (0xb75e6000)
                libp11-kit.so.0 => not found
                libdl.so.2 => /lib/libdl.so.2 (0xb75e1000)
                libpthread.so.0 => /lib/libpthread.so.0 (0xb75c6000)
                libnettle.so.4 => /usr/lib/libnettle.so.4 (0xb7595000)
                libhogweed.so.2 => /usr/lib/libhogweed.so.2 (0xb7568000)
                libgmp.so.10 => /usr/lib/libgmp.so.10 (0xb74fb000)
                libc.so.6 => /lib/libc.so.6 (0xb7370000)
                /lib/ld-linux.so.2 (0xb77d0000)
        
        guest@porteus:~$ ldd /usr/lib/vlc/plugins/access/liblibvnc_plugin.so
                linux-gate.so.1 (0xb771f000)
                libvlccore.so.7 => /usr/lib/libvlccore.so.7 (0xb7615000)
                libidn.so.11 => /usr/lib/libidn.so.11 (0xb75e3000)
                libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0xb7599000)
                libvncclient.so.0 => /usr/lib/libvncclient.so.0 (0xb757e000)
                libnsl.so.1 => /lib/libnsl.so.1 (0xb7562000)
                libpng14.so.14 => /usr/lib/libpng14.so.14 (0xb7537000)
                libm.so.6 => /lib/libm.so.6 (0xb74f5000)
                libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0xb74c0000)
                libresolv.so.2 => /lib/libresolv.so.2 (0xb74a6000)
                libssl.so.1 => /lib/libssl.so.1 (0xb7443000)
                libcrypto.so.1 => /lib/libcrypto.so.1 (0xb7285000)
                libgcrypt.so.11 => /lib/libgcrypt.so.11 (0xb7200000)
                libgpg-error.so.0 => /lib/libgpg-error.so.0 (0xb71fc000)
                libgnutls.so.28 => not found
                librt.so.1 => /lib/librt.so.1 (0xb71f3000)
                libz.so.1 => /lib/libz.so.1 (0xb71dc000)
                libp11-kit.so.0 => not found
                libdl.so.2 => /lib/libdl.so.2 (0xb71d7000)
                libpthread.so.0 => /lib/libpthread.so.0 (0xb71bd000)
                libnettle.so.4 => /usr/lib/libnettle.so.4 (0xb718c000)
                libhogweed.so.2 => /usr/lib/libhogweed.so.2 (0xb715e000)
                libgmp.so.10 => /usr/lib/libgmp.so.10 (0xb70f1000)
                libc.so.6 => /lib/libc.so.6 (0xb6f66000)
                libcrypt.so.1 => /lib/libcrypt.so.1 (0xb6f33000)
                /lib/ld-linux.so.2 (0xb7720000)
        
    So, what is it that causes slackyd to lose sight of vlc?
    Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
    NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

    User avatar
    brokenman
    Site Admin
    Site Admin
    Posts: 5574
    Joined: 27 Dec 2010, 03:50
    Distribution: Porteus v3.2rcX all desktops
    Location: Brazil
    Contact:

    Re: slackyd: a simple but efficient package manager

    Post#50 by brokenman » 26 Jul 2014, 12:37

    Could be the deeply buried libraries. Perhaps the slackyd binary has a -maxdepth for finding libraries. Update USM and try the same thing using it. There is no maxdepth.
    How do i become super user?
    Wear your underpants on the outside and put on a cape.

    Bogomips
    Full of knowledge
    Full of knowledge
    Posts: 2563
    Joined: 25 Jun 2014, 15:21
    Distribution: 3.2.2 Cinnamon & KDE5
    Location: London

    Re: slackyd: a simple but efficient package manager

    Post#51 by Bogomips » 28 Jul 2014, 01:20

    Background

    Code: Select all

    loop7     7:7    0  38.6M  1 loop /mnt/live/memory/images/kkk.xzm
    loop8     7:8    0   3.7M  1 loop /mnt/live/memory/images/kate_070714.xzm
    loop9     7:9    0     3M  1 loop /mnt/live/memory/images/kate-4.10.5-i486-1.xzm
    
    common Kate and K3B dependencies in module kkk.xzm.
      1. Slackyd hit upon same library as USM.
          1. slackyd -d reported:

            Code: Select all

            Found 8 missing dependencies:
            libgnome-keyring.so.0 required by:
             --> Package: NetworkManager-openvpn-0.9.8.4-i486-1ftm (/usr/libexec/nm-openvpn-auth-dialog)
             --> Package: NetworkManager-pptp-0.9.8.4-i486-1ftm (/usr/libexec/nm-pptp-auth-dialog)
            libpython2.7.so.1.0 required by:
             --> Package: alsa-lib-1.0.27.2-i486-1 (/usr/lib/alsa-lib/smixer/smixer-python.so)
             --> Package: kate-4.10.5-i486-1 (/usr/lib/kde4/pateplugin.so)
             --> Package: kate-4.10.5-i486-1 (/usr/lib/python2.7/site-packages/PyKate4/kate.so)
             --> Package: libxml2-2.9.1-i486-1 (/usr/lib/python2.7/site-packages/libxml2mod.so)
             --> Package: libxslt-1.1.28-i486-1 (/usr/lib/python2.7/site-packages/libxsltmod.so)
            libcups.so.2 required by:
             --> Package: gtk+2-2.24.20-i486-1 (/usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so)
            libnepomukutils.so.4 required by:
             --> Package: kate-4.10.5-i486-1 (/usr/bin/kwrite)
             --> Package: kate-4.10.5-i486-1 (/usr/bin/kate)
            ...
             --> Package: kwrite-4.12.3-i486-1ftm (/usr/bin/kwrite)
             --> Package: kwrite-4.12.3-i486-1ftm (/usr/lib/libkdeinit4_kwrite.so)
            libnepomuk.so.4 required by:
             --> Package: kate-4.10.5-i486-1 (/usr/bin/kwrite)
             --> Package: kate-4.10.5-i486-1 (/usr/bin/kate)
            ...
             --> Package: kwrite-4.12.3-i486-1ftm (/usr/bin/kwrite)
             --> Package: kwrite-4.12.3-i486-1ftm (/usr/lib/libkdeinit4_kwrite.so)
            libsoprano.so.4 required by:
             --> Package: kate-4.10.5-i486-1 (/usr/bin/kwrite)
             --> Package: kate-4.10.5-i486-1 (/usr/bin/kate)
             ...
             --> Package: kwrite-4.12.3-i486-1ftm (/usr/bin/kwrite)
             --> Package: kwrite-4.12.3-i486-1ftm (/usr/lib/libkdeinit4_kwrite.so)
            libspectre.so.1 required by:
             --> Package: okular-4.12.3-i486-1ftm (/usr/lib/kde4/okularGenerator_ghostview.so)
            libltdl.so.7 required by:
             --> Package: redland-1.0.16-i486-1 (/usr/lib/librdf.so.0.0.0)
            
            Dependency of interest:

            Code: Select all

            libspectre.so.1 required by:
             --> Package: okular-4.12.3-i486-1ftm (/usr/lib/kde4/okularGenerator_ghostview.so)
            
            • Fixing just Okular
              1. activate libspectre-0.2.7-i486-1.xzm
              2. slackyd -d reported:

                Code: Select all

                Found 5 missing dependencies:
                libgnome-keyring.so.0 required by:
                 --> Package: NetworkManager-openvpn-0.9.8.4-i486-1ftm (/usr/libexec/nm-openvpn-auth-dialog)
                 --> Package: NetworkManager-pptp-0.9.8.4-i486-1ftm (/usr/libexec/nm-pptp-auth-dialog)
                libgs.so.9 required by:
                 --> Package: libspectre-0.2.7-i486-1 (/usr/lib/libspectre.so.1.1.7)
                libmysqlclient.so.18 required by:
                 --> Package: perl-5.18.1-i486-1 (/usr/lib/perl5/vendor_perl/auto/DBD/mysql/mysql.so)
                libtk8.6.so required by:
                 --> Package: python-2.7.5-i486-1 (/usr/lib/python2.7/lib-dynload/_tkinter.so)
                libtcl8.6.so required by:
                 --> Package: python-2.7.5-i486-1 (/usr/lib/python2.7/lib-dynload/_tkinter.so)
                
              3. Dependency of interest:

                Code: Select all

                libgs.so.9 required by:
                 --> Package: libspectre-0.2.7-i486-1 (/usr/lib/libspectre.so.1.1.7)
                
          2. Current configuration:

            Code: Select all

            loop9     7:9    0  21.1M  1 loop /mnt/live/memory/images/Kate_110714.xzm
            loop10    7:10   0     3M  1 loop /mnt/live/memory/images/kate-4.10.5-i486-1.xzm
            loop11    7:11   0   3.7M  1 loop /mnt/live/memory/images/kate_070714.xzm
            loop12    7:12   0  38.6M  1 loop /mnt/live/memory/images/kkk.xzm
            loop13    7:13   0    12M  1 loop /mnt/live/memory/images/python-2.7.5-i486-1.xzm
            loop14    7:14   0   836K  1 loop /mnt/live/memory/images/spacefm-0.8.2-i486-1dj.xzm
            loop15    7:15   0  33.3M  1 loop /mnt/live/memory/images/kte_vlc.xzm
            
            where libspectre-0.2.7-i486-1.txz contained in module Kate_110714.xzm, and common Kate and K3B dependencies in module kkk.xzm.
          3. brokenman wrote:Could be the deeply buried libraries. Perhaps the slackyd binary has a -maxdepth for finding libraries. Update USM and try the same thing using it. There is no maxdepth.
            Slackyd found earlier unresolved dependency in library but missed the one which USM found for same library.
            1. Code: Select all

              root@porteus:/home/guest# usm -u usm
              ...
              WARNING: /etc/usm/usm.conf changed after package installation.
                --> Deleting /etc/usm/usm.conf
              ...
              Generating VLC plugins cache data...
              Package usm-latest-0.0-noarch-1.txz installed.
              
              • Code: Select all

                root@porteus:/home/guest# vi /etc/usm/usm.conf
                root@porteus:/home/guest# usm -u all
                root@porteus:/home/guest# usm -d
                Processing: ConsoleKit-0.4.5-i486-1
                Processing: MPlayer-r36573-i486-1ftm
                Processing: ModemManager-1.0.0-i486-2
                Processing: NetworkManager-0.9.8.8-i486-1
                ...
                Processing: usm-latest-0.0-noarch-1
                Processing: utempter-1.1.5-i486-1
                Processing: util-linux-2.21.2-i486-6
                Processing: v4l-utils-0.9.5-i486-1ftm
                Processing: vamps-0.99.2-i486-1ftm
                Processing: vo-aacenc-0.1.3-i486-1ftm
                Processing: vo-amrwbenc-0.1.3-i486-1ftm
                Processing: vorbis-tools-1.4.0-i486-1ftm
                Processing: vte-0.28.2-i486-2
                Processing: wacomtablet-2.0-i486-1ftm
                Processing: wavpack-4.60.1-i486-1
                Processing: webfs-1.21-i486-1ftm
                Processing: wget-1.14-i486-2
                ...
                Processing: zlib-1.2.8-i486-1
                ####################################
                libgs.so.9 => not found
                Required by: okular-4.12.3-i486-1ftm (/usr/lib/kde4/okularGenerator_ghostview.so)
                ####################################
                Searching  libgs.so.9:  found 2 packages.
                Choose a package to download or choose 'None' to neglect
                1) ghostscript-9.07-i486-2.txz  3) None
                2) ghostscript-9.07-i486-2.txz
                #? 2
                 The following packages are ready to download: 
                ghostscript-9.07-i486-2.txz [12.71 MB]
                
                 Press [r] to remove packages, [q] to quit, or enter to start downloading.
                
                • On the other hand slackyd -d reports:

                  Code: Select all

                  Found 1 missing dependencies:
                  libgnome-keyring.so.0 required by:
                   --> Package: NetworkManager-openvpn-0.9.8.4-i486-1ftm (/usr/libexec/nm-openvpn-auth-dialog)
                   --> Package: NetworkManager-pptp-0.9.8.4-i486-1ftm (/usr/libexec/nm-pptp-auth-dialog)
                  
                  Searching libgnome-keyring.so.0: found 1 package.
                  
                  Download libgnome-keyring-3.8.0-i486-1.txz [from slackware] ? [y/N] 
                  
                  Nothing was choosed.
                  
                1. Slackyd found libspectre dependency but missed libgs, the one that USM found.

                  Code: Select all

                  guest@porteus:~$ ldd /usr/lib/kde4/okularGenerator_ghostview.so
                          linux-gate.so.1 (0xb77d5000)
                          libokularcore.so.3 => /usr/lib/libokularcore.so.3 (0xb771d000)
                          libspectre.so.1 => /usr/lib/libspectre.so.1 (0xb7706000)
                          libkdeui.so.5 => /usr/lib/libkdeui.so.5 (0xb738c000)
                          libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xb735d000)
                          libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xb6ba1000)
                  	...
                          libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0xb617e000)
                          libm.so.6 => /lib/libm.so.6 (0xb613c000)
                          libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb6120000)
                          libgs.so.9 => not found
                          libSM.so.6 => /usr/lib/libSM.so.6 (0xb6117000)
                          libICE.so.6 => /usr/lib/libICE.so.6 (0xb60fe000)
                          libX11.so.6 => /usr/lib/libX11.so.6 (0xb5fc7000)
                  	...
                          libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb56d4000)
                          libstreams.so.0 => /usr/lib/libstreams.so.0 (0xb569a000)
                          libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb5541000)
                          libudev.so.0 => /lib/libudev.so.0 (0xb5532000)
                          libpcre.so.1 => /usr/lib/libpcre.so.1 (0xb54ef000)
                  
                  • Both Slackyd & USM did not scrutinise package vlc-2.1.4-i486-1alien:

                    Code: Select all

                    guest@porteus:~$ ldd /usr/lib/vlc/plugins/video_output/libaa_plugin.so
                    	  ...
                            libaa.so.1 => not found
                            ...
                    guest@porteus:~$ ldd /usr/lib/vlc/plugins/video_output/libcaca_plugin.so
                            ...
                            libcaca.so.0 => not found
                            ...
                    guest@porteus:~$ ldd /usr/lib/vlc/plugins/access/libaccess_smb_plugin.so
                            linux-gate.so.1 (0xb7742000)
                            libvlccore.so.7 => /usr/lib/libvlccore.so.7 (0xb764f000)
                            libidn.so.11 => /usr/lib/libidn.so.11 (0xb761d000)
                            libdl.so.2 => /lib/libdl.so.2 (0xb7603000)
                            libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0xb75b9000)
                            librt.so.1 => /lib/librt.so.1 (0xb75af000)
                            libm.so.6 => /lib/libm.so.6 (0xb756d000)
                            libpthread.so.0 => /lib/libpthread.so.0 (0xb7553000)
                            libsmbclient.so.0 => not found
                            libc.so.6 => /lib/libc.so.6 (0xb73c8000)
                            /lib/ld-linux.so.2 (0xb7743000)
                    
                    (Previous dependency requirements for vlc/plugins/misc/libgnutls_plugin.so and vlc/plugins/access/liblibvnc_plugin.so, being already satisfied in module kte_vlc.xzm.)
                Points in Question
                1. It is interesting to note that USM in 3.b, like slackyd previously, omits processing package vlc-2.1.4-i486-1alien. Surprise surprise both USM and Slackyd scrutinise 528 identical files and packages, verified by diff u s, where u and s are usm_srch.txt and slk_srch.txt stripped down to the bare lists respectively:

                  Code: Select all

                  usm -d > usm_srch.txt
                  slackyd -d > slk_srch.txt
                  • None of the packages making up kte_vlc.xzm are scrutinised:

                    Code: Select all

                      kte_vlc.txt
                    p11-kit-0.16.4-i486-1.txz
                    gnutls-3.2.15-i486-1.txz
                    gc-7.4.0-i486-1sl.txz
                    guile-2.0.9-i486-1.txz
                    libtasn1-3.6-i486-1_slack14.1.txz
                    libunistring-0.9.3-i486-1.txz
                    npapi-vlc-20140226-i486-1alien.txz
                    vlc-2.1.4-i486-1alien.txz
                    
                    cat kte_vlc.txt|xargs -i tar xJf {} -C kte_vlc
                    sudo dir2xzm  kte_vlc kte_vlc.xzm
                    root@porteus:/home/guest# activate p4/tmp/vlc_mod/kte_vlc.xzm
                    
                    loop13    7:13   0    12M  1 loop /mnt/live/memory/images/python-2.7.5-i486-1.xzm
                    loop14    7:14   0   836K  1 loop /mnt/live/memory/images/spacefm-0.8.2-i486-1dj.xzm
                    loop15    7:15   0  33.3M  1 loop /mnt/live/memory/images/kte_vlc.xzm
                    
                    although however vlc and npapi browser plugin running as normal.

                    One could speculate that packages bundled into a module somehow or other resist scrutiny. But then Okular is bundled into the 003-kde.xzm module. Or maybe a home-made module is missing out on something?
                    • Code: Select all

                      root@porteus:/home/guest# usm -u usm
                      Downloading: vercheck.txt  DONE
                      
                       An update is available for the usm database files.
                       Please run:  usm -u all 
                      
                       A new version of USM is available.
                       Would you like to download it now? [y/n]
                      Downloading: usm-latest-0.0-noarch-1.txz  DONE
                       Would you like to install it now? [y/n]
                      
                      Removing package /var/log/packages/usm-3.1.0-noarch-2...
                      ...
                      WARNING: /etc/usm/usm.conf changed after package installation.
                        --> Deleting /etc/usm/usm.conf
                      Does this mean usm.conf gets trashed over an update?
                      • Code: Select all

                        root@porteus:/home/guest# usm -d > t
                        1) ghostscript-9.07-i486-2.txz  3) None
                        2) ghostscript-9.07-i486-2.txz
                        #? 3
                         Press [r] to remove packages, [q] to quit, or enter to start downloading.root@porteus:/home/guest# ls -l t
                        -rw-r--r-- 1 root root 19881 Jul 27 15:12 t
                        
                        Would it be viable or would it work to put the process list on stdout, doing the results and interactive stuff on stderr? Would facilitate in providing a record.
                        • /var/log/packages contains 526 files, so seems clear both Slackyd and USM iterate through these items. It comes as no surprise that packages bundled into kte_vlc.xzm (See ii) are not among the items in this folder.
                        Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
                        NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

                        User avatar
                        brokenman
                        Site Admin
                        Site Admin
                        Posts: 5574
                        Joined: 27 Dec 2010, 03:50
                        Distribution: Porteus v3.2rcX all desktops
                        Location: Brazil
                        Contact:

                        Re: slackyd: a simple but efficient package manager

                        Post#52 by brokenman » 28 Jul 2014, 22:13

                        None of the packages making up kte_vlc.xzm are scrutinised:
                        Please check the contents of var/log/packages in this merged module.

                        When I ran USM (on a bare bones system) to get Alien's vlc just now it found all dependencies required including libcaca etc.

                        Code: Select all

                        The following packages are required. 
                        aalib-1.4rc5-x86_64-5.txz [156K]
                        dbus-python-1.2.0-x86_64-1.txz [124K]
                        dnspython-1.10.0-x86_64-1alien.tgz [232K]
                        foomatic-filters-4.0.12-x86_64-1.txz [80K]
                        gc-7.2d-x86_64-1.txz [236K]
                        ghostscript-9.07-x86_64-2.txz [13108K]
                        gnutls-3.1.25-x86_64-1_slack14.1.txz [2020K]
                        gst-plugins-base-0.10.36-x86_64-2.txz [1304K]
                        gstreamer-0.10.36-x86_64-2.txz [1332K]
                        guile-2.0.9-x86_64-1.txz [3068K]
                        gutenprint-5.2.9-x86_64-1.txz [2232K]
                        libaio-0.3.109-x86_64-1.txz [16K]
                        libcaca-0.99.beta18-x86_64-2.txz [528K]
                        libiodbc-3.52.8-x86_64-1_slack14.1.txz [260K]
                        libmtp-1.1.6-x86_64-1.txz [188K]
                        libunistring-0.9.3-x86_64-1.txz [400K]
                        libvisual-0.4.0-x86_64-3.txz [128K]
                        libvncserver-0.9.9-x86_64-2.txz [232K]
                        mariadb-5.5.37-x86_64-1_slack14.1.txz [21660K]
                        notify-python-0.1.1-x86_64-3.txz [20K]
                        pycairo-1.8.10-x86_64-2.txz [48K]
                        pycups-1.9.61-x86_64-1.txz [64K]
                        pycurl-7.19.0-x86_64-2.txz [52K]
                        pygobject-2.28.6-x86_64-2.txz [404K]
                        pygtk-2.24.0-x86_64-1.txz [1708K]
                        python-2.7.5-x86_64-1.txz [11868K]
                        qt-4.8.5-x86_64-2.txz [28204K]
                        samba-4.1.9-x86_64-1_slack14.1.txz [9924K]
                        tcl-8.6.1-x86_64-1.txz [2500K]
                        tk-8.6.1-x86_64-1.txz [1700K]
                        vlc-2.1.4-x86_64-1alien.txz [23660K]
                        xcb-util-keysyms-0.3.9-x86_64-1.txz [16K]
                        
                        Total size: 127 MB
                        Since the GUI relies on STDOUT in many areas switching this would be a large job. Interesting idea nonetheless.
                        If you want to log output try using tee: usm -d | tee /tmp/output 2>>/tmp/output
                        How do i become super user?
                        Wear your underpants on the outside and put on a cape.

                        User avatar
                        brokenman
                        Site Admin
                        Site Admin
                        Posts: 5574
                        Joined: 27 Dec 2010, 03:50
                        Distribution: Porteus v3.2rcX all desktops
                        Location: Brazil
                        Contact:

                        Re: slackyd: a simple but efficient package manager

                        Post#53 by brokenman » 29 Jul 2014, 20:44

                        Bogomips ... thank you and sorry. Today I had some time and went poking through the code to make sense out of what you said. It lead me to find a flaw in which system libraries were not being reported correctly. I saw that you thoroughly tested this and believed there must be something awry in the code. Your post was very complicated but I got my head around it eventually.

                        I installed openjre and then ran a dep check and it simply was not seeing this library. I found the reason and will push an update that addresses several bugs tonight or tomorrow. Thanks for testing.
                        How do i become super user?
                        Wear your underpants on the outside and put on a cape.

                        Bogomips
                        Full of knowledge
                        Full of knowledge
                        Posts: 2563
                        Joined: 25 Jun 2014, 15:21
                        Distribution: 3.2.2 Cinnamon & KDE5
                        Location: London

                        Re: slackyd: a simple but efficient package manager

                        Post#54 by Bogomips » 03 Sep 2014, 23:09

                        brokenman wrote:
                        None of the packages making up kte_vlc.xzm are scrutinised:
                        Please check the contents of var/log/packages in this merged module.
                        Suppose owe it to any novice newbies reading this thread to furnish the reply.

                        On further examination, using tar to explode the packages and untar all into the same directory, was just overwriting the previous inst.sh install script with the next. At the end, one was left with just the install script of the last package. On top of this dir2xzm, it became clear, was not invoking installpkg.

                        So, back to dimly remembered tutorial [HOWTO] Understanding Module Creation and Manipulation: Two Case Studies, second case and use of fakeroot directory.

                        Lo Maintenance Module Creation :)

                        Text File of Java Packages:

                        Code: Select all

                        Jav_310814.txt:
                        openjre-7u65_b32-i486-1alien.txz
                        rhino-1_7R4-i486-3sl.txz
                        icedtea-web-1.5.1-i486-1alien.txz
                        
                        Create Temporary Fakeroot Directory and Install:

                        Code: Select all

                        guest@porteus:~$ mkdir tmp.$$
                        guest@porteus:~$ ls -ld tmp.$$
                        drwxr-xr-x 2 guest guest 4096 Sep  3 20:11 tmp.2767/
                        
                        root@porteus:/home/guest# xargs -a Jav_310814.txt  -i installpkg --root tmp.2767 --terse {}                                                 
                        openjre-7u65_b32-i486-1alien: JavaTM Platform Standard Edition Runtime E [74M] 
                        rhino-1_7R4-i486-3sl: javascript library for java                        [9.2M]
                        icedtea-web-1.5.1-i486-1alien: Java Web Start browser plugin             [2.3M]
                        
                        Create Module and Activate:

                        Code: Select all

                        root@porteus:/home/guest# dir2xzm  tmp.2767  Jav_310814.xzm
                        Parallel mksquashfs: Using 1 processor
                        Creating 4.0 filesystem on Jav_310814.xzm, block size 262144.
                        [=========================================================================|] 1183/1183 100%
                        Exportable Squashfs 4.0 filesystem, xz compressed, data block size 262144
                                compressed data, compressed metadata, compressed fragments, compressed xattrs
                                duplicates are removed
                        Filesystem size 47229.73 Kbytes (46.12 Mbytes)
                                53.77% of uncompressed filesystem size (87832.04 Kbytes)
                        Inode table size 8546 bytes (8.35 Kbytes)
                                25.43% of uncompressed inode table size (33603 bytes)
                        Directory table size 10298 bytes (10.06 Kbytes)
                                49.12% of uncompressed directory table size (20964 bytes)
                        ...
                        root@porteus:/home/guest# activate Jav_310814.xzm
                        Updating shared library links:  /sbin/ldconfig
                        Updating KDE menu: kbuildsycoca4
                        root@porteus:/home/guest# rm -r tmp.2767
                        loop13    7:13   0  46.1M  1 loop /mnt/live/memory/images/Jav_310814.xzm
                        
                        guest@porteus:~$ ls -lh /var/log/packages/icedtea-web-1.5.1-i486-1alien
                        -rw-r--r-- 1 root root 1.5K Sep  3 16:48 /var/log/packages/icedtea-web-1.5.1-i486-1alien
                        
                        guest@porteus:~$ ls -lh /var/log/packages/openjre-7u65_b32-i486-1alien
                        -rw-r--r-- 1 root root 26K Sep  3 16:48 /var/log/packages/openjre-7u65_b32-i486-1alien
                        
                        AN UPDATE SCENARIO

                        Updating icedtea using usm:

                        Code: Select all

                        root@porteus:/home/guest# usm -g iced
                        
                        1) icedtea-web-1.4.1-i486-1alien.txz
                        2) icedtea-web-1.5.1-i486-1alien.txz
                        #? 2
                        Processing:   icedtea-web-1.5.1-i486-1alien.txz 
                        Ignored libraries: 
                        
                        Libraries required:  11
                        Libraries found in system: 11
                        Libraries to resolve: 0
                        
                        The following packages are required. 
                        icedtea-web-1.5.1-i486-1alien.txz [1352K]
                        Total size: 1 MB
                         Press [r] to remove packages, [q] to quit, or enter to start downloading.
                        
                        but using slackyd:

                        Code: Select all

                        guest@porteus:~$ slackyd -c p10/Por/slackyd.conf -g iced
                        
                        Searching iced: found 1 package.
                        
                        icedtea-web-1.5.1-i486-1alien.txz [from alien]
                        
                        *** icedtea-web-1.5.1-i486-1alien.txz: already installed.
                        
                        All packages available are installed.
                        Package is made available for download by usm, while slackyd informs that package already installed, but neither are able to say that package is up-to-date. Looks like usm doesn't check to see if package installed, while slackyd doesn't give option of downloading package. It would be good to be informed package installed and up-to-date, but all the same be left with option of downloading package.
                        Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
                        NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

                        User avatar
                        francois
                        Contributor
                        Contributor
                        Posts: 5080
                        Joined: 28 Dec 2010, 14:25
                        Distribution: kde xfce porteus manjaro kubun
                        Location: Enfin l'été, le changement climatique attendu: le soleil.

                        Re: slackyd: a simple but efficient package manager

                        Post#55 by francois » 04 Sep 2014, 10:43

                        Bogomips you are doing a real good job with your comparative study of slackyd and usm. This a great way to improve usm. Thanks.
                        Voltaire: Le mieux est l'ennemi du bien.

                        User avatar
                        francois
                        Contributor
                        Contributor
                        Posts: 5080
                        Joined: 28 Dec 2010, 14:25
                        Distribution: kde xfce porteus manjaro kubun
                        Location: Enfin l'été, le changement climatique attendu: le soleil.

                        Re: slackyd: a simple but efficient package manager

                        Post#56 by francois » 20 Mar 2016, 23:32

                        Trying to get slackyd going to retreive some packages, I get:

                        Code: Select all

                        bash-4.3# /usr/bin/slackyd -u all
                        Repository: slackware [www.slackware.at]
                        `- Downloading FILELIST.TXT [Connection timed out]       
                        Warning: cannot retreive all file (0/8). Trying next: nothing
                        
                        Suggestions appreciated. :)
                        Voltaire: Le mieux est l'ennemi du bien.

                        Jack
                        Contributor
                        Contributor
                        Posts: 1187
                        Joined: 09 Aug 2013, 14:25
                        Distribution: Porteus 3.2.rc5 Mate 64 bit
                        Location: Marysville, OHIO USA

                        Re: slackyd: a simple but efficient package manager

                        Post#57 by Jack » 21 Mar 2016, 00:10

                        I just install this one "slackyd-1.0.20110808-x86_64-2sl.xzm" and type slackyd -u all here is the output.

                        Code: Select all

                        root@porteus:/home/guest/Downloads# slackyd -u all
                        
                        Warning: package `LibreOffice_5.1.0.3_x86-64_en-US' isn't standard. Skipping.
                        Warning: package `LibreOffice_5.1.0.3_x86-64_helppack_en-US' isn't standard. Skipping.
                        Repository: slackware [ftp.nluug.nl]
                        `- Downloading FILELIST.TXT [100 % @ 478.8 KB/s]         
                        `- Downloading CHECKSUMS.md5 [100 % @ 335.8 KB/s]         
                        `- Downloading PACKAGES.TXT [100 % @ 285.9 KB/s]         
                        `- Downloading MANIFEST.bz2 [100 % @ 668.0 KB/s]         
                        >> Uncompressing MANIFEST.bz2: done.
                        `- Downloading patches PACKAGES.TXT [100 % @ 113.7 KB/s]         
                        `- Downloading patches MANIFEST.bz2 [100 % @ 643.4 KB/s]         
                        >> Uncompressing patches MANIFEST.bz2: done.
                        `- Downloading extra PACKAGES.TXT [100 % @ 31.6 KB/s]          
                        `- Downloading extra MANIFEST.bz2 [100 % @ 77.0 KB/s]          
                        >> Uncompressing extra MANIFEST.bz2: done.
                        Repository: slacky [darkstar.ist.utl.pt]
                        `- Downloading FILELIST.TXT [No route to host]           
                        
                        root@porteus:/home/guest/Downloads# 
                        
                        Don't know if this will help you.
                        I just like Slackware because I think it teach you about Linux to build packages where Ubuntu is like Windows you just install programs you want.

                        User avatar
                        francois
                        Contributor
                        Contributor
                        Posts: 5080
                        Joined: 28 Dec 2010, 14:25
                        Distribution: kde xfce porteus manjaro kubun
                        Location: Enfin l'été, le changement climatique attendu: le soleil.

                        Re: slackyd: a simple but efficient package manager

                        Post#58 by francois » 21 Mar 2016, 00:35

                        @jack:
                        I should have mentioned that I was in slackware current. I have to change /etc/slackyd/slackyd.conf and add # before the following line and additional repos after:

                        Code: Select all

                        # Official mirror is too slow...
                        #repository ftp://ftp.slackware.com/pub/slackware/slackware64-14.1/
                        #repository = http://www.slackware.at/data/slackware64-current/
                        repository = ftp://ftp.nluug.nl/pub/os/Linux/distr/s ... re64-14.1/
                        repository = http://sunsite.cnlab-switch.ch/ftp/mirr ... re64-14.1/
                        repository = ftp://ftp.slackware.no/pub/linux/slackw ... re64-14.1/
                        repository = ftp://ftp.slackware.at/slackware64-14.1/
                        repository = http://www.slackware.at/data/slackware64-14.1/

                        Code: Select all

                        # Official mirror is too slow...
                        repository = http://ftp.heanet.ie/mirrors/slackware/pub/slackware/slackware64-current/
                        
                        #Extra repositories:
                        # Slacky.eu
                        repository slacky = http://repository.slacky.eu/slackware64-14.1/
                        
                        It works now.
                        Voltaire: Le mieux est l'ennemi du bien.

                        User avatar
                        francois
                        Contributor
                        Contributor
                        Posts: 5080
                        Joined: 28 Dec 2010, 14:25
                        Distribution: kde xfce porteus manjaro kubun
                        Location: Enfin l'été, le changement climatique attendu: le soleil.

                        Re: slackyd: a simple but efficient package manager

                        Post#59 by francois » 27 Mar 2016, 15:39

                        Code: Select all

                        # Official mirror is too slow...
                        repository = http://ftp.heanet.ie/mirrors/slackware/pub/slackware/slackware64-current/
                        
                        #Extra repositories:
                        # Slacky.eu
                        repository slacky = http://repository.slacky.eu/slackware64-14.1/
                        
                        It works now.
                        Voltaire: Le mieux est l'ennemi du bien.

                        User avatar
                        francois
                        Contributor
                        Contributor
                        Posts: 5080
                        Joined: 28 Dec 2010, 14:25
                        Distribution: kde xfce porteus manjaro kubun
                        Location: Enfin l'été, le changement climatique attendu: le soleil.

                        Re: slackyd: a simple but efficient package manager

                        Post#60 by francois » 12 Jun 2017, 03:19

                        Updated first post for 14.2 or current mirrors. :)

                        If usm goes of this is the spare tire. 8)

                        If anyone can propose a better job on repositories, I'll take it. :)
                        Voltaire: Le mieux est l'ennemi du bien.

                        Post Reply