X11 forwarding is extremely slow in a KDE (TDE) session

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
kaz
White ninja
White ninja
Posts: 13
Joined: 07 Jul 2012, 02:21
Location: Japan

X11 forwarding is extremely slow in a KDE (TDE) session

Post#1 by kaz » 10 Jul 2012, 16:02

The following operation takes almost one minute in a KDE session:

Code: Select all

kaz@porteus:~$ ssh -Y kaz@192.168.2.1
Password: 
Last login: Wed Jul 11 00:35:01 2012 from 192.168.2.219
[kaz@ph ~]$ xterm
In an LXDE session or openbox session, the window of xterm appears immediately. When I tried Porteus-XFCE-v1.2-rc2-i486, and when I was using Porteus v1.1, there was no problem. So the problem of slow X11 forwarding is peculiar to KDE of Porteus v1.2.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5652
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: X11 forwarding is extremely slow in a KDE (TDE) session

Post#2 by brokenman » 11 Jul 2012, 02:43

Anyone with ssh server available that can confirm this?
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4623
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: X11 forwarding is extremely slow in a KDE (TDE) session

Post#3 by fanthom » 11 Jul 2012, 12:49

in my case xterm appeared immediately but kwin crashed:
link

steps to reproduce:
a) start porteus in any mode on your PC
b) enable X11 forwarding in /etc/ssh/sshd_config and start sshd
c) launch Porteus in Vbox and boot to Trinity desktop
d) while in vbox session: run 'ssh -X guest@xxx.xxx.xxx.xxx'
e) once logged in on a remote machine run 'xterm' command

result: xterm opens but kwin crashes and window decorations are gone.
same scenario works with LXDE desktop in virtual session.
Please add [Solved] to your thread title if the solution was found.

kaz
White ninja
White ninja
Posts: 13
Joined: 07 Jul 2012, 02:21
Location: Japan

Re: X11 forwarding is extremely slow in a KDE (TDE) session

Post#4 by kaz » 13 Jul 2012, 05:46

fanthom wrote:in my case xterm appeared immediately but kwin crashed:
Same here.

I tested this case using various ssh servers.

Server OS | Client in KDE | Client in LXDE
Arch Linux | Slow | Good
Vine Linux 6.0 | Slow | Good
Arch Linux 64bit | Slow | Good
Frenzy 1.2 | Slow | Good
Porteus 1.2 remote | KWin crashed | Good
Porteus 1.2 localhost | Good | Good

Posted after 4 hours 56 minutes 40 seconds:
I thought I would try another distro using Trinity to see if it has the same problem. But according to the distrowatch search, Porteus is the only distro which uses Trinuty. :shock: I will try some Debian based distro and apt-get install Trinity.

Posted after 8 hours 37 minutes 10 seconds:
I tested this on Debian 6.0 after installing Trinity Desktop environment. The results were all good.

Server OS | Client in TDE
Arch Linux | Good
Porteus 1.2 | Good

The TDE version installed to Debian 6.0 was 3.5.13, while that of Porteus is R 14.0.0[DEVELOPMENT].

Post Reply