[SOLVED] Xfce-v1.2 Time Zone can't be changed

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
sean
Contributor
Contributor
Posts: 144
Joined: 08 Jul 2012, 02:30
Distribution: Porteus v3.0 LXDE i486
Location: South Central PA, USA

[SOLVED] Xfce-v1.2 Time Zone can't be changed

Post#1 by sean » 08 Jul 2012, 13:54

Using Porteus Xfce-v1.2 and loving it on a USB stick.

However, I can find no way to set the time zone, therefore my panel time is UTC, but I'm in the usa EDT.

Thanks,

sean

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Xfce-v1.2 Time Zone can't be changed

Post#2 by Ahau » 08 Jul 2012, 17:18

Welcome, sean!

We've seen this happen on a few systems in the past (it happens on my android tablet as well, when I run my homebrewed Porteus-ARM on it). It seems that sometimes the local timezone isn't always picked up when the BIOS clock is set to UTC. Please open a Terminal and run these commands:

Code: Select all

su 
    #use 'toor' as the password
timeconfig
    #this will open an ncurses menu.  tell it your system clock is set to UTC, then select your local timezone
exit
    #drops you back to guest user
xfce4-panel -r
    #restarts the panel, now the clock should be right
Let me know if that works for you. If it does, I'll work on a script to handle this and build a module with the needed config files, and perhaps it could be included in future versions of porteus-settings-centre.

Thanks!
Please take a look at our online documentation, here. Suggestions are welcome!

sean
Contributor
Contributor
Posts: 144
Joined: 08 Jul 2012, 02:30
Distribution: Porteus v3.0 LXDE i486
Location: South Central PA, USA

Re: Xfce-v1.2 Time Zone can't be changed

Post#3 by sean » 08 Jul 2012, 22:38

Hello Ahau,

Thank you kindly for the quick response to my post.

I could very easily be "behind the times", so to speak,
because this is the response resulting from your
suggestion, using Terminal:

guest@porteus:~/Desktop$ su timeconfig
Unknown id: timeconfig
guest@porteus:~/Desktop$ su
Password:
root@porteus:~# timeconfig
/usr/sbin/timeconfig: line 84: /var/log/setup/tmp/utc: No such file or directory
root@porteus:~#
guest@porteus:~/Desktop$ gksudo timeconfig
bash: gksudo: command not found
guest@porteus:~/Desktop$ sudo
bash: sudo: command not found
guest@porteus:~/Desktop$

and this is the response using Super User Mode Terminal:

Password:
root@porteus:/home/guest# timeconfig
/usr/sbin/timeconfig: line 84: /var/log/setup/tmp/utc: No such file or directory
root@porteus:/home/guest#

I have no idea, being a pure layman. Your efforts are deeply appreciated, however,
however, please do not waste a lot of time on this for this one user.

Thanks Ahau,

sean

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Xfce-v1.2 Time Zone can't be changed

Post#4 by Ahau » 09 Jul 2012, 00:54

Sorry about that, sean. I tested this on my tablet before, and now I've had a chance to run it in 32-bit porteus. Please do the following:

Code: Select all

su
(enter password, toor)
mkdir -p /var/log/setup/tmp
timeconfig
(select Yes, then your timezone)
exit
xfce4-panel -r
Apparently /var/log/setup/tmp is missing for some reason, and it's needed in order for timeconfig to create the file 'utc' there. We'll need to look into this some more. Thanks for your time in reporting (and hopefully resolving) this bug!
Please take a look at our online documentation, here. Suggestions are welcome!

sean
Contributor
Contributor
Posts: 144
Joined: 08 Jul 2012, 02:30
Distribution: Porteus v3.0 LXDE i486
Location: South Central PA, USA

Re: Xfce-v1.2 Time Zone can't be changed

Post#5 by sean » 09 Jul 2012, 01:56

Okay :-) Ahau,

That worked very nicely. Thank you, Thank you.

This sure is a sweet system you folks have here. Finally I can take my computer with me anywhere.

Ahau, thanks again for putting out my fire so very quickly. You made my day!

sean

Seq_Res
Black ninja
Black ninja
Posts: 51
Joined: 17 Jan 2011, 02:07
Location: China

Re: Xfce-v1.2 Time Zone can't be changed

Post#6 by Seq_Res » 10 Jul 2012, 06:48

hi, Ahau,

In RC2, I use Orage globaltime to show the 'localtime' and keep the window in the 2nd workspace.
I thought it is a default of XFCE itself.

In the next version please include an archive manager which should be able to extract the .iso of porteus
itself. I always use the application in SalixOS Live, or ark in Debian to do such a job.

Abiword is nice, but it has some defects in copy-paste functions when used to process Chinese characters.
would you like to make it a separate .xzm so I can remove it from installed porteus ?

thank you very much !

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Xfce-v1.2 Time Zone can't be changed

Post#7 by Ahau » 12 Jul 2012, 15:04

Thanks, sean and Seq_Res!

@sean, I'm glad I was able to help -- no worries about my time on this. I figure for each person who reports a problem here, there are ten people who experience it but don't report it, so it's never just about getting the problem fixed for one person.

@Seq_Res,
If I understand correctly, your XFCE panel was always showing UTC time, and you'd have to open orage globaltime and set it to your local timezone, just to see the time where you are? If so, that should not be the default, but I think a few users are experiencing this. The panel should show your local time and you should be able to use orage globaltime to see other timezones. Unfortunately, systems with UTC clocks don't get their local zone shown and systems with localtime clocks don't seem to work properly with orage globaltime (it adjusts the time assuming the system is set to UTC). More on this below.

RE: an archive manager, I do want to improve on squeeze, and have considered file-roller as well, since it also has built-in compatibility with the thunar-archive-plugin, but it doesn't appear to handle extracting iso's -- that would be a useful tool for the GUI (currently I use the mloop CLI utility by brokenman, and copy files out of /mnt/loop). This is on my to-do list for V2.0.

RE: abiword -- I'll consider splitting this out as well -- it may make sense since brokenman is offering it as a standalone module already in 32-bits. This would allow me to use his module for 32-bit xfce, and only have to maintain the packages for 64-bit myself.

@all: Back on topic: utc/timezone configs. I've started a gtkdialog script that acts as a front end to the slackware 'timeconfig' script. My goal is to allow users with UTC clocks to easily configure their system to UTC and select a timezone, and save a module (if running without 'changes=') with those settings. Here's my work in progress:
(Link is deprecated -- go to the thread linked at the bottom of this post instead)

This is still experimental and has no icons yet, but seems to behave most of the time for me. One problem is that it doesn't update the clock in the menu for trinity or kde4, so clicking the "apply" button won't show you the correct time -- you'll have to click "OK", then log out and back in (unless someone knows the command to restart the panels -- I'm afraid I've been spending too much time in xfce lately!). Also, trinity and kde4 have settings to handle timezones already. I'm not sure if these are sufficient and/or easier to use than my script. If so, I could have the script open the appropriate tde/kde4 settings dialog, and copy those settings instead, and then my gtkdialog window would only open in lxde/xfce.

I did have one instance where I exited the program without clicking "OK" or "Cancel" (logged out of the Desktop Environment with it open) and it altered my system time (directly, rather than through the config files saved by this script) -- To fix that, I booted into my BIOS and adjusted it back. Consider yourself warned if you are nervous about entering your BIOS... but otherwise, I'd love for folks to test this out and let me know if it works and if they like it. To use it, download the script somewhere (/tmp will do), make it executable with 'chmod +x porteus-timeconfig', and run it as root: 'ktsuss /tmp/porteus-timeconfig'. Enter the root password (toor) into ktsuss, and then adjust your settings according to the instructions.

Thanks!

Posted after 1 day 22 hours 17 minutes 10 seconds:
I've updated my script and published a module, see this thread: http://porteus.org/forum/viewtopic.php?f=53&t=1389

I'm moving the discussion about this utility over there, and marking this thread as [SOLVED].

Thanks!
Please take a look at our online documentation, here. Suggestions are welcome!

Post Reply