So, how would I disable wicd-client.py?

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
User avatar
TheDoctor
White ninja
White ninja
Posts: 14
Joined: 03 Sep 2011, 21:15
Location: I am everywhere.
Contact:

So, how would I disable wicd-client.py?

Post#1 by TheDoctor » 27 Jun 2012, 02:28

As part of a project, I am trying to figure out how to prevent the wicd-client.py utility from running when the desktop starts up. Disabling the wicd utility daemon was as easy as editing /etc/rc.d/rc.M, but now when the desktop starts the user is presented with an error window asking to run the wicd daemon as root. This is bad because it breaks the user experience.

I have tried editing the /etc/xdg/autostart/wicd-tray.desktop file to add the "Hidden=true" attribute (and booted with the nonetwork cheat code) but that does not seem to do anything in the default KDE Trinity environment. I have also tried wiping that file's contents and deleting it entirely, but those do not seem to work, either (they were tested by logging out and back in again, incidentally, and not rebooting).

Doing a recursive grep of all of the files in /home/guest on the case-insensitive string '*wicd*' did not turn anything up. Nor did grepping files under /usr, /etc, or even ~/.kde (where I would expect KDE startup files to go).

Does anyone more knowledgable of KDE know how to do this? It is fairly important.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5651
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: So, how would I disable wicd-client.py?

Post#2 by brokenman » 30 Jun 2012, 02:03

Code: Select all

chmod -x /etc/rc.d/rc.wicd
The startup script will look for an executable .rc file and run it.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
wread
Module Guard
Module Guard
Posts: 1108
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: So, how would I disable wicd-client.py?

Post#3 by wread » 01 Jul 2012, 18:47

Eliminate wicd and install Network Manager instead. See my post http://porteus.org/forum/viewtopic.php? ... 1188#p8939, EDIT 5. Maybe this solves your problem!

Wicd is already deprecated; we will be using NM.

Cheers :)
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
TheDoctor
White ninja
White ninja
Posts: 14
Joined: 03 Sep 2011, 21:15
Location: I am everywhere.
Contact:

Re: So, how would I disable wicd-client.py?

Post#4 by TheDoctor » 19 Jul 2012, 15:06

brokenman wrote:

Code: Select all

chmod -x /etc/rc.d/rc.wicd
The startup script will look for an executable .rc file and run it.
We did that - it works fine for deactivating the daemon but the client-side applet still comes up, complains, and asks the user for permission to restart it. That is fine for most users but in our particular case it breaks things.

We figured out how to disable it entirely, starting here.

User avatar
wread
Module Guard
Module Guard
Posts: 1108
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: So, how would I disable wicd-client.py?

Post#5 by wread » 05 Aug 2012, 02:00

Umm.., I may have a 002-xorg module with no wicd at all. I made it clean first, and then added the present Network Manager. But in that case you will not be able to connect at all..

Let me know if that would solve your poblem.

Regards :)
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

Post Reply