X.Org 7.7 Katamari Finally Surfaces - could we include it?

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
Post Reply
Lukas
White ninja
White ninja
Posts: 10
Joined: 11 Jun 2012, 04:17
Location: masovia province

X.Org 7.7 Katamari Finally Surfaces - could we include it?

Post#1 by Lukas » 11 Jun 2012, 08:22

After a year and a half they managed to clean up a bit this mess. Bring this up probably would breake some :wall: but never put off until tomorrow what you can do today I believe.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: X.Org 7.7 Katamari Finally Surfaces - could we include i

Post#2 by fanthom » 12 Jun 2012, 16:25

done for 64bits:

Code: Select all

[   332.481] 
X.Org X Server 1.12.2
Release Date: 2012-05-29
[   332.481] X Protocol Version 11, Revision 0
[   332.481] Build Operating System: Slackware 13.37 Slackware Linux Project
[   332.481] Current Operating System: Linux porteus 3.4.1-porteus #2 SMP PREEMPT Sun Jun 10 09:41:53 UTC 2012 x86_64
[   332.481] Kernel command line: root=/dev/ram0 rootfstype=ext4 rw initrd=/boot/initrd.xz from_dev=/dev/sdb7 nocd nomagic lxde  BOOT_IMAGE=/boot/vmlinuz 
[   332.481] Build Date: 11 June 2012  04:29:30PM
[   332.481]  
[   332.481] Current version of pixman: 0.25.6
no conflicts with official repo so if i succeed in 32bits edition then we will have latest xorg + drivers for porteus 1.2.
i wont upgrade mesa as it's damn huge (gallium drivers requires llvm which produces 5 times larger DRI modules).

Posted after 18 hours 45 minutes 24 seconds:
Re: X.Org 7.7 Katamari Finally Surfaces - could we include it?
spoke too soon - xorg-server-1.12.2 is causing some troubles:
a) fglrx-12.4 (last one which supports HD 2000-7000 family) does not work with latest xorg
b) mouse wheel is not working in vbox
c) newer xcb-util is short of .la files needed for compilation from sources
d) probably other small issues

we are at rc2 stage (no plans for rc3) and i'm short of time to track everything down so will stick to well tested 1.9.5 version.
sorry about that.
Please add [Solved] to your thread title if the solution was found.

Post Reply