Microphone sound is too low

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
rameshtap
White ninja
White ninja
Posts: 7
Joined: 22 May 2012, 13:19
Location: India

Microphone sound is too low

Post#1 by rameshtap » 30 May 2012, 13:09

Microphone sound is too low and I had to shout to be heard. Is that a problem that can be tuned or not? Other OS have boost mic option. I've test with 3 different PCs.

Thanks.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Microphone sound is too low

Post#2 by fanthom » 31 May 2012, 09:10

hi rameshtap,

did you try to adjust microphone settings in any audio mixer?

please run 'alsamixer' in console -> press F4 to switch to 'capture' settings and set all to max.
if that wont work then please post output of 'amixer' command to postebin.com and link here (also run this command on other OS where mic is working fine)
Please add [Solved] to your thread title if the solution was found.

rameshtap
White ninja
White ninja
Posts: 7
Joined: 22 May 2012, 13:19
Location: India

Re: Microphone sound is too low

Post#3 by rameshtap » 31 May 2012, 10:43

Find the output of 'amixer' command

http://www.sendspace.com/filegroup/23Ji ... HbKCubiRCl

I have tried with slax with 3 more motherboard all of them having same problem
but
with windows on the same hardware it works fine.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Microphone sound is too low

Post#4 by brokenman » 31 May 2012, 17:57

Have set the input source to the front mic? Front mic seems to be disabled in your screenshots. Where do you have the microphone plugged in?

Also please show your alsa.conf file if you have one ... it should loo something like: options snd-hda-intel model=
How do i become super user?
Wear your underpants on the outside and put on a cape.

rameshtap
White ninja
White ninja
Posts: 7
Joined: 22 May 2012, 13:19
Location: India

Re: Microphone sound is too low

Post#5 by rameshtap » 01 Jun 2012, 05:55

I am using back mic port for microphone.

Find the alsa.conf as attachment
cat /usr/share/alsa/alsa.conf
http://www.sendspace.com/file/kw43f5


cat /usr/share/alsa/alsa.conf
http://www.sendspace.com/file/m0j97j

User avatar
fanthom
Site Admin
Site Admin
Posts: 4546
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Microphone sound is too low

Post#6 by fanthom » 01 Jun 2012, 08:35

@rameshtap

i have few ideas what you could try:

1) create /rootcopy/etc/modprobe.d/snd_hda_intel.conf file with following content:

Code: Select all

options snd_hda_intel model=auto position_fix=3
as per this arch forum thread: link
that issue was quite different but may be worth trying.
2) go to the BIOS and change sound device to AC97 compatibility mode
3) upgrade to latest rc2 of upcoming porteus-1.2 (maybe newer kernel contains a fix for that)
4) compile latest alsa{lib,oss,utils} from slack-current on porteus (slack-13.37):
link

btw: did you try to connect your mic to the front panel and unmute it in alsamixer?
Please add [Solved] to your thread title if the solution was found.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Microphone sound is too low

Post#7 by brokenman » 02 Jun 2012, 02:06

/etc/modprobe.d/snd_hda_intel.conf

Sorry, i wasn't very clear ... this is the .conf file i meant.
Also i assumed OP was using latest rc2. Please confirm that you have tried plugging into front mic input.
How do i become super user?
Wear your underpants on the outside and put on a cape.

rameshtap
White ninja
White ninja
Posts: 7
Joined: 22 May 2012, 13:19
Location: India

Re: Microphone sound is too low

Post#8 by rameshtap » 02 Jun 2012, 11:27

Hi,
fanthom

thanks for your ideas

I have tried with number 1 idea microphone sound gets disturb fully.

My bios does not have the option to change sound device to AC97 compatibility mode. (Gigabyte GA-D425TDU)

I have also tried with latest rc2 but i have not find any recoding software. i have installed krec but it does not get started. I have tried with skype there is same problem the sound is to low.

i have not tried with the 4th option because i am a new user to linux

I have also tried with front mic the sound get more disturb.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Microphone sound is too low

Post#9 by brokenman » 02 Jun 2012, 20:51

I have tried with number 1 idea microphone sound gets disturb fully.
What does this mean? Do you have sound but it is very noisy?

If so add: position_fix=1

options snd_hda_intel model=auto position_fix=1
How do i become super user?
Wear your underpants on the outside and put on a cape.

rameshtap
White ninja
White ninja
Posts: 7
Joined: 22 May 2012, 13:19
Location: India

Re: Microphone sound is too low

Post#10 by rameshtap » 03 Jun 2012, 06:43

Hi brokenman,

By default the microphone sound is to low.

I have tried fanthom idea number 1
1) create /rootcopy/etc/modprobe.d/snd_hda_intel.conf file with following content:
CODE: SELECT ALL
options snd_hda_intel model=auto position_fix=3

as per this arch forum thread: link
that issue was quite different but may be worth trying.
after doing this the sound get totally noisy

Post Reply