Porteus attempts to unmount partition

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
rnport
Black ninja
Black ninja
Posts: 98
Joined: 01 May 2011, 00:55

Porteus attempts to unmount partition

Post#1 by rnport » 25 Apr 2012, 00:48

I installed latest stable version (1.1) and it has a beautiful desktop and works very smoothly. However, I had some problems with partition mounting.

I used 'noauto' cheatcode on kernel line to prevent automatic mounting of all partitions. Then I selected a partition (say abcd) which mounted very well. However, after every few minutes a dialog box appears saying that 'partition abcd could not be unmounted as it is busy' with details of the processes. I do not know why this is happening.

For some partitions, clicking on them produced error message dialog box: no permission. For these, I changed to su and started konqueror from command line. However, on clicking the storage devices link, media:/ appears but there are no partitions stored there. So I guess I will have to mount these partitions manually from command line.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5504
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus attempts to unmount partition

Post#2 by brokenman » 25 Apr 2012, 03:12

I will have to look into the 'noauto' cheatcode and the message you receive every few minutes.

As a test i unmounted /dev/sda4 from a console. When opening konqueror via console (kdesu konqueror) and going to media:// everything had disappeared however; by going to system:/media all drives were visible and i could mount /dev/sda4 again by double clicking on it.

This appears to be a kioslave bug which i thought was already address upstream. Will let them know.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply