nVidia Drivers

Post here if you are a new Porteus member and you're looking for some help.
edge226
Contributor
Contributor
Posts: 98
Joined: 27 Feb 2012, 23:55
Location: Canada

nVidia Drivers

Post#1 by edge226 » 28 Feb 2012, 00:01

I've done a fresh install a couple times and have been trying to get the nVidia drivers working. I installed them and added the nvidia module to the porteus/optional and added vga-detect to my /boot/porteus.cfg, It seems to fail upon doing the nVidia driver and unloads it then falls back to the default driver. however once I ran nvidia-xconfig as root as I would do on practically any distribution. I then recieve a No Server error message in a loop.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: nVidia Drivers

Post#2 by brokenman » 28 Feb 2012, 02:02

Can you please supply some system specs, and which nvidia module you chose to download.
How do i become super user?
Wear your underpants on the outside and put on a cape.

edge226
Contributor
Contributor
Posts: 98
Joined: 27 Feb 2012, 23:55
Location: Canada

Re: nVidia Drivers

Post#3 by edge226 » 28 Feb 2012, 06:08

i5 2500k, 6gb ram, asus p8p67-m pro motherboard, Asus gt-440. Installed to a 16GB USB 3.0 Corsair Voyager Flash drive. and I used ext4 as my filesystem.

Nvidia module : http://ponce.cc/porteus/x86_64/current/ ... -2beny.xzm

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: nVidia Drivers

Post#4 by fanthom » 28 Feb 2012, 08:24

hello edge226,

i5 2500k + Asus gt-440 means that this is dual GPU system which currently is not supported by 'vga-detect'. as per /boot/docs/cheatcodes.txt:

Code: Select all

Note that this cheatcode may not perform as expected if you have 
a dual-graphics card setup.
(wish i own that hw setup to dig more into it)

despite of that we may try to get your PC working with nVidia driver without 'vga-detect' cheat. please upload output of 'lspci -knn' and 'lsmod' commands, also /var/log/messages and /var/log/Xorg.0.log to pastebin.com (can be all in one file) and link here for review.
Please add [Solved] to your thread title if the solution was found.

User avatar
Hamza
Warlord
Warlord
Posts: 1846
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: nVidia Drivers

Post#5 by Hamza » 28 Feb 2012, 08:35

It's strange, we have more problems with nVidia Cards than ATI ones. :Search:
NjVFQzY2Rg==

edge226
Contributor
Contributor
Posts: 98
Joined: 27 Feb 2012, 23:55
Location: Canada

Re: nVidia Drivers

Post#6 by edge226 » 28 Feb 2012, 09:46

Okay, I accidentally was using the 1.2rc1 disc, I changed to the 1.1 discs and now have both 32 and 64 bit working with Nvidia drivers. However it says that my resolution is 1360x768 on both, it looks as if my resolution is either off or the DPI is off. I have ran nvidia-xconfig which often fixes these issues.

User avatar
Hamza
Warlord
Warlord
Posts: 1846
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: nVidia Drivers

Post#7 by Hamza » 28 Feb 2012, 09:49

So, this thread should be marked as solved by following this rule
8. If your problem has been solved, please add the [Solved] tag to tittle of the thread. It will make it easier to search the forum for working solutions.


Thanks!
Last edited by Hamza on 28 Feb 2012, 10:27, edited 1 time in total.
NjVFQzY2Rg==

edge226
Contributor
Contributor
Posts: 98
Joined: 27 Feb 2012, 23:55
Location: Canada

Re: nVidia Drivers

Post#8 by edge226 » 28 Feb 2012, 09:51

My drivers are still not working properly so the issue is not solved yet, however nearing solution.

how do I change my DPI? I am sure 215 x 217 dpi for the xserver is incorrect.

hmmm, I checked my other linux distro and the dpi is also 215 x 217. Yet it seems like I have at best a 600x480 or 800x600 resolution...

going to test if nomodeset helps with this, Ill report back with the result ;)

still not resolved, I wonder if it is a KDE or LXDE setting making all the text huge...

User avatar
Hamza
Warlord
Warlord
Posts: 1846
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: nVidia Drivers

Post#9 by Hamza » 28 Feb 2012, 10:28

Maybe a tweak in xorg.conf file..will need to wait on fanthom for that :)
NjVFQzY2Rg==

edge226
Contributor
Contributor
Posts: 98
Joined: 27 Feb 2012, 23:55
Location: Canada

[solved] nVidia Drivers + DPI issues

Post#10 by edge226 » 28 Feb 2012, 10:55

I ended up finding the DPI setting, it was a kde system setting under Application Appearance, Then fonts, Force fonts DPI - Disabled. This needed to be changed to 96 DPI.

User avatar
Hamza
Warlord
Warlord
Posts: 1846
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: nVidia Drivers

Post#11 by Hamza » 28 Feb 2012, 11:03

You had solved the issue yourself for KDE but what about other DE like LXDE ? For you, this issue has been solved but it has not been solved entirely because other DE don't contain the KDE System manager to disable the "force fonts" setting.
NjVFQzY2Rg==

edge226
Contributor
Contributor
Posts: 98
Joined: 27 Feb 2012, 23:55
Location: Canada

Re: nVidia Drivers

Post#12 by edge226 » 28 Feb 2012, 14:50

You are correct sir, that fixes things for KDE but not LXDE. well it does but it is not a permanent fix. If I set the setting and then log out and back in the setting is maintained. However it is not maintained upon boot.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: nVidia Drivers

Post#13 by fanthom » 28 Feb 2012, 15:03

@edge226

please save this config as /mnt/sdXY/porteus/rootcopy/etc/X11/xorg.conf and boot in 'Always Fresh' mode (to skip your old settings)

Code: Select all

Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option	    "Protocol" "auto"
Option	    "Device" "/dev/input/mice"
Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
EndSection

Section "Device"
Identifier  "Card0"
Driver      "nvidia"
Option	    "UseEdidDpi" "False"
Option	    "DPI" "96 x 96"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection
let me know if fonts looks ok (KDE/LXDE) when you boot with nVidia driver.
if yes then i'll update all nVidia drivers on the server with new config.
Please add [Solved] to your thread title if the solution was found.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: nVidia Drivers

Post#14 by Ahau » 28 Feb 2012, 15:20

I have the same large font issue with nvidia drivers; adding this:

Section "Device"
Identifier "Card0"
Driver "nvidia"
Option "UseEdidDpi" "False"
Option "DPI" "96 x 96"
EndSection


resolves the text size in all three DE's. Thanks!
Please take a look at our online documentation, here. Suggestions are welcome!

edge226
Contributor
Contributor
Posts: 98
Joined: 27 Feb 2012, 23:55
Location: Canada

[solved] nVidia Drivers

Post#15 by edge226 » 29 Feb 2012, 20:38

Simply adding

Option "UseEdidDpi" "False"
Option "DPI" "96 x 96"

to my xorg.conf fixed this issue, Thank you.

Post Reply