Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#1 by Ahau » 20 Feb 2012, 18:53

I'm pleased to report that the XFCE desktop has been accepted as an official desktop for Porteus!

You can download the Porteus-XFCE 64-bit ISO here:
http://ponce.cc/porteus/x86_64/testing/Porteus-v1.2-rc1

This ISO is based on the standard edition of Porteus and uses the same kernel, initrd, and the following base modules: kernel, core, xorg, devel and firefox. To these modules, I've added a module containing the XFCE desktop and a module with several desktop applications.

The ISO has modified bootloader configs, so you can install it exactly the same as the standard edition, and the default options will get you into XFCE.

If you're interested, please download and test it, and report any issues you find here. Also, I've got some room left for additional applications, so feel free to suggest things you'd like to add. I do want to keep this ISO as one application per task, so keep that in mind for your suggestions.

Known Bugs:
- on rare occasions, I've had the desktop hang for about 30 seconds when I logout from the session using the buttons in the panel (running reboot or halt from the command line is not affected). This appears to be an upstream bug, but I haven't sorted out when it occurs or why, so please let me know if this happens to you, and we'll get it sorted.
EDIT: This only seems to occur when applications that write to ~/.cache are left open (e.g. medit) while logging out. To avoid this bug, please close these applications prior to logging out. If you get hit with this bug with saved changes applied, you'll need to delete the contents of the ~/.cache/sessions/ directory in order to get the window manager working properly again.

Changelog from last beta release:
- dropped several packages from the XFCE build: gnome-keyring, gstreamer, and all dependencies
- replaced xfce4-mixer with retrovol, a neat little panel mixer app from the puppy distro
- replaced xfce4-volumed with some keymappings -- please let me know if your laptop/keyboard volume/mute buttons stop working
- replaced xfburn with pburn (also from the puppy project) to eliminate gstreamer
- dropped parole (gnome-mplayer is already present in the 002-xorg.xzm module)
- replaced xnoise with audacious
- dropped midori from the ISO, but it can still be downloaded from the google code page, here: http://code.google.com/p/porteus-xfce/downloads
- dropped SLiM login manager -- XFCE now loads through lxdm, which has been moved into the 002-xorg.xzm base module
- added abiword and gnumeric to the office section
- removed "opaque" cheatcode, this functionality is now available from the second boot option in extlinux/lilo, using the cheat "autoexec=xf-compositing~off". This turns off compositing for the XFCE window manager, but it will be turned on at each boot-up by default unless this cheatcode is used.
- removed international language support (locales) -- this will be added to the downloads for Language Selection Tool, so users can set up internationalization just as they would in the standard editions.
-other minor tweaks to the DE to improve the look/feel

Thank you for testing!
Last edited by Ahau on 22 Feb 2012, 02:52, edited 3 times in total.
Reason: Stuck it
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#2 by Rava » 24 Feb 2012, 06:31

Currently I am running it.

My changes:
Included also these modules:

Code: Select all

0092-midori+flash-rava.xzm
010-nVidia-295.20-porteus-v1.2-rc1-x86_64-1beny.xzm
020-opera-11.61.1250-stripped.locales-x86_64.xzm
025-truecrypt-7.0-x86_64.xzm
051-geany-0.20-x86_64.xzm
052-gimp-2.6.11-x86_64-alldeps-Rava-stripped-locales.xzm
Excluded this:
005-devel.xzm

Works all like a charm! And the most important thing! I have finally my XFCe back! LXDE is not that bad as KDE, by far not! But there are lots of little things that irk me, like the drawing errors of the pager preview. Or that you cannot move a window from desktop to desktop using the pager preview.

*ahem* I digress. But me is happy. Thanks to all that helped! :good: :Yahoo!: :Rose: :good:

_________________________________________________

So... does anything not work as it should: Yes, but only a small thing. When I use alsamixer from the console I realize the XFCe volume panel thingy is the PCM volume. Now, when I e.g. set it via console/alsamixer to, say, 93%, the XFCe mixer tells me it's 96%. At least the XFCe mixer only reacted when I changed the PCM volume.
When I pushed the XFCe mixer up to 100% to see what would happen, in console/alsamixer the focus switched to Master... (I did not switch it it was on another desktop then..)
So, that's a bit weird. My sound hardware:

Code: Select all

root@porteus:~# lspci |grep -i Audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
Yes, the sound was buggy in older Porteus versions as well, I used a hack to fire up the volume since it was always muted by default...

I just did another XFCe mixer test. Seems it could be a redrawing error:
I pumped up or down the master volume, the XFCe bar showed no changes. But when I clicked on the icon and clicked it again (to make iot go away and reappear) it showed about the right bar. :%)

_________________________________
Ahau wrote:- replaced xfce4-volumed with some keymappings -- please let me know if your laptop/keyboard volume/mute buttons stop working
Just the very contrary, my dear sir! It is the very first time the volume keys using the Fn key + §/3 or $/4 is working for the first time in a Linux ever. When I recall right so far only Puppy managed that on the Toshiba. xD
Cheers!
Yours Rava

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#3 by Ahau » 24 Feb 2012, 15:37

Thanks, Rava!

Damn, I had hoped retrovol would autoconfig to the right channel (or at least to Master) in all cases. Try doing this:

Right click on the volume icon (retrovol) in the panel; select 'Config Window', click on the 'Tray' tab, then open the 'Tray Slider' dropdown menu and select the channel you want to control through retrovol. Then, click "Apply". If you select "Master" then it should match up when you press the volume keys.

All that said, I'd appreciate some testing of a script I just wrote yesterday to better handle the volume buttons. You can download it as a module here: http://porteus-xfce.googlecode.com/files/pxf-sound.xzm

This module contains the script (/opt/porteus-scripts/xfce/pxf-sound) as well as new keymapings that will point the laptop volume keys to this script. The script will cause the volume keys to control the Master Volume just like they do for you now, but if you make changes to retrovol as discussed above, it will pick up the channel you have specified as your "Tray Slider" and the volume buttons will then control that channel.

Also, when you press the button keys, an xdialog window will open up showing you the current volume level and/or mute status. I wanted something more visible than the tray icon when I mute or change volume, but if this is too obtrusive for other users, let me know and I will either scale it back or create an option to prevent the dialogs from opening. Go easy on me, this is my first Xdialog script :)

This xzm module will work in 32 and 64-bit XFCE.

Thanks!
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#4 by Rava » 24 Feb 2012, 23:27

Good I will check out this script.

I just tried the same XFCe 1.2rc1 on another PC (desktop, not a notebook) but no sound came at all... It worked like charms in 1.0 and 1.1, though...

Hopefully your script might help me there.

Should I post some infos of the hardware here? Which would be possible hardware error messages I could search for, e.g. in dmesg?
Cheers!
Yours Rava

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#5 by Ahau » 25 Feb 2012, 01:04

Yes, please post some information for this computer, and we'll try to sort it out.

please upload the following to pastebin:

psinfo
lspci |grep Audio #already included in psinfo but should tell you right away what the audio device is and if the driver is loaded)
amixer #no options
amixer controls
aplay -l

Thanks!
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#6 by Rava » 25 Feb 2012, 03:26

I will as soon as I start up that very machine again.
Currently I am on the notebook and all runs like a charm...

Okay, I managed to break something when I upgraded firefox to 10.0.2 with the newest x86-64 Flash (from 14th of Feb, that Flash is)...
Seems FFx forgot in its settings that it has Flash... And me forgot where he stores that. Sometimes one hack needs some more hacks to have it all running well again. :( :oops:
But that is OT in this thread so forget the above. (All who read it to write me a PM if you have a hint, though xD)
Cheers!
Yours Rava

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#7 by Ahau » 25 Feb 2012, 03:43

Thanks, Rava. You might try moving midori to /optional while you install and test your new firefox. The 0092-midori module contains flash as well, with libs tied to seamonkey-solibs instead of firefox libs. That might be some (or all) of your problems.
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#8 by Rava » 25 Feb 2012, 14:38

For now I removed midory completely since I use Opera as 2nd browser...

Reminds me, why did i not try Opera, if it still can give me youtube and such...

________________________-

Anyhow, found an error:
I ran GIMP. And when I have it on a desktop, left and right the narrow toolbox and settings windows, in the middle one window with an image I just edited. and switched to some other desktops using the mouse wheel... these narrow left and right windows followed me to all the other desktops. How can that be? :o

I use the same GIMP on 1.0 and 1.1 finale and he never did so on these...

Verfasst after 1 minute 41 second:
Yup, youtube works fine with Opera.

Verfasst after 10 hours 40 minutes 20 seconds:
UPDATE
______________________________________________________

root@porteus:/etc/X11/xinit# ls -l xinitrc*
lrwxrwxrwx 1 root 27 2012-02-25 14:14 xinitrc -> /etc/X11/xinit/xinitrc.lxde
lrwxrwxrwx 1 rava 28 2012-02-25 14:14 xinitrc.xfce -> ../../xfce/xdg/xfce4/xinitrc

Now, I was running XFCe 1.2rc1, so... there is no such thing as /etc/X11/xinit/xinitrc.lxde.

In my book, as failsave thingy, rc.M also should check if the target files do exist.
In this case, I have no clue whatsoever it thought me has a lxde cheatcode:

Code: Select all

root@porteus:~# cat /proc/cmdline
root=/dev/ram0 rootfstype=ext4 rw initrd=/boot/initrd.xz xfce nomagic  BOOT_IMAGE=/boot/vmlinuz
And me was right!
Checking rc.M I found the mistake:

Code: Select all

# Let's check if user used 'lxde/xfce' cheatcode to determine display manager:
dm() { echo $1 > /mnt/live/tmp/dm; }
if egrep -qo " lxde( |\$)" /proc/cmdline; then
    if [ -x /usr/sbin/lxdm ]; then
	sed -i s^session=/usr/bin/startxfce4^session=/usr/bin/startlxde^g /etc/lxdm/lxdm.conf 2>/dev/null
        ln -sf /etc/X11/xinit/xinitrc.lxde /etc/X11/xinit/xinitrc
        dm /usr/sbin/lxdm
    else
        dm xinitrc
    fi
elif egrep -qo " xfce( |\$)" /proc/cmdline; then
    if [ -x /usr/sbin/lxdm ]; then
	sed -i s^session=/usr/bin/startlxde^session=/usr/bin/startxfce4^g /etc/lxdm/lxdm.conf 2>/dev/null
        ln -sf /etc/X11/xinit/xinitrc.lxde /etc/X11/xinit/xinitrc
        dm /usr/sbin/lxdm
    else
        dm xinitrc
    fi
else

Looks like, infamous Dr. Copy and Mr. Paste stuck again! (And Dr, Jekyll and Mr. Hide *cough* I meant Dr. Copy and Mr. Paste so often do!)

Me suggests
ln -sf /etc/X11/xinit/xinitrc.xfce /etc/X11/xinit/xinitrc
in the xfce part. xD

And (inhales, says the next three words quite quickly) please, please please, if you change any files, please also change/inclease the version number...
And start giving the script a version number to begin with...
Cheers!
Yours Rava

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#9 by Ahau » 25 Feb 2012, 19:41

You're correct about rc.M -- I'd seen that earlier and I think I fixed it in a patch for 32-bit. Here's a fixed rc.M, in an xzm module:
http://porteus-xfce.googlecode.com/file ... -patch.xzm

please put that in your modules folder to fix, and let me know if that does the trick. I'll have to look into the gimp issue some more and test it to see what the problem is; not much time today...

Thanks!
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#10 by Rava » 25 Feb 2012, 22:55

Ahau wrote:You're correct about rc.M -- I'd seen that earlier and I think I fixed it in a patch for 32-bit. Here's a fixed rc.M, in an xzm module:
http://porteus-xfce.googlecode.com/file ... -patch.xzm
I fixed it by editing it and putting it into my rootcopy. xD

But yes, I will check out yours as well - and put it into rootcopy,, too. :D

Aaaaand did you change the version number and comments? :Rose:

I increased it, and put my name into it after fanthom's name{/s].
Cheers!
Yours Rava

my9821
Ronin
Ronin
Posts: 2
Joined: 17 Jan 2011, 01:42
Location: Chinese

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#11 by my9821 » 27 Feb 2012, 04:38

How to display Chinese ?
sorry.My English is very poor!

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#12 by Ahau » 27 Feb 2012, 15:44

welcome, my9821!

Unfortunately, your English is far better than my Chinese, but hopefully we can get this working for you properly.

As detailed in this post: http://porteus.org/forum/viewtopic.php?f=39&t=297
the first step for asian fonts is to install a proper font. The Porteus ISO ships with very few fonts by default in order to keep it's size small. I did a search this morning and found the WenQuanYi font, which is an open source chinese font. Here is a link to it's sourceforge page, which has several different fonts available: http://sourceforge.net/projects/wqy/

I downloaded the wqy-zenhei font, extracted it and followed the instructions in the INSTALL document to alter ~/.font.conf and to add the proper directory to /etc/fonts/font.conf, and created a porteus module for you, which you can download here: http://porteus-xfce.googlecode.com/file ... 0.9.45.xzm

Please download this module and place it on your storage device where Porteus is installed, inside the directory /porteus/modules (for example, /mnt/sdb1/porteus/modules), restart your system, and you should be able to display chinese fonts on your system.

If you would like your system to display chinese menus, then you will need to run the "language-selection-tool" program, available in the XFCE menu under the "system" heading. However, since this is still a Release Cadidate, the XFCE-specific locale files have not yet been merged into this tool. I apologize for this being so disjointed...anyway, here are two more modules that should help. The first was created by going through the language-selection tool and selecting 'zh_CN' as the default system language and keymapping with utf8 encoding:
http://porteus-xfce.googlecode.com/file ... x86_64.xzm

And this next module contains the chinese localization files for XFCE and XFCE-apps:
http://porteus-xfce.googlecode.com/file ... x86_64.xzm

Please download these modules and place them on your storage device inside the /porteus/modules/ directory. With all three of these modules in place, I am able to restart my system and display chinese characters, whith chinese menus.

If you would prefer to use different locales (something other than zh_CN), then please run 'language-selection-tool' for yourself and select the encoding and locale you prefer. Here are the steps I followed:

1. connect to internet
2. select menu->system->language-selection-tool
3. click next
4. check 'I want UTF8 Encoding', selected 'zh_CH.utf8' from the dropdown list (select the encoding you would like)
5. click next
6. leave the KDE section blank, check 'Choose System Language' box, select zh_CH (or other locale) from dropdown
7. click next
8. skip KDE keyboard settings (these are only for KDE), click next again
9. did not check 'automount windows filesystems' or 'IOCHARSET' (but you can select these if you like), click next
10. click 'build'
11. click 'cancel' to download files
12. wait -- it will download glibc-i18n-x86_64-ftm.xzm and locales module
13. after download finishes, select zh_CN for Manual pages, click OK
14. click OK again -> a module will be created and placed in the /porteus/modules folder
15. check the /porteus/modules folder to make sure the module is there, and remove any other localization modules that might be different (move to /porteus/optional)
16. reboot

Please let us know if this doesn't work for you, or if you have any other questions.

EDIT: I forgot to mention, I was unable to get a chinese keyboard keymapping working on my system. I'm not sure if it's unsupported by the operating system, my specific hardware, or the xfce xkb panel plugin. If anyone has any guidance for setting up chinese keymapping in Porteus, I'd be grateful. EDIT TO MY EDIT: I just saw this thread by feng: http://porteus.org/forum/viewtopic.php?f=39&t=1083 maybe that will help. I'll see about compiling that for a 64-bit environment and post it here if I get it working.

Posted after 11 minutes 22 seconds:
@rava,

Sorry, still haven't had a chance to install and test the GIMP -- still on my ToDo list

I did not change the version number or comments in rc.M, it was a minor typo fix (just changed xinitrc.lxde to xinirc.xfce). As fanthom is the maintainer for rc.M in all editions of porteus, I'll let him speak to the question of versioning in porteus scripts.

I do maintain a number of scripts that are specific to Porteus. Most of them are inside /opt/porteus-scripts/xfce, and most of them do not have individual version numbers. However, they are all part of a slackware package that I create and use to produce the modules inside the ISO. This package is zzz-xfce-customizations-$VERSION-$ARCH-1Ahau.txz or something similar. I find this versioning to be adequate for my needs and would probably forget to update version numbers for each script individually...but I'm open to suggestions :)

BTW, I've rewritten the pxf-sound script so that it has a gtkdialog volume bar (looks better than Xdialog) and I've also written a simple startup wrapper for retrovol which should automatically set the default channel to "Master Volume" -- I thought this was already the case, but it appears one of your systems was set to some PCM channel (channel 37, I'm guessing, as that is the default set by the applications' author). I'd still like to see the outputs from the commands I listed previously on that computer, to make sure I've set this up properly.

Cheers!
Please take a look at our online documentation, here. Suggestions are welcome!

my9821
Ronin
Ronin
Posts: 2
Joined: 17 Jan 2011, 01:42
Location: Chinese

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#13 by my9821 » 27 Feb 2012, 22:04

:Yahoo!:
Thank you very much?

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#14 by Ahau » 28 Feb 2012, 03:03

Here's a module for gcin in 64-bit: http://porteus-xfce.googlecode.com/file ... 1_Ahau.xzm
download and place in /porteus/modules with the others. After you reboot, you'll be able to type chinese characters (at least, I think they're chinese!). Thanks to feng for putting up information on this on another thread!

gcin loads an icon in the notification tray, which you can right click on to change the language to type. Since I don't know any chinese I wasn't able to test it thoroughly, but as I typed on my US keyboard, it presented me with dropdown menus with different characters to choose.
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
Hamza
Warlord
Warlord
Posts: 1846
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: Porteus-XFCE-v1.2-rc1-x86_64.iso is ready for testing!

Post#15 by Hamza » 28 Feb 2012, 09:47

I got it! I will try it soon as usual :Yahoo!:
NjVFQzY2Rg==

Post Reply