Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#31 by Ahau » 16 Mar 2012, 15:25

Thank you, Tonio! Yes, I see what the issue is now. I neglected to mention that the bug I was talking about only affected guest user in X (not in text mode). Root was working fine (which is why I didn't notice the bug until after RC1 was released).

Only read this if you care about the details:
Inside the /opt/porteus-scripts/activate script, there are checks to see whether the user is running in X and if the user is root. If you're logged in to X and are root, then it simply runs /opt/porteus-scripts/xactivate, but if you're running as guest, it runs something like '/opt/porteus-scripts/xorg/terminal -e ktsuss /opt/porteus-scripts/xactivate'. This is a wrapper to open up the appropriate terminal and open ktsuss to elevate the user's perms to root for the activation. This works just fine for lxterminal and konsole, but Terminal (terminal emulator in xfce) doesn't respect the '-e' switch in the same way and needed to be run as '-x' instead. So without that patch in place, Terminal interprets this command as an invalid option, displays the error you see there, and quits. This will all be resolved for RC2.

Thanks for the screenshots. I think I'll move the panel to the top and add the second 'launcher' panel to the bottom with autohide, and folks can speak up if they don't like that configuration. I've only heard from two people (you and justwantin) about the panel location, and you both are accustomed to having it at the top, and that is the default for XFCE.
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
francois
Contributor
Contributor
Posts: 5068
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#32 by francois » 23 Mar 2012, 14:51

francois wrote:I might come with some good news. But before, I will have to do some additional exploration. The problem might have with the type of changes I introduce, as I have been booting a few times with the changes option without changing anything and preserving the logout menu options: logout, restart, shutdown, suspend and hibernate.

I will revise each of the different modifications I use to implement from one session to another and come back.
Sorry if I took so much time to come back. My experiments did not provide some consistent data. In addition, I cannot say that I had the time to test the DE thoroughly. I will put some additional efforts this weekend.

Posted after 2 hours 44 minutes 48 seconds:
francois wrote:Using:
1) xfce cheatcode in menu.lst
2) removing telinit 4
Thus the menu.lst entry becomes:

Code: Select all

title porteus v11_32 on sda7/32bit_v12rc1 XFCE 4.8 NO CHANGES
kernel (hd0,6)/32bit_v11/boot/vmlinuz from_dev=/dev/sda7 from_dir=/32bit_v11/porteus xfce toroot autoexec=xconf max_loop=256
initrd=(hd0,6)/32bit_v11/boot/initrd.xz
boot
3) inserted patch:
http://porteus-xfce.googlecode.com/file ... -patch.xzm

Everything works fine for porteus xfce hdd frugal install. :D

4) However, at logout I get in the same problem as with slim, that is in the login manager. XFCE panel logout will not allow shutdown from X environment.
1.1 Using the above mentioned setup, with a brand new save changes folder, and with setting the session and startup being set to automatically saved session feature, I have rebooted 6 times without any and then a few windows opened: a) the file manager and b) firefox.

Yet there is no bootup problem and neither a shutdown problem. Which is very fine.

1.2 However, the setup of the desktop does not stay the same.

From here I will continue to add some feature and see how DE reacts.
Last edited by francois on 23 Mar 2012, 21:33, edited 1 time in total.
Voltaire: Le mieux est l'ennemi du bien.

mailmegx
White ninja
White ninja
Posts: 29
Joined: 23 Mar 2012, 18:44
Distribution: Porteus 1.2 XFCE 64bit
Location: Cyprus

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#33 by mailmegx » 23 Mar 2012, 19:32

Testing poerteus 32 bit xfce
boot fails when trying a 'poor mans install', the sgn flile was not found
when I use 'debug' cheatcode I run mount and /mnt/sda1 is not mounted, after boot fails at the ash prompt mount shows /mnt/sda1 is mounted

is this a known bug?

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#34 by Ahau » 23 Mar 2012, 19:51

I don't think this is a known bug per se, and I'd like a little more information before we call it a bug. Hopefully we just need to tweak the cheatcodes a bit.

First, does this computer boot up into porteus when run from a usb flash drive and/or cdrom? If so, please boot into porteus and run "psinfo" from a command line, and post the output to pastebin, with a link here. That will establish a base for us to know what hardware is present.

Then, please post the porteus.cfg file you are using for the "frugal" mode.

Just so I'm clear on when /mnt/sda1 is present and when it is not: If you run 'debug', you get to a prompt, and it is not mounted anywhere, but when you boot without "debug", once you get the error message that "porteus data cannot be found", then you can see it, correct? Please try booting with debug again, check for /mnt/sda1, press ctrl-D once, check again, etc., to see if it shows up at any point prior to failing out (though it is probably failing after the first command prompt, it doesn't cost us anything to try).

Thanks!
Please take a look at our online documentation, here. Suggestions are welcome!

mailmegx
White ninja
White ninja
Posts: 29
Joined: 23 Mar 2012, 18:44
Distribution: Porteus 1.2 XFCE 64bit
Location: Cyprus

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#35 by mailmegx » 23 Mar 2012, 20:12

First, does this computer boot up into porteus when run from a usb flash drive and/or cdrom? If so, please boot into porteus and run "psinfo" from a command line, and post the output to pastebin, with a link here. That will establish a base for us to know what hardware is present.
this is a virtuabox vm with a hard disk formatted to ext4 and using extlinux to boot (version 1.0 boots fine)
Then, please post the porteus.cfg file you are using for the "frugal" mode.
LABEL porteus 1.2 rc2
MENU LABEL porteus1.2.rc2
KERNEL /slax_v/porteus-1.2.rc2/boot/vmlinuz
APPEND initrd=/slax_v/porteus-1.2.rc2/boot/initrd.xz nomagic from_dev=/dev/sda1/ from_dir=/slax_v/porteus-1.2.rc2/
TEXT HELP
Porteus 1.2 rc 2
ENDTEXT

I also tried with sgnfile
LABEL porteus 1.2 rc2
MENU LABEL porteus1.2.rc2
KERNEL /slax_v/porteus-1.2.rc2/boot/vmlinuz
APPEND initrd=/slax_v/porteus-1.2.rc2/boot/initrd.xz nomagic from_dev=/dev/sda1/ from_dir=/slax_v/porteus-1.2.rc2/ sgnfile=/mnt/sda1/slax_v/porteus-1.2.rc2/porteus/porteus-v1.2-i486.sgn
TEXT HELP
Porteus 1.2 rc 2
ENDTEXT
Just so I'm clear on when /mnt/sda1 is present and when it is not: If you run 'debug', you get to a prompt, and it is not mounted anywhere, but when you boot without "debug", once you get the error message that "porteus data cannot be found", then you can see it, correct?

yes correct
When I run 'debug', you get to a prompt, if I type mount it shows /dev/sda1 is not mounted.
Even if I manually mount /mnt/sda1 it gives the same error (after pressing ctrl+d in debug mode)
after "porteus data cannot be found" message mount shows /mnt/sda1 loaded (in all cases)

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#36 by Ahau » 23 Mar 2012, 21:45

hmm, unfortunately I don't have a lot of experience with vbox and have never tried it with a frugal install on the virtual partition. Anyone else have any suggestions or experience with this?

Edit: update based on mchat conversation. mailmegx is able to boot slax and porteus v1.0 this way (frugal install through VM), but not V1.1 or V1.2. I'm guessing this has to do with some changes made to linuxrc between 1.0 and 1.1? fanthom, any help here?

Posted after 44 minutes 23 seconds:
Mailmegx -- per discussion with fanthom (he's told me this before but damned if I will ever remember this): as of V1.1, you need to include the full path to the sgn file with the from_dir= cheatcode. Also, the sgn cheatcode should only use the filename, not the full path (e.g. sgnfile=porteus-v1.2-i486.sgn)


Please modify your syslinux config file to use 'from_dir=/slax_v/porteus-1.2.rc2/porteus/' and let us know if it works.
Please take a look at our online documentation, here. Suggestions are welcome!

mailmegx
White ninja
White ninja
Posts: 29
Joined: 23 Mar 2012, 18:44
Distribution: Porteus 1.2 XFCE 64bit
Location: Cyprus

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#37 by mailmegx » 24 Mar 2012, 03:42

Thanks Ahau I didnt realize there was a change to those two cheatcodes, that did the trick!

User avatar
francois
Contributor
Contributor
Posts: 5068
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#38 by francois » 24 Mar 2012, 23:21

Thus save session on logout does not work:
xfce menu > settings > session and startup > logout settings > automatically save session on logout
Voltaire: Le mieux est l'ennemi du bien.

Tonio
Contributor
Contributor
Posts: 266
Joined: 28 Dec 2010, 16:37
Distribution: Slackware,porteus,FreeBSD,Slax
Location: 127.0.0.1

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#39 by Tonio » 25 Mar 2012, 00:58

I added the modules that fixed several issues

Code: Select all

xfce-patch-feb-23-i486.xzm
xfce-rc.M-patch.xzm
, and then got another bug :( When I tried to shut down, it logged me out and presented me with the login screen where one sees Welcome to Porteus. It did not matter if I shutdown from menu or terminal. I noticed this when I was updating kertex module. If these modules are not in modules/ folder, then the system shuts down as normal.
I wonder what is causing this? I remastered the iso adding these modules and others in the directory. I tested with virtualbox in the normal x86_64 version, and did not notice :(
Has anyone encountered this?

mailmegx
White ninja
White ninja
Posts: 29
Joined: 23 Mar 2012, 18:44
Distribution: Porteus 1.2 XFCE 64bit
Location: Cyprus

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#40 by mailmegx » 25 Mar 2012, 05:33

Hi All

I finally got mist stuff working however Im still having some problems, my main problem now is wicd does not start and power manager
Both problems are related to DBus
If I login as root its fine when I login as guest it does not work, here is an example:

Code: Select all

bash-4.1$ wicd-gtk 
Traceback (most recent call last):
  File "/usr/share/wicd/gtk/wicd-client.py", line 63, in <module>
    from wicd import dbusmanager
  File "/usr/lib/python2.6/site-packages/wicd/dbusmanager.py", line 93, in <module>
    DBUS_MANAGER = DBusManager()
  File "/usr/lib/python2.6/site-packages/wicd/dbusmanager.py", line 57, in __init__
    self._bus = dbus.SystemBus()
  File "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 202, in __new__
    private=private)
  File "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 108, in __new__
    bus = BusConnection.__new__(subclass, bus_type, mainloop=mainloop)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 125, in __new__
    bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
bash-4.1$ 
Any ideas?

System setup:
hw: dell xps m1710
porteus 1.2.rc1 XFCE
added modules:
gst-plugins-base-0.10.32-i486-1.xzm
gstreamer-0.10.31-i486-1.xzm
gtkspell-2.0.16-i486-1.xzm
nVidia-295.20-porteus-v1.2-rc1-i486-1beny.xzm
pidgin-2.7.11-i486-1.xzm
qt-4.7.0_7abde40-i486-3.xzm
vbox-4.1.8_extensionpack.xzm
VirtualBox-4.1.8-porteus-v1.2-rc1-i486-1ftm.xzm
vlc-1.1.7-i486-1tm.xzm
xfce4-cpugraph-plugin-1.0.1-i486-69.1.xzm

GX

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#41 by Ahau » 25 Mar 2012, 05:54

@francois, what elements are not being saved, or what are you looking to have saved, which is not? I thought I'd checked this before and it was working, but perhaps not with the latest version. I'll test again with some specifics for you, and see if I can recreate the issue.

@tonio, you have either made my day or ruined it :D francois has had this issue with xfce4-session happen, we've tried and tried to find a cause and a problem and I chalked it up to being an upstream bug. Are you testing with saved changes, and if so what is the filesystem on which you are saving your changes (or, are you using a save.dat?). Please test those two modules one at a time to narrow down which one exactly is the issue. Are you starting in text mode and logging in to xfce via "startx" or "startxfce4", or are you booting into normal graphics mode?

@mailmegx, I'm not having dbus issues with guest user on my end. Would you please try booting without any additional modules to see if the issue is resolved? If you have anything in rootcopy or magic folders, please remove them temporarily as well. If the issue is resolved, please start adding things back in and narrow it down to which module is causing the problem -- it might have incorrect permissions on a file or folder somewhere, which might be the cause. If the error is there without any extra modules/rootcopy, etc, then I'll dig deeper into the ISO and look for a fix there.

Thanks, everyone!
Please take a look at our online documentation, here. Suggestions are welcome!

Tonio
Contributor
Contributor
Posts: 266
Joined: 28 Dec 2010, 16:37
Distribution: Slackware,porteus,FreeBSD,Slax
Location: 127.0.0.1

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#42 by Tonio » 25 Mar 2012, 13:48

Ahau wrote: @tonio, you have either made my day or ruined it :D francois has had this issue with xfce4-session happen, we've tried and tried to find a cause and a problem and I chalked it up to being an upstream bug. Are you testing with saved changes, and if so what is the filesystem on which you are saving your changes (or, are you using a save.dat?). Please test those two modules one at a time to narrow down which one exactly is the issue. Are you starting in text mode and logging in to xfce via "startx" or "startxfce4", or are you booting into normal graphics mode?
I startup in textmode, straight from cd without changes, if I don't activate the modules, mostly everything works except the activation of modules from command line when in X, but that is not a big problem for me :) I log in via startx. I activate the modules after logging in. It seems that the bigger of the two modules causes the problems of not being able to shutdown or reboot :( But I shall run it again to make sure or to report back which one exactly causes this!

Thanks,

Antonio

EDIT:
The one that is causing the machine not being able to shutdown is the rc.M patch one:
guest@porteus:~$ ls /mnt/live/memory/images/xfce-rc.M-patch.xzm
EDIT2:
with the other module activated the machine shuts down, but the cd is not ejected :(
xfce-patch-feb-23-i486.xzm
it fixes the activation of modules from terminal as non root, but the above happens when shutting down.

Hope this helps!

mailmegx
White ninja
White ninja
Posts: 29
Joined: 23 Mar 2012, 18:44
Distribution: Porteus 1.2 XFCE 64bit
Location: Cyprus

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#43 by mailmegx » 25 Mar 2012, 14:26

@Ahau
I'm not having dbus issues with guest user on my end. Would you please try booting without any additional modules to see if the issue is resolved? If you have anything in rootcopy or magic folders, please remove them temporarily as well. If the issue is resolved, please start adding things back in and narrow it down to which module is causing the problem -- it might have incorrect permissions on a file or folder somewhere, which might be the cause. If the error is there without any extra modules/rootcopy, etc, then I'll dig deeper into the ISO and look for a fix there.
sorry for the delay, this has been driving me mad I rebooted 12321657652137612 times till now :wall:
I usualy use the nomagic cheat code anyway. I have narrowed down the 'module' causing the problem its 'zzz_base.xzm' this is a personal module that has the following (all for /etc):

xorg.conf
rc.d (disable startup of cups, gpm pcmcia, enable startup of sshd as well as custom rc.local for mounting my disks)
HOSTNAME (and hosts: changed porteus.example.net to gx_xps.example.net)
acpi_handler.sh (for suspend)
asound.state
sftab
group, passwd and shadow (I changed guest to gx and have mu own password obviously)
localtime
sauth

some of the files were owned by gx so I did a "chown -R root *" but that didnt help. Im in the process of deleting each file, rebulding the module, rebooting to see who the culprit is....


GX

well after many hours an many many more reboots , im none the wizer :s it seems any files I add to /etc causes a problem, most time guest cant even log in...
For the time being I can live without battery indicator and wifi indicator... and just hope to sort it out in the near future?
Last edited by mailmegx on 25 Mar 2012, 17:25, edited 1 time in total.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#44 by Ahau » 25 Mar 2012, 17:09

@tonio, very interesting, you're entering init 4 after logging out of xfce from init 3 (I think...) Please provide me with the output of 'cat /proc/cmdline' so I can test with the same exact setup (if you are savinfg changes, please let me know the filesystem).

@mailmegx -- ahh, I see now. This is almost definitely related to changing around accounts. You replaced guest with gx manually in /etc/shadow and /etc/passwd rather than using 'adduser', correct? And, then did you modify rc.M and /etc/lxdm/lxdm.conf to log gx by default, and copy /home/guest to /home/gx, then chown -R gx:guest (or gx:gx, gx:users or whatever gx's group is) on /home/gx? My guess is you didn't modify lxdm.conf, so you're still loging into xfce as 'guest', not 'gx', but you've stripped guest of it's group priveleges by inserting gx elsewhere.

I'm posting from my phone, so haven't tested any of the above today... Will do so tonight/tomorrow am. Thanks guys!
Please take a look at our online documentation, here. Suggestions are welcome!

mailmegx
White ninja
White ninja
Posts: 29
Joined: 23 Mar 2012, 18:44
Distribution: Porteus 1.2 XFCE 64bit
Location: Cyprus

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#45 by mailmegx » 25 Mar 2012, 17:35

Hey Ahau..

You replaced guest with gx manually in /etc/shadow and /etc/passwd rather than using 'adduser', correct?
correct

And, then did you modify rc.M and /etc/lxdm/lxdm.conf to log gx by default,
nope I prefer to log in manually I did not change rc.M

and copy /home/guest to /home/gx, then chown -R gx:guest (or gx:gx, gx:users or whatever gx's group is) on /home/gx?
nope I left my old /home/gx as it was

My guess is you didn't modify lxdm.conf, so you're still loging into xfce as 'guest', not 'gx', but you've stripped guest of it's group priveleges by inserting gx elsewhere.

Most of this is related to permissions of gx however I did many many many tests the first this I did was remove passwd, group and shadow from the problematic module so in actual fact im testing with guest so its not a problem of guest permissions as we originally thought.

It just seems that the system is way too temperamental as I mention in the edit above any change I make to /etc causes problems

Post Reply