Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#16 by Ahau » 28 Feb 2012, 15:36

Thanks, hamza -- this is what they suggest on that site:
Open the Terminal by clicking on Application > Accessories > Terminal
Type: sudo update-grub
Press Enter
Type your password and press Enter
Once the update is done, Restart your computer.
I do recall that francois is booting with grub -- I guess I don't understand why grub would be meddling with logout procedures at this level, but it's worth a shot. Francois, would you try doing this? If you don't have grub installed, you'll probably have to add it (http://carroll.cac.psu.edu/pub/linux/di ... i486-9.txz) and, of course, just run update-grub as root (or su) instead of sudo. You might also try with the cheat 'acpi=force', I read that helped some of the other ubuntu folks with similar issues.
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#17 by francois » 29 Feb 2012, 14:52

I can try it. However, I am sure that this procedure is for grub2. It is a command to reset grub.cfg.

I am working with grub legacy.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#18 by Ahau » 29 Feb 2012, 15:04

ahh, ok then. Yeah, I've never worked with grub2...

I have one more theory, and that is that it may be related to unclean shutdown procedures. When you are shutting down from xfce, do you ever get a message that says "remounting /union as read only, please use 'fsck' cheatcode during next boot..."?? I've been getting that on occasion with saved changes. There's also an upstream bug report about XFCE not properly closing all running programs that were initiated by XFCE on startup. Maybe there's a relation; I'm looking into it now.
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#19 by francois » 01 Mar 2012, 23:17

I might come with some good news. But before, I will have to do some additional exploration. The problem might have with the type of changes I introduce, as I have been booting a few times with the changes option without changing anything and preserving the logout menu options: logout, restart, shutdown, suspend and hibernate.

I will revise each of the different modifications I use to implement from one session to another and come back.
Voltaire: Le mieux est l'ennemi du bien.

crashman
Contributor
Contributor
Posts: 118
Joined: 28 Dec 2010, 17:03
Location: Poland

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#20 by crashman » 11 Mar 2012, 12:01

Hi Ahau

I Download Porteus-XFCE-v1.2-rc1-i486.iso and is impressive :good: is fast and good for my old laptop :D but i have problem with language-selection-tool, i want set my natural language but xdialog crashes after download locales and no have finished.

All other stuff work without problems.

regards

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#21 by brokenman » 11 Mar 2012, 13:49

The LST is not functioning in release candidates. Only final releases. Sorry.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#22 by Ahau » 12 Mar 2012, 14:28

@crashman -- very busy at work right now, but when I get a chance in the next couple of days I'll upload a module to my google code page that contains all of the localization files for xfce and xfce-apps. You can then copy the polish files from that module to create a 'locales-polish' module, and boot with the 'lang=' and 'kmap=' cheatcodes -- hopefully that will get you set up.
Please take a look at our online documentation, here. Suggestions are welcome!

crashman
Contributor
Contributor
Posts: 118
Joined: 28 Dec 2010, 17:03
Location: Poland

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#23 by crashman » 12 Mar 2012, 17:14

@brokenman
my stupid question i forgot :%)

@Ahau
Thanks - in this moment i've package from porteus-09.

I wait for final release your XFCE !

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#24 by Ahau » 13 Mar 2012, 05:56

well, the V09 locales from kde and lxde will only help you out some... here's the full locales module for 32-bit:

http://porteus-xfce.googlecode.com/file ... -1Ahau.xzm

That module is not set up like a regular porteus .xzm module -- the folders aren't in exactly the right layout. So, download it and mount it with mloop, then copy it to a new module:

Code: Select all

mloop locales-porteus-XFCE-i486-1Ahau.xzm 
mkdir -p /tmp/xfce-locales-pl/usr/share/locale
cp -r /mnt/loop/locale/pl /tmp/xfce-locales-pl/usr/share/locale/
dir2xzm /tmp/xfce-locales-pl /mnt/sdXY/porteus/modules/xfce-locales-pl.xzm
Then, that should work with your V09 locales module (which will set the system language and keyboard mapping). Just let me know if you run into trouble :)
Please take a look at our online documentation, here. Suggestions are welcome!

crashman
Contributor
Contributor
Posts: 118
Joined: 28 Dec 2010, 17:03
Location: Poland

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#25 by crashman » 13 Mar 2012, 19:09

@Ahau

I integrate V09 locales module with your package, now XFCE is better :Yahoo!:

Thanks very much !!!

Tonio
Contributor
Contributor
Posts: 266
Joined: 28 Dec 2010, 16:37
Distribution: Slackware,porteus,FreeBSD,Slax
Location: 127.0.0.1

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#26 by Tonio » 15 Mar 2012, 02:00

A couple of observations.

1) Upon booting up, I like to go in text mode and log in as guest. I log in and copy modules from a partition in the hard drive and I activate them one by one and type root password and we succeed. Then I log into beautiful XFCE desktop and fireup command line and try to activate a module that I forgot to activate and I get error, that /opt/porteus-script-activate? error. I need to su to root and then I can activate modules or deactivate them. Later I try to activate another module and it succeeds just enter root password and it works. Weird situation. I thought I had posted this yesterday, but I might have placed it in wrong thread :( ?

if this problem with activating /deactivating modules is known, I apologize in advance, otherwise, are there any users that have encountered such behavior?

2) I thought I mentioned this to Ahau, but I will restate this: Great Job!!! At first I did not believe it was an XFCE desktop, till I really clicked. I am acustomed to seeing two panels one on top and another where, we can click on thunar, terminal, firefox, find utility, and a folder , then the Applications Menu, I am used to see the little mouse, but Ahau customized it beautifully and put the Porteus icon/logo :) Simply amazing. Abiword and gnumeric are present, a document viewer, Gnome Mplayer, etc.

Great Job to all developers and contributors :) Also have a Happy Pi Day! 3/14

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#27 by Ahau » 15 Mar 2012, 05:34

Thanks, Tonio!

1) What command are you executing to get from text mode into XFCE? startx, startxfce4, telinit 4, lxdm, etc? I just tried and wasn't able to duplicate the error, but maybe there's something specific about the process. Or, it might be an issue that has already been resolved on my image, because I have modified some of the things that would affect this. Have you applied the patches from the google code page: http://code.google.com/p/porteus-xfce/downloads/list this would be the rc.M patch and the feb23rd patch. I'll keep trying to recreate this. Sometimes if I screw with it enough, it will fail to find the current session and will ask me if I want to start a new panel -- is this the error your getting, or is it literally "/opt/porteus-script-activate?" ?

2) Regarding the panel layout -- we did discuss this on mchat a bit, but it warrants saying again here -- I set up the panel in a way that made sense to me alone, since I'm so used to windows, kde and lxde. If users are interested I'd be more than happy to move the panel to the top, add a second panel with launchers, etc, and even to write some scripts that would allow users to customize this a little bit at startup. Would you (speaking broadly to Tonio and to all users) be interested in a configuration such as this?

Thanks again for your kind words! I'm glad you like it, and hope to make it better :)
Please take a look at our online documentation, here. Suggestions are welcome!

Tonio
Contributor
Contributor
Posts: 266
Joined: 28 Dec 2010, 16:37
Distribution: Slackware,porteus,FreeBSD,Slax
Location: 127.0.0.1

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#28 by Tonio » 15 Mar 2012, 20:38

"/opt/porteus-script-activate?"
Yes this was it. But like I said, I like to start in text mode, then login as guest and activate modules before I type startx. Everything works. Then while I am logged in and I create a new module or download one from the repository(ponce's), I get cannot activate and don't even get prompted to type root password. I switch to root activate the module successfully and then come back. Try it again as guest and it works. Just something that happen(ed)(s). But not really a problem. I have not applied any fixes or other modules. So you may have already corrected the issue ?

The panel is a luxury, I can post screen shots of my xfce desktop(s) if you like, but I would not ask for it just for myself. Folks need to ask for it, like voting for it. Otherwise don't worry about it you are doing a great job and don't do unncessary things :) Unless of course the Community wants it.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#29 by Ahau » 15 Mar 2012, 21:00

Well, we're all a part of the community, and you're opinion counts as much as anyone's (much more, in fact, since you have both expressed it and you have paid me a compliment, so you can expect preferential treatment over all of the silent and snarky bastards who provide no feedback :D ) Please do post a screenshot -- I can hardly match my socks to my pants (just ask my wife), so any style to emulate is much appreciated.

The way you're describing the activation problem, it is quite odd (how it comes and goes). The script that ought to be called is /opt/porteus-scripts/activate (not /opt-porteus-script-activate) --It may indeed already be fixed, because the inital release contained a known issue (activate/deactivate and a number of .desktop files in 32-bit were calling /opt/porteus-scripts/xorg/terminal -e, which didn't play nice with "Terminal" (the xfce terminal emulator), so guest users wouldn't be able to activate modules at all (I'm not sure how you're succeeding from the guest account even some of the time). Please do apply those patches from the google code page and let me know if the behavior improves.
Please take a look at our online documentation, here. Suggestions are welcome!

Tonio
Contributor
Contributor
Posts: 266
Joined: 28 Dec 2010, 16:37
Distribution: Slackware,porteus,FreeBSD,Slax
Location: 127.0.0.1

Re: Porteus-XFCE-v1.2-rc1-i486.iso is ready for testing!

Post#30 by Tonio » 15 Mar 2012, 23:24

Ahau wrote: Please do post a screenshot -- I can hardly match my socks to my pants (just ask my wife), so any style to emulate is much appreciated.
<a href="http://picturepush.com/public ... g" /></a>

http://picturepush.com/public/7806051


This is on a FreeBSD amd64 machine, in slackware the main panel is on bottom and not on top. In your implementation, it is much better looking than the default in slackware, but those are my $0.02. Many folks might not like this, so I leave that decision to you.
guest users wouldn't be able to activate modules at all (I'm not sure how you're succeeding from the guest account even some of the time). Please do apply those patches from the google code page and let me know if the behavior improves.
If you log on in text mode as guest, activate module.xzm works well , then you type startx. When you are in full gui(xfce) then fireup terminal and type activate othermodule.xzm, is when it fails. I will post what happens so you can see. But I do need to apply the fixes, but after I show you what I mean. OK!

EDIT:
To make sure it is xfce version of 1.2rc1 :)
guest@porteus:~$ uname -a
Linux porteus 3.1.8-porteus #1 SMP PREEMPT Sat Jan 7 11:08:29 UTC 2012 i686 AMD Phenom(tm) 8250e Triple-Core Processor AuthenticAMD GNU/Linux
guest@porteus:~$ cat /etc/porteus-version
Porteus-v1.2
guest@porteus:~$ ls /mnt/live/memory/images/ -l
total 0
drwxr-xr-x 6 root root 60 Jan 1 10:48 000-kernel.xzm/
drwxrwxrwx 19 root root 269 Feb 20 10:47 001-core.xzm/
drwxr-xr-x 11 root root 142 Feb 20 08:59 002-xorg.xzm/
drwxr-xr-x 7 root root 83 Feb 20 11:18 007-devel.xzm/
drwxr-xr-x 6 root root 61 Oct 15 22:26 008-firefox.xzm/
drwxr-xr-x 8 root root 95 Feb 19 08:55 0090-xfce.xzm/
drwxr-xr-x 6 root root 83 Feb 20 08:44 0091-xfce-apps.xzm/
drwxr-xr-x 3 root root 26 Mar 12 20:04 ghostscript-9.05-i486.xzm/
drwxr-xr-x 3 root root 26 Mar 12 20:02 ghostscript-fonts-std-8.11-i486.xzm/
Then before startup:

Code: Select all

guest@porteus:~$ cat .testmodulesbeforestartx.txt 
Script started on Thu 15 Mar 2012 06:32:59 PM UTC
guest@porteus:~$ cp /mnt/sdb4/home/olivares/tmp/porteus-i486-remaster/
addkertexpath2etcprofile.sh          ghostscript-9.05-i486.xzm
bison-2.4.3-i486-2.xzm               ghostscript-fonts-std-8.11-i486.xzm
ed-1.4-i486-1.xzm                    kertex-0.9999.3.0-i486-1_ast.xzm
flex-2.5.35-i486-1.xzm               lftp-4.2.2-i486-1.xzm
guest@porteus:~$ cp /mnt/sdb4/home/olivares/tmp/porteus-i486-remaster/kertex-0.9999.3.0-i486-1_ast.xzm .
guest@porteus:~$ cp /mnt/sdb4/home/olivares/tmp/porteus-i486-remaster/ghostscript-* .
guest@porteus:~$ ls -l
total 43912
drwxr-xr-x 2 guest guest        3 Jun 15  2011 Downloads/
-r--r--r-- 1 guest guest 12828672 Mar 15 18:33 ghostscript-9.05-i486.xzm
-r--r--r-- 1 guest guest  3629056 Mar 15 18:33 ghostscript-fonts-std-8.11-i486.xzm
-rw-r--r-- 1 guest guest 28508160 Mar 15 18:33 kertex-0.9999.3.0-i486-1_ast.xzm
guest@porteus:~$ activate ghostscript-fonts-std-8.11-i486.xzm 
Please enter root's password below
Password: 
Updating shared library links:  /sbin/ldconfig
guest@porteus:~$ activate ghostscript-9.05-i486.xzm 
Please enter root's password below
Password: 
Updating shared library links:  /sbin/ldconfig
guest@porteus:~$ exit
exit

Script done on Thu 15 Mar 2012 06:34:14 PM UTC
Then after:

Code: Select all

guest@porteus:~$ cat .activatemodulesinx.txt 
Script started on Thu 15 Mar 2012 06:35:16 PM UTC
guest@porteus:~$ cp /mnt/sdb4/home/olivares/Downloads/gkrellm
gkrellm-2.3.5.tar.bz2           gkrellm.pbuild
gkrellm-2.3.5.xzm               gkrellm.pusbuild
gkrellm-countdown-0.1.1.tar.gz  gkrellm.theme.defaults.diff.gz
guest@porteus:~$ cp /mnt/sdb4/home/olivares/Downloads/gkrellm-
gkrellm-2.3.5.tar.bz2           gkrellm-countdown-0.1.1.tar.gz
gkrellm-2.3.5.xzm               
guest@porteus:~$ cp /mnt/sdb4/home/olivares/tmp/porteus-i486-remaster/
addkertexpath2etcprofile.sh          ghostscript-9.05-i486.xzm
bison-2.4.3-i486-2.xzm               ghostscript-fonts-std-8.11-i486.xzm
ed-1.4-i486-1.xzm                    kertex-0.9999.3.0-i486-1_ast.xzm
flex-2.5.35-i486-1.xzm               lftp-4.2.2-i486-1.xzm
guest@porteus:~$ activate kertex-0.9999.3.0-i486-1_ast.xzm 
Unknown option "/opt/porteus-scripts/xactivate"
guest@porteus:~$ su -
Password: 
root@porteus:~# exit
logout
guest@porteus:~$ pwd
/home/guest
guest@porteus:~$ activate kertex-0.9999.3.0-i486-1_ast.xzm 
Unknown option "/opt/porteus-scripts/xactivate"
guest@porteus:~$ which activate
/usr/bin/activate
guest@porteus:~$ exit
exit

Script done on Thu 15 Mar 2012 06:37:03 PM UTC
Downloaded conky and now it behaves the same.

Code: Select all

guest@porteus:~$ cd Downloads/
guest@porteus:~/Downloads$ ls
conky-1.8.1-i486-1sl.xzm
guest@porteus:~/Downloads$ activate conky-1.8.1-i486-1sl.xzm 
Unknown option "/opt/porteus-scripts/xactivate"
guest@porteus:~/Downloads$ 
I get the rc. M pacch and now activating from terminal works :)

Code: Select all

guest@porteus:~/Downloads$ ls
conky-1.8.1-i486-1sl.xzm  xfce-patch-feb-23-i486.xzm  xfce-rc.M-patch.xzm
guest@porteus:~/Downloads$ activate xfce-rc.M-patch.xzm 
Going multiuser...
enabling dhcpcd on all available interfaces...
syslogd: Already running.
klogd: Already running.
Starting ACPI daemon:  /usr/sbin/acpid
 2183 ?        Ss     0:00 dbus-daemon
 2729 ?        Ss     0:00 dbus-daemon
 2762 ?        Ss     0:00 dbus-daemon
Starting ConsoleKit daemon:  /usr/sbin/console-kit-daemon
Starting HAL daemon:  /usr/sbin/hald --daemon=yes
Wicd appears to already be running.
If this is not the case, then remove 
/var/run/wicd/wicd.pid and try again...
Avahi mDNS/DNS-SD Daemon is already running (will not start it twice).
Avahi mDNS/DNS-SD DNS Server Configuration Daemon is already running (will not start it twice).
Starting gpm:  /usr/sbin/gpm -m /dev/mouse -t ps2
O0o.oops(): [startup.c(119)]: gpm is already running as pid 2468
starting autoexec commands
tr: write error: Broken pipe
tr: write error
Updating shared library links:  /sbin/ldconfig
Loading ALSA mixer settings:  /usr/sbin/alsactl restore
find: `/mnt/live/memory/images/xfce-rc.M-patch.xzm/usr/share': No such file or directory
/opt/porteus-scripts/xactivate: line 62:  3839 Terminated              Xdialog --title "$TITLE" --no-buttons --no-close --infobox "$BASE: module insertion in progress, wait please..." 0 0 9000  (wd: /home/guest/Downloads)
guest@porteus:~/Downloads$
however the other patch is taking long to finish

Code: Select all

guest@porteus:~/Downloads$ activate xfce-rc.M-patch.xzm 
Unknown option "/opt/porteus-scripts/xactivate"
guest@porteus:~/Downloads$ su -
Password: 
root@porteus:~# activate /home/guest/Downloads/xfce-patch-feb-23-i486.xzm 
Updating shared library links:  /sbin/ldconfig
Updating XFCE menu: xfce4-panel restart; update-desktop-database

it is staying there, and now module activation works again with gui(xfce) strange. But this explains the scenario.

EDIT:
Another screenshot xfce in Fedora:

http://picturepush.com/public/7806261

Post Reply