1.1 x86-64 LXDE

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

1.1 x86-64 LXDE

Post#1 by Rava » 06 Feb 2012, 22:31

My changes to 1.1:
Put nVidia-legacy-96.43.20-porteus-v1.1-x86_64-2beny into the base folder.

Starting lxde won't work, even when I started Porteus with the LXDE cheatcode from porteus.cfg

When I logged into the virtual terminal first as root, Porteus started X, seemingly as user root...
I thought prior the 1.0 finale it was a poll if X should be started as root or as non-root user and the majority voted for "non-root user"
(X was started with the generic /etc/X11/xorg.conf, while trying to start X as guest gave only an error and I needed to run nvidia-xconfig first)

So, I killed this X session. I also killed it, because I started 1.1 Porteus with the LXDE menu entry, still it started KDE.... :cry: And that, as LXDE or XFCe user is a no go. :D

Now, trying to start LXDE with startx from the guest account not works, it only starts KDE again.
Trying to start LXDE with startlxde does nothing from the console.
Again I need to go - just like I needed with 1.0 - to /etc/X11/xinit and do this as root:

Code: Select all

root@porteus:/etc/X11/xinit# rm xinitrc
root@porteus:/etc/X11/xinit# ln -s xinitrc.lxde xinitrc
Then X was started, LDXE was fired up and not KDE, but....

it made a nasty strange error, the desktop changed all the time between a light blue-grez background and the steel-grey Porteus background image.
At times the taskbar and startmenu in the lower area vanished, at times it was there like normal, and at rare moments I saw a window named lxde-greeter-gtk in the area where LXDE shows the running windows.
Maybe that program made the strange bug?

I got this error over and over again while that X session was running:

Code: Select all

lxpanel : X error: BadWindow (invalid Window parameter)
When I killed X with Ctrl+Alt+Backspace, it got started again but I could not say which virtual terminal did start X, since no VT was occupied, all 6 have been still free to use.
But at least now LXDE was started also as guest, and was not flickering or whatever you might call that error I described above, and was okay for use...

Here now again the two main issues with 1.1 and LXDE / startx for me:

1 ) That the looged in root user started X already, when I don't want root to start x, unless I tell root so manually, and on purpose.

2 ) The strange things with the "flickering desktop" the first time I started X as guest...

________________________________________________

Now I try to start the 1.1 from other PCs with NVidia GPU and give you my heads up on how other machines react to the same Linux / Porteus system...

But one good thing already can be told: The PC I first started the 1.1 x86-64 with (see the above bugs) is the same as the 120 sec. after /sbin/udevadm trigger bug, and the 1.1 not creates that bug. :) :friends:
Cheers!
Yours Rava

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: 1.1 x86-64 LXDE

Post#2 by fanthom » 07 Feb 2012, 03:00

hi Rava,

you always has a bunch of surprises for me :)
Starting lxde won't work, even when I started Porteus with the LXDE cheatcode from porteus.cfg
believe me or not - i have started lxde 1000 times already and it always work. please make sure that you have "lxde" cheatcode in porteus.cfg and not "LXDE" or "autoexec=lxde".
I also killed it, because I started 1.1 Porteus with the LXDE menu entry, still it started KDE.... :cry:
lxde menu entry uses 'lxdm' and 'kdm' helpers which are an improvement over 'startx' (offers switching to another session, sleep, hibernate, etc...) . startx still relies on /etc/X11/xinit/xinitrc symlink which points to kde when this module is activated.
Again I need to go - just like I needed with 1.0 - to /etc/X11/xinit and do this as root:

Code: Select all
root@porteus:/etc/X11/xinit# rm xinitrc
root@porteus:/etc/X11/xinit# ln -s xinitrc.lxde xinitrc
you should run 'xwmconfig' utility instead and choose your desktop -> run startx
it made a nasty strange error, the desktop changed all the time between a light blue-grez background and the steel-grey Porteus background image.
were you able to reproduce the error in any way? did you try to boot without nvidia driver?
the looged in root user started X already, when I don't want root to start x, unless I tell root so manually, and on purpose.
default runlevel in Porteus-1.1 was changed to '4' which is GUI. you supposed to boot into "text mode" and then you should stay in cli without problems.
Please add [Solved] to your thread title if the solution was found.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: 1.1 x86-64 LXDE

Post#3 by Rava » 07 Feb 2012, 21:26

fanthom wrote:you always has a bunch of surprises for me :)
I try my very best to be helpful. :)
fanthom wrote:
Starting lxde won't work, even when I started Porteus with the LXDE cheatcode from porteus.cfg
believe me or not - i have started lxde 1000 times already and it always work. please make sure that you have "lxde" cheatcode in porteus.cfg and not "LXDE" or "autoexec=lxde".
This is the append I used:
APPEND initrd=/boot/initrd.xz vga=0x314 lxde

Yes, I changed the vga= value. And I removed the changes=/porteus/ entry, since it is a vfat USB pendrive anyway...
But otherwise (from the changes top append I just mentioned), I copied the whole LXDE entry and used that.
fanthom wrote:you should run 'xwmconfig' utility instead and choose your desktop -> run startx
But, for the less experienced user and new users to Porteus... shouldn't that work on its own, just by using the cheatcode "lxde" ?

And I presume, the xwmconfig also does adjust the link in /etc/X11/xinit, yes?
fanthom wrote:
it made a nasty strange error, the desktop changed all the time between a light blue-grez background and the steel-grey Porteus background image.
were you able to reproduce the error in any way? did you try to boot without nvidia driver?
Nope, not tried it without the nVidia driver. But I try to boot the very same system with another PC, also with NVidia GPU. Then I try to boot it on the same PC as above, but with the other nVidia driver. (Also, I will boot in on the same PC as above again, with the very same configuration as described above to see if it gives me the same results or not...)

I just not had the time so far, since I also need a running system once in a while to do my work and stuff. And that is still 1.0 fo9r now, but I am working to get 1.1 up and running as it should. :D :)
fanthom wrote:
the looged in root user started X already, when I don't want root to start x, unless I tell root so manually, and on purpose.
default runlevel in Porteus-1.1 was changed to '4' which is GUI. you supposed to boot into "text mode" and then you should stay in cli without problems.
... But I did not change anything with the startup. You see my append line above. Just removing the changes= entry and changing the vga= entry should not make Porteus behave in that way... like, moving from "4" to "3". It was obviously starting up in cli mode, since I could log into tty1 to tty6. And only after logging into tty1 Porteus tried to start X, not before that... :unknown:

But like I said, I will try the very same USB pendrive on other PCs and give you the heads up about what happened...

Written after 11 hours 58 minutes 54 seconds:
##### update #####

When I started the very same Porteus with the same nVidia driver, this is what happened:
Without logging in, it gave me "Starting up X11 session manager... [several times]" but was not able to start X.

Even after adjustments in /etc/X11/xinit and nvidia-xconfig I still got it all the time

Starting up X11 session manager... [several times]
INIT: Id "x1" respawning too fast: disabled for 5 minutes

Then it started all over again. :unknown:
Cheers!
Yours Rava

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: 1.1 x86-64 LXDE

Post#4 by fanthom » 07 Feb 2012, 22:15

But, for the less experienced user and new users to Porteus... shouldn't that work on its own, just by using the cheatcode "lxde" ?
ok you won.
i hate to do this as it will create unnecessary I/O during boot (i believe you are the one of the very few - if not only person who is still using startx) but next version of Porteus despite of calling lxdm will also replace this symlink.
And I presume, the xwmconfig also does adjust the link in /etc/X11/xinit, yes?
yes
When I started the very same Porteus with the same nVidia driver, this is what happened:
Without logging in, it gave me "Starting up X11 session manager... [several times]" but was not able to start X.
are you sure that your GPU is supported by nVidia-legacy driver and not the latest one? please show me 'lspci | grep VGA'
please also try without any nVidia driver (just nouveau) to check that your installation is ok.
Please add [Solved] to your thread title if the solution was found.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: 1.1 x86-64 LXDE

Post#5 by Rava » 07 Feb 2012, 22:59

fanthom wrote:i hate to do this as it will create unnecessary I/O during boot (i believe you are the one of the very few - if not only person who is still using startx) but next version of Porteus despite of calling lxdm will also replace this symlink.
Thanks, that is great! :)
fanthom wrote:are you sure that your GPU is supported by nVidia-legacy driver and not the latest one? please show me 'lspci | grep VGA'
please also try without any nVidia driver (just nouveau) to check that your installation is ok.

Code: Select all

04:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 LE] (rev a1)
This is the first PC I tested.

I will try booting it with nouveau as well, aka just removing the nVidia driver from /base...

I will give you the updates tomorrow. Good night for now...
Cheers!
Yours Rava

beny
Full of knowledge
Full of knowledge
Posts: 730
Joined: 02 Jan 2011, 11:33
Location: italy

Re: 1.1 x86-64 LXDE

Post#6 by beny » 08 Feb 2012, 20:56

rava, you can use the 290.10 x86 nvidia driver with this video card not legacy, i have the same card now.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: 1.1 x86-64 LXDE

Post#7 by Rava » 08 Feb 2012, 21:11

beny wrote:rava, you can use the 290.10 x86 nvidia driver with this video card not legacy, i have the same card now.
Okay, I try...
Now this is the output with the 2nd PC I tested in on:

Code: Select all

root@porteus:~# uname -p;lspci | grep VGA
AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
02:00.0 VGA compatible controller: nVidia Corporation G98 [GeForce 8400 GS] (rev a1)
What is wrong with the nVidia-legacy-96.43.20-porteus-v1.1-x86_64-2beny driver?

@Fanthom
I suggest that when a module is created for a GPU, like ATI, nVidis or whatever, that the needed change, like running nvidia-xconfig is done via a /etc/rc.d/whatever script...
So that a system with Porteus and a GPU driver module runs out of the box. Just my 2 cents on how to make like easier for the new users to Porteus...
Cheers!
Yours Rava

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: 1.1 x86-64 LXDE

Post#8 by fanthom » 08 Feb 2012, 22:45

What is wrong with the nVidia-legacy-96.43.20-porteus-v1.1-x86_64-2beny driver?
maybe it does not support fully your GPU? trying 290.10 wont harm...
I suggest that when a module is created for a GPU, like ATI, nVidis or whatever, that the needed change, like running nvidia-xconfig is done via a /etc/rc.d/whatever script...
there is a config created by nvidia-xconfig already which i tested on 2 GPU's (one legacy) and worked ok.
So that a system with Porteus and a GPU driver module runs out of the box
are you saying that it doesn't? if yes then please write once again which driver doesn not work on which GPU. please make sure you are using right driver for right GPU.
Please add [Solved] to your thread title if the solution was found.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: 1.1 x86-64 LXDE

Post#9 by Rava » 08 Feb 2012, 23:42

fanthom wrote:are you saying that it doesn't? if yes then please write once again which driver doesn not work on which GPU. please make sure you are using right driver for right GPU.
After running nvidia-xconfig it works, but not without running that,

My idea is just to have that running by itself as soon as a user uses a GPU driver, like the nVidia-whatever ones...

Written after 39 minutes 39 seconds:
Update

On the

Code: Select all

AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
02:00.0 VGA compatible controller: nVidia Corporation G98 [GeForce 8400 GS] (rev a1)
machine, X refused to start at all. But now I switched to the 290.10 and all works well. [It even accepts the old xorg.conf that I created running Porteus 1.0 ...]
Cheers!
Yours Rava

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: 1.1 x86-64 LXDE

Post#10 by Rava » 23 Feb 2012, 23:53

fanthom wrote:
But, for the less experienced user and new users to Porteus... shouldn't that work on its own, just by using the cheatcode "lxde" ?
ok you won.
i hate to do this as it will create unnecessary I/O during boot (i believe you are the one of the very few - if not only person who is still using startx) but next version of Porteus despite of calling lxdm will also replace this symlink.
Just my idea:

LXDE is loaded before KDE is loaded, yes?
Why not put the symlink in the module to point towards lxde...

and then, when KDE is used afterwards, it lets it point to KDE.

Now, a user that wants both modules (let's say, to have the libraries of KDE and a few programs, but not runs KDE) just needs to put LXDE AFTER KDE.
The standard user not needs to change anything,

And the XFCe module can do the same, put the symlink to .xfce.

Now, when a user only uses one of these modules, all works out of the box.


If a user wants to use more, we just have to give the info that (s)he has to put the most frequently used X environment module at the bottom of the /base/line...
Cheers!
Yours Rava

User avatar
fanthom
Site Admin
Site Admin
Posts: 4618
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: 1.1 x86-64 LXDE

Post#11 by fanthom » 24 Feb 2012, 09:59

LXDE is loaded before KDE is loaded, yes?
Why not put the symlink in the module to point towards lxde...
this is already done Rava.
please boot porteus-1.1 with 'autoexec=telinit~3,startx' cheat and you will get into kde desktop.
when you rename 004-kde.xzm as 003-kde.xzm and 003-lxde.xzm as 004-kde.xzm the same cheat will log you into lxde desktop.
'lxde' cheatcode is not necessary then.

rc1 of porteus-1.2 swaps the symlinks in rc.M so it's better to use (or not use) lxde cheat than changing the order of base modules as it may break other things.
Please add [Solved] to your thread title if the solution was found.

Post Reply