USM v3.1.4 errors

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

USM v3.1.4 errors

Post#1 by Rava » 09 Sep 2014, 03:44

I still get the usm update error, even after upgrading to Port 3.0.1

This happened when I activate my old usm-database module:

Code: Select all

root@porteus:~# usm version

 You are using USM version:  3.1.4

root@porteus:/var# usm -u all
root@porteus:/mnt/live/memory/images# usm -u all
alien was already updated today. Skipping.
 Starting salix database update 
Downloading: vercheck.txt  DONE
Downloading: CHECKSUMS.md5  DONE
Downloading: PACKAGES.TXT  DONE
Downloading: LIBS.TXT.gz  DONE
Downloading: OPTIFEST.gz  DONE
Downloading: MANIFEST.bz2  DONE
bunzip2: /var/usm/salix/MANIFEST.bz2 is not a bzip2 file.
          

==============================================================================
WARNING!        WARNING!        WARNING!        WARNING!        WARNING!
==============================================================================
One or more errors occurred while usm was running:                       
 
FATAL ERROR!
usm update_database 232
Could not decompress: MANIFEST.bz2
 
============================================================================== 

root@porteus:/mnt/live/memory/images# file /var/usm/salix/MANIFEST.bz2
/var/usm/salix/MANIFEST.bz2: gzip compressed data, from Unix, max speed
When none of you can reproduce this error... could it be I access a salix mirror different from you guys?


Then I deactivated my usm-database module and also rm -r /var/usm. Now it's kinda worse since usm froze, and after ^C I get the same error:

Code: Select all

root@porteus:/var# usm -u all
 Starting alien database update 
Downloading: vercheck.txt  DONE
Downloading: CHECKSUMS.md5.gz  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT.gz  DONE
Downloading: LIBS.TXT.gz  DONE
File verification was good.
Optimizing manifest
 alien  database updated. 

Updating config file
[usm freezes]
^C      
root@porteus:/var# usm -u all
alien was already updated today. Skipping.
 Starting salix database update 
Downloading: vercheck.txt  DONE
Downloading: CHECKSUMS.md5  DONE
Downloading: PACKAGES.TXT  DONE
Downloading: LIBS.TXT.gz  DONE
Downloading: OPTIFEST.gz  DONE
Downloading: MANIFEST.bz2  DONE
bunzip2: /var/usm/salix/MANIFEST.bz2 is not a bzip2 file.
          

==============================================================================
WARNING!        WARNING!        WARNING!        WARNING!        WARNING!
==============================================================================
One or more errors occurred while usm was running:                       
 
FATAL ERROR!
usm update_database 232
Could not decompress: MANIFEST.bz2
 
============================================================================== 

Also, downloading is not working. What do I do wrong?

Code: Select all

root@porteus:~# usm -s git-1

git-1.8.4-x86_64-1.txz was found in slackware
Packages found:   1 

Use:   usm -i <package>  for more info
Use:   usm -g <package>  to download

root@porteus:~# usm -i git-1.8.4-x86_64-1

Package:  git-1.8.4-x86_64-1.txz  (3836 K) [not installed]
git: git (the stupid content tracker)
git:
git: Git is a fast, scalable, distributed revision control system with an
git: unusually rich command set that provides both high-level operations
git: and full access to internals.
git:
git: "git" can mean anything, depending on your mood.
git:
git: Git was originally written by Linus Torvalds and is currently
git: maintained by Junio C. Hamano.
git:

root@porteus:~# usm -g git-1.8.4-x86_64-1

 Nothing found for:  git-1.8.4-x86_64-1 

root@porteus:~# usm -g git-1.8.4-x86_64-1.txz

 Nothing found for:  git-1.8.4-x86_64-1.txz 
Why does usm -i work and usm -g not?
Cheers!
Yours Rava

User avatar
Ed_P
Contributor
Contributor
Posts: 3201
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: USM v3.1.4 errors

Post#2 by Ed_P » 09 Sep 2014, 04:23

Try the approach shown here Rava: viewtopic.php?f=75&t=3040&start=300#p27520

It worked for me.
Ed

User avatar
brokenman
Site Admin
Site Admin
Posts: 5503
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM v3.1.4 errors

Post#3 by brokenman » 09 Sep 2014, 14:01

From a fresh v3.0.1 this is what I get:

Code: Select all

root@porteus:/mnt/sda8/projects/kiosk/storage# usm -v

 You are using USM version:  3.1.4

root@porteus:/mnt/sda8/projects/kiosk/storage# usm -g git

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) git-1.8.4-x86_64-1.txz
could it be I access a salix mirror different from you guys?
No. The MANIFEST.bz2 file is downloaded from sourceforge as it doesn't exist in salix. In fact you can open the file /etc/usm/files.txt and remove MANIFEST.bz2 from the salix section as it is not needed anymore. (will update next release).

So my advice would be to do: usm -u usm
Then try updating the databases.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM v3.1.4 errors

Post#4 by Rava » 09 Sep 2014, 19:40

I also get an error, but it seems to work:

Code: Select all

root@porteus:/var# usm -u usm
Downloading: vercheck.txt  DONE

 An update is available for the usm database files.
 Please run:  usm -u all 

 A new version of USM is available.
 Would you like to download it now? [y/n]
Downloading: usm-latest-0.0-noarch-1.txz  DONE
 Would you like to install it now? [y/n]

No such package: /var/log/packages/usm-*. Can't remove.
  Installing new version now 
xz: (stdin): File format not recognized
usm-latest-0.0-noarch-1:                                                 [0K]  
WARNING:  Package has not been created with 'makepkg'

 USM was updated successfully
 You are currently using:
 USM-v3.1.4 
How do I create an usm-3.1.4.xzm, or even better, how to update the module of Port 3.0.1 that has the outdated usm?

//edit
Found a typo in the help:
nodeps: No dpepndency resolution.
-> "nodeps: No dependency resolution."
Cheers!
Yours Rava

User avatar
brokenman
Site Admin
Site Admin
Posts: 5503
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM v3.1.4 errors

Post#5 by brokenman » 09 Sep 2014, 23:26

No such package: /var/log/packages/usm-*. Can't remove.
In a default porteus install there should be the package: /var/log/packages/usm-*
This is not so important, but it shows that your Porteus install has been modified?

You are currently using:
USM-v3.1.4

The latest version is USM-v3.1.6
The typo nodeps: No dpepndency resolution. was fixed in 3.1.6

How do I create an usm-3.1.4.xzm, or even better, how to update the module of Port 3.0.1 that has the outdated usm?
You can download a module from here

Or download and install the .txz package from the same address. Thanks.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM v3.1.4 errors

Post#6 by Rava » 12 Sep 2014, 19:36

brokenman wrote:The latest version is USM-v3.1.6
Downloaded and activated the module, now all seems to work fine... Searching and updating the databases is OK...

But... downloading still not works:

Code: Select all

root@porteus:/mnt/live/memory# usm -s midori

midori-0.5.8-x86_64-1ponce.txz was found in ponce
midori-0.5.8-x86_64-2gv.txz was found in salix
Packages found:   2 

Use:   usm -i <package>  for more info
Use:   usm -g <package>  to download

root@porteus:/mnt/live/memory# usm -i midori-0.5.8-x86_64-1ponce.txz

Package:  midori-0.5.8-x86_64-1ponce.txz  (2716 K) [not installed]
midori: midori (simple web-browser)
midori:
midori: midori is a simple web-browser, based on the webkit framework.
midori:
midori:
midori:
midori: Homepage: http://midori-browser.org/
midori:
midori:
midori:
midori:

root@porteus:/mnt/live/memory# usm -g midori-0.5.8-x86_64-1ponce.txz

 Nothing found for:  midori-0.5.8-x86_64-1ponce.txz 

root@porteus:/mnt/live/memory# usm -g midori-0.5.8-x86_64-1ponce

 Nothing found for:  midori-0.5.8-x86_64-1ponce 
When running the usmgui it said something along the line of "brokenman needs to update [... some file ...]"
When I see that error again I will post it...
Last edited by Rava on 13 Sep 2014, 07:47, edited 1 time in total.
Cheers!
Yours Rava

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM v3.1.6 errors

Post#7 by Rava » 13 Sep 2014, 07:44

Got another issue just now... usm v3.1.6 has issues updating the databases.

Code: Select all

root@porteus:/var/usm/alien# usm -u all
alien was updated 14 seconds ago. Skipping.
salix was updated 14 seconds ago. Skipping.
slacky was updated 14 seconds ago. Skipping.
 Starting ponce database update
Downloading: vercheck.txt  DONE
Downloading: CHECKSUMS.md5.gz  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT.gz  DONE
Downloading: LIBS.TXT.gz  DONE
Optimizing manifest
 ponce  database updated.

Updating config file

slackware was updated 20 seconds ago. Skipping.
slackwarepatches was updated 20 seconds ago. Skipping.
 Starting sbo database update
SLACKBUILDS.TXT.gz
Downloading: SLACKBUILDS.TXT.gz  DONE
 sbo  database updated.

Updating config file


Downloading: extra-deps.txt  DONE
Downloading: ignore-deps.txt  DONE

root@porteus:/var/usm/alien# ls -l
total 412
-rw-r--r-- 1 root root 166887 Sep 11 00:43 CHECKSUMS.md5
-rw-r--r-- 1 root root  35972 Sep 11 09:21 LIBS.TXT
-rw-r--r-- 1 root root  77606 Sep 11 09:21 OPTIFEST
-rw-r--r-- 1 root root 136850 Sep 11 09:21 PACKAGES.TXT
root@porteus:/var/usm/alien# date
Sat Sep 13 09:35:13 CEST 2014
Not only usm is mistaken when alien was updated ("14 seconds ago. Skipping.") but same is true for:
  • "salix was updated 14 seconds ago. Skipping."
    "slacky was updated 14 seconds ago. Skipping."
    "slackware was updated 20 seconds ago. Skipping."
    "slackwarepatches was updated 20 seconds ago. Skipping."
All these have last been updated 2 days ago... still usm insists that instead of 2 days, it was 14 or 20 seconds ago...
Cheers!
Yours Rava

User avatar
brokenman
Site Admin
Site Admin
Posts: 5503
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: USM v3.1.4 errors

Post#8 by brokenman » 14 Sep 2014, 16:14

Once you've updated to v3.1.6 please provide output of: usm info
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Ed_P
Contributor
Contributor
Posts: 3201
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

Re: USM v3.1.6 errors

Post#9 by Ed_P » 14 Sep 2014, 21:53

brokenman wrote:Once you've updated to v3.1.6
It sounds like he has upgraded to it.
Rava wrote:Got another issue just now... usm v3.1.6 has issues updating the databases.
Ed

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM v3.1.4 errors

Post#10 by Rava » 16 Sep 2014, 20:01

brokenman, here you go:

Code: Select all

root@porteus:/usr/local/bin# usm info
++++++++++++++++++++++++++++++
usm application information

USM version:  3.1.6
DB version:  140901
Current storage: /tmp/usm
Current config: /etc/usm/usm.conf
Current platform: Porteus-v3.0.1
Current arch: x86_64
Slackware Slackware 14.1
Current kernel 3.14.15-porteus
Current distros: slackware slackwarepatches slacky salix alien ponce
quiet initrd=initrd.xz sgnfile=intHDE.sgn ramsize=45% zram=20% timezone=Europe/Berlin volume=75% kmap=de BOOT_IMAGE=vmlinuz 

 Use: usm -i <package> 
 For example: usm -i imagemagick
(This is without my usm databases module loaded, fresh after reboot)
Cheers!
Yours Rava

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM v3.1.6 errors

Post#11 by Rava » 25 Sep 2014, 11:20

And another update. Usm version is still 3.1.6.

Code: Select all

root@porteus:/var# usm -s alpine

alpine-2.11-x86_64-1.txz was found in slackware
Packages found:   1 

Use:   usm -i <package>  for more info
Use:   usm -g <package>  to download

root@porteus:/var# usm -g alpine-2.11-x86_64-1.txz

 Nothing found for:  alpine-2.11-x86_64-1.txz 

root@porteus:/var# usm -g alpine-2.11-x86_64-1

 Nothing found for:  alpine-2.11-x86_64-1 
Sadly, I am not able to download any package via usm... :(

Also, this probably minor bug:

Code: Select all

root@porteus:/Lsfind# usm -u usm
Downloading: vercheck.txt  DONE

/usr/share/usm/funcupdateDatabase: line 381: [: -gt: unary operator expected
No database updates were found.

/usr/share/usm/funcupdateDatabase: line 394: [: -gt: unary operator expected
You have the current USM version.
Cheers!
Yours Rava

beny
Full of knowledge
Full of knowledge
Posts: 728
Joined: 02 Jan 2011, 11:33
Location: italy

Re: USM v3.1.4 errors

Post#12 by beny » 25 Sep 2014, 19:42

sorry rava but with slackware in portable way usm work great:
Processing: alpine-2.11-x86_64-1.txz
Ignored libraries:

Libraries required: 10
Libraries found in system: 10
Libraries to resolve: 0



The following packages are required.
alpine-2.11-x86_64-1.txz [1896K]

Total size: 1 MB

Press [r] to remove packages, [q] to quit, or enter to start downloading.

Updates are available.
Program update: not required
Database update: available
Please run: usm -u all and/or usm -u usm
This message can be disabled in /etc/usm/usm.conf
###############################
Downloading: alpine-2.11-x86_64-1.txz DONE

well isn't porteus but it is the same i have a full environment.

SM version: 3.1.6
DB version: 140901
Current storage: /tmp/usm
Current config: /etc/usm/usm.conf
Current platform: UNKNOWN
Current arch: x86_64
Slackware Slackware 14.1
Current kernel 3.12.6
Current distros: slackware slackwarepatches slacky salix alien ponce
quiet auto BOOT_IMAGE=vmlinuz-3.12.6

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM v3.1.4 errors

Post#13 by Rava » 27 Sep 2014, 22:30

^
*facedesks* I am at my wit's end... maybe I did an mistake when I included the current usm in my Port 3.0.1 xzm...
Creating my updated 001-core.xzm I renamed it to to 001-core-rava-usm_3.1.6.xzm to reflect the changes made in it.
Cheers!
Yours Rava

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: USM v3.1.6 errors

Post#14 by Rava » 28 Sep 2014, 05:45

*Update*

I activated the usm-noarch-3.1.6 module... that should have fixed any potential errors I made while including usm in my 001- module... but to no preveail. It keeps getting to this:

Code: Select all

root@porteus:/# usm -s gimp

gimp-2.8.6-x86_64-1.txz was found in slackware
Packages found:   1 

Use:   usm -i <package>  for more info
Use:   usm -g <package>  to download

root@porteus:/# usm -g gimp-2.8.6-x86_64-1.txz

 Nothing found for:  gimp-2.8.6-x86_64-1.txz 
... or could it be that the error is somehow connected to another error...

I run usm via XFCe's terminal... I either use "su" or "su -" there. But even "su -" behaves strange...
from man su:
-, -l, --login
Provide an environment similar to what the user would expect had
the user logged in directly.

When - is used, it must be specified as the last su option. The
other forms (-l and --login) do not have this restriction.
Going to the home directory using "cd" ... gets me to ~ ... but it is not /root, but /home/guest...
Could this be the reason why my usm behaves strangely?

///
Update
Nope, just tried it in the virtual terminal where I logged in as root directly. There a "cd" gets me to "/root", so the above issue is not there. Still I get the same old error as quoted on top of this post.

Anyway, I don't see anything about dependencies... Gimp needs at least babl and gegl... Would that be solved during the download phase (that's not working for me?)
Cheers!
Yours Rava

Bogomips
Full of knowledge
Full of knowledge
Posts: 2560
Joined: 25 Jun 2014, 15:21
Distribution: 3.2.2 Cinnamon & KDE5
Location: London

Re: USM v3.1.4 errors

Post#15 by Bogomips » 28 Sep 2014, 11:55

Code: Select all

root@porteus:/home/guest# usm -g gimp-2.8.6-x86_64-1

 Nothing found for:  gimp-2.8.6-x86_64-1 

root@porteus:/home/guest# usm -g gimp

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) gimp-2.8.6-i486-1.txz
#? 1

Processing:   gimp-2.8.6-i486-1.txz 
Ignored libraries: 

Libraries required:  95
Libraries found in system: 78
Libraries to resolve: 17

Processing library: libaa.so.1
Processing library: libbabl-0.1.so.0
Processing library: libgegl-0.2.so.0
Processing library: libgimp-2.0.so.0
Processing library: libgimpbase-2.0.so.0
Processing library: libgimpcolor-2.0.so.0
Processing library: libgimpconfig-2.0.so.0
Processing library: libgimpmath-2.0.so.0
Processing library: libgimpmodule-2.0.so.0
Processing library: libgimpthumb-2.0.so.0
Processing library: libgimpui-2.0.so.0
Processing library: libgimpwidgets-2.0.so.0
Processing library: libgs.so.9
Processing library: libjasper.so.1
Processing library: libpoppler.so.43
Processing library: libwmf-0.2.so.7
Processing library: libwmflite-0.2.so.7


Processing:   aalib-1.4rc5-i486-5.txz 
8)
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB

Post Reply