Page 3 of 4

Re: "Must have apps" - 64bit official repo requests

Posted: 14 Sep 2012, 19:47
by att
Ok, fanthom, I see your point.
By the way, .... another big wish of mine: SABNZBD is just one of the best binary newsreaders. A true must-have for Porteus, IMHO! :Yahoo!:

Re: "Must have apps" - 64bit official repo requests

Posted: 22 Sep 2012, 08:13
by ncmprhnsbl
this is maybe the place to make a request for Mypaint and its python deps.... this might be helpful.... https://github.com/gperon/my_slackbuild ... er/mypaint ... i have no slackware at present..
.. and then i think- the development version is quite stable http://mypaint.intilinux.com/?page_id=18 ..git, scons needed to build it..
...also, there is some backgrounds( /usr/share/mypaint/backgrounds/ramon +mrmamurk) that can be removed, or made a separate module
slimming from 30+ to 5 mb (tested in 32bit version)...

while i'm at it, how about this: krita >2.4 ..but.. with as little of calligra as possible?

thanks

Re: "Must have apps" - 64bit official repo requests

Posted: 24 Sep 2012, 08:34
by fanthom
@ncmprhnsbl

i'm relly busy this week but may try to compile mypaint in early October.
if you dont want to wait then please follow this guide:
link
and share the module in case of success.

Calligra is another huge task so i would rather wait on first RC of Porteus-2.0 and then use slackware-14.0 package.
(we have libreoffice for porteus-1.x and that should be enough for majority of users).

Cheers

Re: "Must have apps" - 64bit official repo requests

Posted: 25 Sep 2012, 22:33
by ncmprhnsbl
thanks fanthom , that link looks like what i need ... 'slack4dummies' :crazy:
i'll mess about with it if i have some time..
i sort figured krita would be down the track..i dont generally have more than a text editor myself..

..when you say porteus 2.0, is that the next version? after 1.2..

Re: "Must have apps" - 64bit official repo requests

Posted: 03 Oct 2012, 21:11
by fanthom
@att
apologize as i have forgotten about your request.
glad to see that you were able to get SABNZBD module yourself.

@ncmprhnsbl
added mypaint to the repo.
here is the list of deps (python ones so not resolved by PPM):

Code: Select all

numpy-1.6.0-x86_64-1sl.xzm
pycairo-1.8.10-x86_64-1.xzm
pygobject-2.26.0-x86_64-1.xzm
pygtk-2.22.0-x86_64-2ftm.xzm
python-2.6.6-x86_64-1.xzm
scons-2.0.1-x86_64-1sl.xzm
swig-2.0.6-x86_64-1ftm.xzm
Cheers

Re: "Must have apps" - 64bit official repo requests

Posted: 04 Oct 2012, 08:22
by ncmprhnsbl
Thank you fanthom, much appreciated. :beer:
tested and runs fine,
one thing, scons is a build dependency and not needed to run it (tho i might use it to try to make the git version)
cheers

Re: "Must have apps" - 64bit official repo requests

Posted: 26 Oct 2012, 18:26
by miguipda
Hi,

as a "Must have apps" is also SweetHome 3D : http://www.sweethome3d.com/index.jsp

then if some of you could offre ot to us it could be appreciate.

Have a nice dday,

Miguipda ;-)

Re: "Must have apps" - 64bit official repo requests

Posted: 26 Oct 2012, 22:33
by Hamza
@Miguipda,

Here you go!

viewtopic.php?f=49&t=1630

Enjoy ;-)

Re: "Must have apps" - 64bit official repo requests

Posted: 04 May 2013, 16:04
by att
Can you perhaps help me to update the "tigervnc" module?
I tried to make it myself, but ran into some problems. My old module is tigervnc-1.1.0-x86_64-2alien.xzm.
I wanted to update to 1.2.0, but when I tried to run it, it said "LibPAM required" - and I don't have it, nor know how to install it.

Also, I would be glad if I could run "Teamviewer 8" inside a Tigervnc-created vncserver window. So far, it crashes after 3 secs; only Teamviewer 7 works fine.

Any help appreciated.

Re: "Must have apps" - 64bit official repo requests

Posted: 04 May 2013, 20:00
by fanthom
@att

AlienBob downgraded tigervnc to 1.1:

Code: Select all

# 1.1.0-2:    28/jul/2012 by Eric Hameleers <alien@slackware.com>
#             * Build 1.1.0 again, using a revised script which can be used
#               on Slackware 14 as well.  Also, enable compositing in the
#               server.  Abandon the tigervnc-1.2 branch for now, because
#               the fltk based viewer rewrite is not yet fully functional.
despite of that you may try to get 1.2 from 13.37 repo. please boot in always fresh and download from here:
http://www.slackware.com/~alien/slackbu ... g64/13.37/
you'll also need older 'gnutls' package from 13.37.
try it and if not happy then delete both as old gnutls as it may break other slackware-14.0 packages. if you'll be happy with tigervnc-1.2 then you'll have to compile it from sources in porteus-2.0 to link against recent version of gnutls.

Re: "Must have apps" - 64bit official repo requests

Posted: 22 Oct 2013, 06:42
by freestyler
any chance of adding whisker menu and guake terminal?

Re: "Must have apps" - 64bit official repo requests

Posted: 28 Oct 2013, 15:48
by fanthom
in the repo now. please read a warning from the changelog reg guake.

Re: "Must have apps" - 64bit official repo requests

Posted: 05 Nov 2013, 08:19
by freestyler
Thanks for the adds. Is it possible to also add polipo and libc6 to the repo?

Re: "Must have apps" - 64bit official repo requests

Posted: 05 Nov 2013, 12:02
by fanthom
will add polipo during next update but 'libc6' is just glibc and we have it already in the system as it's the main lib (moreover - you cant change/update/downgrade it without breaking the whole system). is it needed by some debian app? if yes then you must use slackware package i'm afraid.

Re: "Must have apps" - 64bit official repo requests

Posted: 05 Nov 2013, 20:37
by freestyler
Thanks mate. Yeah I've had some issues with glibc6 working with some deb packages. I spent all yesterday trying to upgrade it. You just saved me an extra day or 2 of messing around now that i know it cant be changed. Cheers!