video editing software

Non release banter
User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: video editing software

Post#46 by Rava » 15 Nov 2016, 06:55

francois wrote:pitivi under porteus seems to work well.

Kino from usm misses some libraries. The good news is that it could be built easily from:

Code: Select all

usm sbo -s kino
Is that a kde program or will it run okay with XFCe?

___________________________________
brokenman wrote:Most screen recording apps use ffmpeg as a backend. This is my go to for screen recording. If you know how to use it you have FULL control of your recording.
I tried it once and it works like a charm, like you said, when you know how to run it it's like s charm. A little graphical helper would be nice, e.g. that lets you use the mouse prior recording to set the x,y and width/height of the area to be recorded, just like a run-of-the-mill screenshot utility works. Since there are already many screenshot utilities, it should not be that hard to implement. Maybe it already exists?
Cheers!
Yours Rava

User avatar
brokenman
Site Admin
Site Admin
Posts: 5659
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: video editing software

Post#47 by brokenman » 15 Nov 2016, 14:14

The last one that I found (and liked) was called 'obs' which allows overlaying a camera like you see in many vlogs.
http://ftp.vim.org/ftp/os/Linux/distr/p ... 2/bundles/
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
francois
Contributor
Contributor
Posts: 5136
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: video editing software

Post#48 by francois » 02 Dec 2016, 13:35

Is that a kde program or will it run okay with XFCe?
I have built it from kde. It works in the kde environment for me.

Kino.

Necessary package and libraries under porteus 3.1:
ffmpeg-2.6.3-x86_64_custom-1ponce.xzm
kino-1.3.4-x86_64-4ponce.xzm
libavc1394-0.5.4-x86_64-1ponce.xzm
libdv-1.0.0-x86_64-1ponce.xzm
libiec61883-1.2.0-x86_64-2ponce.xzm
libquicktime-1.2.4-x86_64-2ponce.xzm
lua-5.1.5-x86_64-1ponce.xzm
openjpeg-1.5.2-x86_64-1ponce.xzm
orc-0.4.23-x86_64-1ponce.xzm
Carpe diem.

User avatar
francois
Contributor
Contributor
Posts: 5136
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: video editing software

Post#49 by francois » 02 Dec 2016, 17:44

With xfce4 3.1 porteus you will in addition need at least:
libfdk-aac-0.1.4-x86_64-1ponce.xzm
libilbc-2.0.2-x86_64-1ponce.xzm
schroedinger-1.0.11-x86_64-1ponce.xzm
x264-20150223-x86_64-1ponce.xzm
x265-1.8-x86_64-1ponce.xzm
zvbi-0.2.35-x86_64-1ponce.xzm

I have stopped there. :(
Carpe diem.

User avatar
francois
Contributor
Contributor
Posts: 5136
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: video editing software

Post#50 by francois » 18 Jun 2017, 03:54

From xfce 64 bit architecture under 3.x

kdenlive:
library:
swig
http://slackware.cs.utah.edu/pub/slackw ... 6_64-1.txz
mlt
http://slackware.schoepfer.info/14.2_64 ... 4-1jsc.txz

Interface running up, almost running built from sbopkg_gui.
Carpe diem.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: video editing software

Post#51 by Rava » 19 Jun 2017, 08:08

^

Is this only for KDE?
Cheers!
Yours Rava

User avatar
francois
Contributor
Contributor
Posts: 5136
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: video editing software

Post#52 by francois » 20 Jun 2017, 02:01

Supposedly. Actually under xfce there is still some bugs. I did not tested under KDE5.
Carpe diem.

anajames
Black ninja
Black ninja
Posts: 30
Joined: 12 Jun 2017, 08:38
Distribution: Gentoo Linux
Location: USA

Re: video editing software

Post#53 by anajames » 20 Jun 2017, 13:41

Rava wrote:^

Is this only for KDE?
Similar Query. Is this only for KDE?

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: video editing software

Post#54 by Rava » 20 Jun 2017, 14:38

francois wrote:Supposedly. Actually under xfce there is still some bugs. I did not tested under KDE5.
What exactly are the bugs?
Cheers!
Yours Rava

User avatar
francois
Contributor
Contributor
Posts: 5136
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: video editing software

Post#55 by francois » 20 Jun 2017, 15:40

It seems that I have a working kdenlive under xfce:
kdenlive-0.9.10-x86_64-bundle.xzm with usm
mlt-0.7.0-x86_64-1jsc.xzm
swig-3.0.7-x86_64-1.xzm

Were missing:
dvgrab-3.5-x86_64-1ponce.txz
libiec61883-1.2.0-x86_64-2ponce.txz
amrnb-11.0.0.0-x86_64-1_slonly.txz
libavc1394-0.5.4-x86_64-1ponce.txz
dvdauthor-0.7.2-x86_64-1ponce.txz
libmp4v2-2.0.0-x86_64-1ponce.txz
gsm-1.0.13-x86_64-2ponce.txz
libquicktime-1.2.4-x86_64-2ponce.txz and associated dependencies see usm
dvgrab-3.5-x86_64-1ponce.xzm
libiec61883-1.2.0-x86_64-2ponce.xzm
Carpe diem.

User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Re: video editing software

Post#56 by Rava » 20 Jun 2017, 15:53

^
Quite the list.
How many MB is this altogether?
As in: compressed xzm sizes...

_____________________
Trying to get a newer avidemux version running since the old one from ponce (avidemux-2.5.4-x86_64-1ponce) is quite buggy: when editing out commercials the audio/video gets desynchronized as in: the audio is about half a second too late, and that sucks.


The other newer version uses QT5, I wonder if that's a good idea to get that running in XFCE 3.1 that only has QT4?

These are the errors so far trying to run avidemux-qt-2.6.15-alt1.S1.x86_64:

Code: Select all

rava@porteus:/mnt/live/memory/images$ ldd /usr/bin/avidemux3_qt5 |grep not
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/bin/avidemux3_qt5)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/bin/avidemux3_qt5)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/bin/avidemux3_qt5)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/bin/avidemux3_qt5)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreVideoCodec6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib64/libADM_coreLibVA6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreLibVA6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreJobs.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_coreJobs.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib64/libADM_coreJobs.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib64/libADM_core6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_core6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_core6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib64/libADM_coreAudio6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreAudio6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_coreAudio6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreAudioFilterAPI6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib64/libADM_coreAudioDevice6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreAudioDevice6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_coreAudioDevice6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib64/libADM_coreAudioEncoder6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreAudioEncoder6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib64/libADM_coreDemuxer6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreDemuxer6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreImage6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_coreMuxer6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib64/libADM_coreMuxer6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreMuxer6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreUI6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_coreUI6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib64/libADM_coreUtils6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib64/libADM_coreUtils6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreUtils6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_coreUtils6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreSocket6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib64/libADM_coreVideoEncoder6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib64/libADM_coreVideoEncoder6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreVideoEncoder6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_coreVideoEncoder6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib64/libADM_coreVideoFilter6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreVideoFilter6.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_UIQT56.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib64/libADM_coreScript.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreScript.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_render6_QT5.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_coreSqlLight3.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib64/libADM_coreSqlLight3.so)
/usr/bin/avidemux3_qt5: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib64/libADM_audioParser6.so)
	libQt5Network.so.5 => not found
	libQt5OpenGL.so.5 => not found
	libQt5Widgets.so.5 => not found
	libQt5Gui.so.5 => not found
	libQt5Core.so.5 => not found
	libQt5OpenGL.so.5 => not found
	libQt5Widgets.so.5 => not found
	libQt5Gui.so.5 => not found
	libQt5Core.so.5 => not found
	libQt5OpenGL.so.5 => not found
	libQt5Widgets.so.5 => not found
	libQt5Gui.so.5 => not found
	libQt5Core.so.5 => not found
	libQt5OpenGL.so.5 => not found
	libQt5Gui.so.5 => not found
	libQt5Core.so.5 => not found
Is it possible to get libQt5 running on 3.1 XFCe?

(I still am not able to startup Port 3.2.2 ... :( )
Cheers!
Yours Rava

User avatar
francois
Contributor
Contributor
Posts: 5136
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

Re: video editing software

Post#57 by francois » 18 Jul 2017, 03:40

kdenlive installed under kde plasma with usm, only missing package was mlt. However at first use kdenlive complained of missing
avformat module (ffmpeg)
dv module (libdv)
dvgrap
dvdauthor
xine
Carpe diem.

mariareese
Ronin
Ronin
Posts: 3
Joined: 31 Jul 2017, 12:42
Distribution: none
Contact:

video editing software

Post#58 by mariareese » 03 Aug 2017, 11:11

But few of plugins are not working fine .. :(

User avatar
francois
Contributor
Contributor
Posts: 5136
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus artix
Location: C'est l'hiver: la neige soudainement est là à Montréal.

video editing software

Post#59 by francois » 05 Aug 2017, 12:10

@mariareese:
A little more on kdenlive kde 5 plasma: kdenlive and video editing tweaking

Personally, I went with shotcut wich is the follower of KINO by the same author Dan Kennedy SHOTCUT: flexible, intuitive video editor, kino's follower

Very easy to install, but mainly compatible with most video formats.
Carpe diem.

mariareese
Ronin
Ronin
Posts: 3
Joined: 31 Jul 2017, 12:42
Distribution: none
Contact:

video editing software

Post#60 by mariareese » 12 Aug 2017, 08:50

Yes I have read in which you have provided.. helpful for me ,.. :)

Post Reply