LXQT forum???

Get help with LXQt specific problems
User avatar
phhpro
Full of knowledge
Full of knowledge
Posts: 545
Joined: 10 Nov 2013, 20:35
Distribution: .

LXQT forum???

Post#1 by phhpro » 10 Dec 2014, 05:12

...
Last edited by phhpro on 04 Feb 2016, 02:09, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: LXQT forum???

Post#2 by fanthom » 10 Dec 2014, 06:31

here you go :)
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 4942
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#3 by francois » 12 Dec 2014, 21:27

I was unfamiliar with the lxde environment, but eager to familiarize myself with the lxqt environment. I have two questions.

1.0 Is there a way to save the desktop environment before loging out?

2.0 With the monitor settings, in dual display, is there a way to switch the left screen for the right?

Thanks.
Last edited by francois on 12 Dec 2014, 23:44, edited 1 time in total.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: LXQT forum???

Post#4 by fanthom » 12 Dec 2014, 21:54

@francois
1) looks like you will need external app:
https://bbs.archlinux.org/viewtopic.php?id=104090

2) dont know the answer to this question.
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 4942
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#5 by francois » 12 Dec 2014, 23:30

@fanthom:
Downloading a package with google-chrome under lxqt, there is a problem in with a contextual menu. Right clicking on the downloaded application at the bottom of the google-chrome window to get the contextual menu, choosing option show in folder will trigger qmmp software instead of displaying the file in the a file manager.

Thanks for obapps. I am looking at it presently.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
francois
Contributor
Contributor
Posts: 4942
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum

Post#6 by francois » 12 Dec 2014, 23:51

obapps follow-up

Installation:
obapps is available for slackware x86-64 architecture:
https://slackonly.com/pub/packages/14.1 ... op/obapps/

Two dependencies are needed:
wxPython-2.8.0+
python-xlib

These are available with some additional libraries from usm.

Starting the application:
obapps is started thru command line obapps.

I will report later on its use.

Thanks.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5456
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: LXQT forum???

Post#7 by brokenman » 12 Dec 2014, 23:54

I remember having this problem in RazorQT and making a really ugly fix for it. I think it is the fault of qmmp's aggressive mimetype application.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 843
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: LXQT forum???

Post#8 by ncmprhnsbl » 13 Dec 2014, 04:42

pretty sure obapps won't help save application state on log out
it basicly edits a section of the rc.xml that controls per application window rules
eg. use it to have lxterminal undecorated.
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: LXQT forum???

Post#9 by fanthom » 13 Dec 2014, 19:07

@brokenman
thanks - will try to sort the mimetypes manually for LXQt

@ncmprhnsbl
you are our openbox expert - is there any other solution to this?
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 4942
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#10 by francois » 14 Dec 2014, 00:32

1.0 Saving the desktop:
.obapps:
It seemed to work a few times. But now, there is nothing I can do to get the thing to save the desktop???
.. lxqt menu > preference > sessions settings > autostart > add (application):
This will work so to have standard applications poping up at bootup, except google-chrome.

2.0 Changing menu items:
I have found a gui front end written in java called lxmed that will change the lxqt menu:
http://sourceforge.net/projects/lxmed/
[url]task.http://ubuntuforums.org/showthread.php?t=896355[/url]

Unpack the lxmed and use the install script. lxmed will be installed in opt.

You need openjre package (download it with usm package manager) to get it running. Java will install itself in /usr/lib64/java/jre/bin/java. To start the lxmed menu editor:

Code: Select all

root@porteus: /usr/lib64/java/jre/bin/java -jar /opt/lxmed/LXMenuEditor.jar
Then simply use this java command line to change thru:
lxde panel > preferences > main menu editor > properties

The command in properties should be: /usr/lib64/java/jre/bin/java -jar /opt/lxmed/LXMenuEditor.jar.

Alternatively, keep the command line lxmed and change /usr/bin/lxmed program by the script:

Code: Select all

#!/bin/bash
/usr/lib64/java/jre/bin/java -jar /opt/lxmed/LXMenuEditor.jar 
Montreal, edited 150106
Last edited by francois on 29 Jan 2015, 02:26, edited 3 times in total.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
Posts: 843
Joined: 20 Mar 2012, 03:42
Distribution: 3.2.2-64bit xfce/openbox
Location: australia
Contact:

Re: LXQT forum???

Post#11 by ncmprhnsbl » 14 Dec 2014, 02:11

- is there any other solution to this?
not something ive come across, and after a little search, seems LX/openbox users who want this soon become xfce users ;)
as you say, lxqt-session doesnt have this facility, (nor lxde-session,or openbox-session)....
some sort of work around might involve automatically adding/removing .desktop files to/from ./config/autostart of running gui apps gleaned from some ps list at logout.
even if that made any sense, it seems like a lot of trouble :crazy:
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
francois
Contributor
Contributor
Posts: 4942
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#12 by francois » 16 Dec 2014, 03:15

I am just curious if anybody was able to build and use virtualbox under porteus 3.1 lxqt?
Thanks.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: LXQT forum???

Post#13 by fanthom » 16 Dec 2014, 09:58

@francois
please make sure that devel module is activated before you create Vbox module.
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 4942
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#14 by francois » 16 Dec 2014, 11:17

This was the case. And if devel.xzm is not there, vbox and vbox guest additions will not build before devel.xzm will be downloaded automatically, which is really a nice feature.

Other problem:
The icon in lxqt will not start the usm gui frontend.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
francois
Contributor
Contributor
Posts: 4942
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: LXQT forum???

Post#15 by francois » 04 Jan 2015, 05:46

The icon in the lxqt panel will not start the usm gui. It has to be started thru command line, which will start the usmgui frontend.Only in root mode (tested in always fresh mode).

lxqt > preferences > main menu editor:
- there is no loading of the main menu editor
- loading the corresponding command to main menu editor yields the following error message:

Code: Select all

root@porteus:~# lxmed
/usr/bin/lxmed: ligne35: gksu : commande introuvable
root@porteus:~#
[/s]
Voltaire: Le mieux est l'ennemi du bien.

Post Reply