[SOLVED] Keyboard layout doesn't seem to be applied

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
b0bbywan
White ninja
White ninja
Posts: 7
Joined: 05 Sep 2017, 15:49
Distribution: Porteus Kiosk

[SOLVED] Keyboard layout doesn't seem to be applied

Post#1 by b0bbywan » 05 Sep 2017, 15:58

I'm using porteus kiosk with a network config, in it I have:

primary_keyboard_layout=fr:latin9

(Azerty layout basically)

It works fine with a keyboard (that is only used for debugging purposes), but not with a QRcode reader, which is its main usage

both root and guest have the same anwser to this command setxkbmap -v 10 -query

Code: Select all

Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     us
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+us+inet(evdev)
geometry:   pc(pc105)
rules:      evdev
model:      pc105
layout:     us
If anyone has an idea of what I'm doing wrong, thanks !
Last edited by b0bbywan on 05 Sep 2017, 17:19, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4593
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Keyboard layout doesn't seem to be applied

Post#2 by fanthom » 05 Sep 2017, 16:36

Not sure if i understand but i'm getting this output after using your parameter:

Code: Select all

root@kiosk:~# setxkbmap -v 10 -query
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     fr,
variant:    latin9,
Trying to build keymap using the following components:
keycodes:   evdev+aliases(azerty)
types:      complete
compat:     complete
symbols:    pc+fr(latin9)+inet(evdev)
geometry:   pc(pc105)
rules:      evdev
model:      pc105
layout:     fr,
variant:    latin9,
So it must be your kiosk config issue.
Please add [Solved] to your thread title if the solution was found.

b0bbywan
White ninja
White ninja
Posts: 7
Joined: 05 Sep 2017, 15:49
Distribution: Porteus Kiosk

Keyboard layout doesn't seem to be applied

Post#3 by b0bbywan » 05 Sep 2017, 17:19

Ok so I retried, it's plugging the qrcode reader on the pc that changed the layout back to US, if it's plugged before boot, the layout is indeed fr:latin9

Do you want more info ? It really looks like a bug to me

I'm using Porteus Kiosk 4.5.0 btw

User avatar
fanthom
Site Admin
Site Admin
Posts: 4593
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

[SOLVED] Keyboard layout doesn't seem to be applied

Post#4 by fanthom » 06 Sep 2017, 09:39

Unfortunately i do not have this hardware around so wont be able to recreate your issue.
Please contact me on support@porteus-kiosk.org and will try to debug this over SSH/VNC.

Thanks
Please add [Solved] to your thread title if the solution was found.

Post Reply