05-devel.xzm toolchain errors...

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
n0ctilucient
Samurai
Samurai
Posts: 107
Joined: 21 Apr 2017, 15:59
Distribution: fullmoonremix
Location: 127.0.0.1

05-devel.xzm toolchain errors...

Post#1 by n0ctilucient » 19 Jul 2017, 21:40

I tried to compile (a 64 bit) eglibc-2.13-r13356.tar.bz2
@ http://ftp.lfs-matrix.net/pub/clfs/cong ... on/eglibc/

...using the current 05-devel.xzm (and the current stable Porteus)
@ http://dl.porteus.org/x86_64/current/kernel/

...this is the erroneous src2pkg output of eglibc-configure.log

Code: Select all

checking version of gmake... 4.1, bad
checking for gnumsgfmt... no
checking for gmsgfmt... no
checking for msgfmt... msgfmt
checking version of msgfmt... 0.19.8.1, ok
checking for makeinfo... makeinfo
checking version of makeinfo... 6.1, bad
checking for sed... sed
checking version of sed... v. ?.??, bad
checking for autoconf... autoconf
checking whether autoconf works... yes
configure: error:
*** These critical programs are missing or too old: make
...Installed
make-4.1-x86_64-2 (current... make-4.2.1)
sed-4.2.2-x86_64-1 (current... sed-4.4)
texinfo-6.1-x86_64-1 (current... texinfo-6.4)

...Latest versions @
https://ftp.gnu.org/gnu/make/
https://ftp.gnu.org/gnu/sed/

...Texinfo (makeinfo???)
https://ftp.gnu.org/gnu/texinfo/
:hmmm: I do NOT have the "right" to tell anyone what they should do...
but I always reserve the "right" to tell them what they should consider.

Post Reply