Porteus-v3.2.1 bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.

Re: Porteus-v3.2.1 bug reports

Postby fulalas » 08 Dec 2016, 02:59

Booting on a FAT32 usb stick and Porteus told me that it can only run on Always Fresh mode, but in fact it loaded all modules inside /porteus/modules and also copied rootcopy folder. Is this normal?
fulalas
Contributor
Contributor
 
Posts: 270
Joined: 26 Oct 2016, 16:34
Location: Brazil
Distribution: Porteus

Re: Porteus-v3.2.1 bug reports

Postby ncmprhnsbl » 08 Dec 2016, 03:15

fulalas wrote:Booting on a FAT32 usb stick and Porteus told me that it can only run on Always Fresh mode, but in fact it loaded all modules inside /porteus/modules and also copied rootcopy folder. Is this normal?

its a little misleading but is correct...(to a point)
its referring to changes=/porteus/ cheatcode not being able to work because fat32 is not POSIX compatible ie. doesnt handle ownership/permissions..
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44
User avatar
ncmprhnsbl
Full of knowledge
Full of knowledge
 
Posts: 640
Joined: 20 Mar 2012, 04:42
Location: australia
Distribution: 3.2.2-64bit xfce/openbox

Re: Porteus-v3.2.1 bug reports

Postby fulalas » 08 Dec 2016, 05:58

ncmprhnsbl wrote:its referring to changes=/porteus/ cheatcode not being able to work because fat32 is not POSIX compatible ie. doesnt handle ownership/permissions..

I see. And also FAT32 doesn't support symlinks.

But anyway the Porteus message doesn't seem to be correct once Porteus isn't really running on AF mode in this case, right?
fulalas
Contributor
Contributor
 
Posts: 270
Joined: 26 Oct 2016, 16:34
Location: Brazil
Distribution: Porteus

Re: Porteus-v3.2.1 bug reports

Postby Ed_P » 08 Dec 2016, 06:19

^ A porteus changes= save.dat file works fine on FAT32 & NTFS drive formats for me.
Ed
User avatar
Ed_P
Contributor
Contributor
 
Posts: 2645
Joined: 06 Feb 2013, 23:12
Location: Western NY, USA
Distribution: Cinnamon 3.2.* 64-bit ISO

Re: Porteus-v3.2.1 bug reports

Postby Ed_P » 08 Dec 2016, 08:24

3.2.1 Cinnamon 64-bit

WiFi not working on an HP Pavilion notebook. WifI is an option in Network Manager but enabling it immediately disables it.

Hopefully there is enough here to help determine a fix.
Code: Select all
WIRELESS INFO:

02:00.0 Network controller: Intel Corporation Wireless 3165 (rev 81)
   Subsystem: Intel Corporation Dual Band Wireless AC 3165
   Flags: bus master, fast devsel, latency 0, IRQ 131
   Memory at b1500000 (64-bit, non-prefetchable) [size=8K]
   Capabilities: [c8] Power Management version 3
   Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [40] Express Endpoint, MSI 00
   Capabilities: [100] Advanced Error Reporting
   Capabilities: [140] Device Serial Number 94-65-9c-ff-ff-b7-9c-b5
   Capabilities: [14c] Latency Tolerance Reporting
   Capabilities: [154] L1 PM Substates
   Kernel driver in use: iwlwifi
   Kernel modules: iwlwifi, wl

DMESG INFO:

[    0.000000] Linux version 4.8.11-porteus (root@porteus) (gcc version 5.3.0 (GCC) ) #1 SMP PREEMPT Mon Nov 28 00:18:06 BRST 2016
[    0.000000] Command line: BOOT_IMAGE=(loop)/boot/syslinux/vmlinuz from=/ISOs/Porteus-CINNAMON-v3.2.1-x86_64.iso volume=33 reboot=cold extramod=/mnt/sdb1/porteus3.2/Modules
[    0.000000] x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x008: 'MPX bounds registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x010: 'MPX CSR'
[    0.000000] x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256
[    0.000000] x86/fpu: xstate_offset[3]:  832, xstate_sizes[3]:   64
[    0.000000] x86/fpu: xstate_offset[4]:  896, xstate_sizes[4]:   64
[    0.000000] x86/fpu: Enabled xstate features 0x1f, context size is 960 bytes, using 'compacted' format.
[    0.000000] x86/fpu: Using 'eager' FPU context switches.
[    0.000000] e820: BIOS-provided physical RAM map:
[    0.000000] BIOS-e820: [mem 0x0000000000000000-0x0000000000057fff] usable
[    0.000000] BIOS-e820: [mem 0x0000000000058000-0x0000000000058fff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000000059000-0x0000000000085fff] usable
[    0.000000] BIOS-e820: [mem 0x0000000000086000-0x00000000000fffff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000000100000-0x000000007ae3efff] usable
[    0.000000] BIOS-e820: [mem 0x000000007ae3f000-0x000000007ae3ffff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x000000007ae40000-0x000000007ae69fff] reserved
[    0.000000] BIOS-e820: [mem 0x000000007ae6a000-0x000000008c10dfff] usable
[    0.000000] BIOS-e820: [mem 0x000000008c10e000-0x000000008c30dfff] type 20
[    0.000000] BIOS-e820: [mem 0x000000008c30e000-0x000000008cafdfff] reserved
[    0.000000] BIOS-e820: [mem 0x000000008cafe000-0x000000008cdfdfff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x000000008cdfe000-0x000000008cefdfff] ACPI data
[    0.000000] BIOS-e820: [mem 0x000000008cefe000-0x000000008cefefff] usable
[    0.000000] BIOS-e820: [mem 0x000000008ceff000-0x000000008fffffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000e0000000-0x00000000efffffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fd000000-0x00000000fe7fffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000feb00000-0x00000000feb03fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fed00000-0x00000000fed00fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fed10000-0x00000000fed19fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fed84000-0x00000000fed84fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000ffa00000-0x00000000ffffffff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000100000000-0x000000016effffff] usable
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] efi: EFI v2.40 by INSYDE Corp.
[    0.000000] efi:  SMBIOS=0x8c37b000  ESRT=0x8c37ca18  ACPI 2.0=0x8cefd014
[    0.000000] esrt: Reserving ESRT space from 0x000000008c37ca18 to 0x000000008c37ca50.
[    0.000000] SMBIOS 2.8 present.
[    0.000000] DMI: HP HP Pavilion x360 Convertible/80D1, BIOS F.1D 08/17/2016
[    0.000000] e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
[    0.000000] e820: remove [mem 0x000a0000-0x000fffff] usable
[    0.000000] e820: last_pfn = 0x16f000 max_arch_pfn = 0x400000000
[    0.000000] MTRR default type: uncachable
[    0.000000] MTRR fixed ranges enabled:
[    0.000000]   00000-9FFFF write-back
[    0.000000]   A0000-BFFFF uncachable
[    0.000000]   C0000-FFFFF write-protect
 :
 :
 :
[   13.057397] USB Video Class driver (1.1.1)
[   13.069001] Bluetooth: hci0: read Intel version: 370810011003110e00
[   13.069140] bluetooth hci0: Direct firmware load for intel/ibt-hw-37.8.10-fw-1.10.3.11.e.bseq failed with error -2
[   13.069143] Bluetooth: hci0 failed to open Intel firmware file: intel/ibt-hw-37.8.10-fw-1.10.3.11.e.bseq(-2)
[   13.069206] bluetooth hci0: Direct firmware load for intel/ibt-hw-37.8.bseq failed with error -2
[   13.069208] Bluetooth: hci0 failed to open default Intel fw file: intel/ibt-hw-37.8.bseq
[   13.192395] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   13.225190] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC3227: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[   13.225196] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   13.225197] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[   13.225198] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[   13.225199] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[   13.225201] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x19
[   13.225202] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
[   13.258897] snd_hda_intel 0000:00:1f.3: Too many HDMI devices
[   13.258899] snd_hda_intel 0000:00:1f.3: Consider building the kernel with CONFIG_SND_DYNAMIC_MINORS=y
[   13.261006] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input14
[   13.261077] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input15
[   13.261187] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input16
[   13.261255] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input17
[   13.261318] input: HDA Intel PCH HDMI/DP as /devices/pci0000:00/0000:00:1f.3/sound/card0/input18
[   14.767092] NET: Registered protocol family 10
[   15.408222] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   15.435926] r8169 0000:03:00.0 eth0: link down
[   15.436004] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   15.438697] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   15.466262] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   15.466711] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   15.540082] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   15.540478] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   15.568579] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   19.701615] snd_hda_intel 0000:00:1f.3: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
[   65.889361] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   65.890024] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   65.958523] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   65.959104] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   65.990228] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   66.054323] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   66.054879] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   66.122312] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   66.122869] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   66.152984] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   66.192494] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   78.476383] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   78.476997] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   78.545469] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   78.546025] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   78.578086] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   78.628184] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  100.321248] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  100.321806] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  100.389889] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  100.390468] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[  100.420775] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  100.466246] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Ed
User avatar
Ed_P
Contributor
Contributor
 
Posts: 2645
Joined: 06 Feb 2013, 23:12
Location: Western NY, USA
Distribution: Cinnamon 3.2.* 64-bit ISO

Re: Porteus-v3.2.1 bug reports: KDE baloo_file hyperactivity

Postby Bogomips » 08 Dec 2016, 16:52

Testing for baloo_file upon entry to KDE

Normally kill off baloo-file process in guiexec script. Here reporting situation without this precaution.

Upon text mode entry there is no sign of baloo_file activity:
Code: Select all
quiet from=/dev/sda10/tmp/iso/3.2.1/i586/Porteus-KDE-v3.2.1-i586.iso copy2ram ramsize=25% noauto rootcopy=/dev/sda4/kd_rcp 3

guest@porteus:~$ ps -e | grep baloo


Upon entry to GUI
  1. Booting
    Code: Select all
    quiet from=/dev/sda10/tmp/iso/3.2.1/i586/Porteus-KDE-v3.2.1-i586.iso copy2ram ramsize=25% noauto rootcopy=/dev/sda4/kd_rcp noload=1bp extramod=/dev/sda10/kd_xzm rammod=base;-2bp cliexec=mount~--bind~/home/guest/p9/tmp~/tmp

    # Non standard /rootcopy dir:
    /dev/sda4/kd_rcp

    # Modules activated during boot time:
    /memory/copy2ram/000-kernel.xzm
    /memory/copy2ram/001-core.xzm
    /memory/copy2ram/002-xorg.xzm
    /memory/copy2ram/003-kde.xzm
    /mnt/sda10/kd_xzm/flashplayer-plugin-23.0.0.207-i586-1.xzm
    /mnt/sda10/kd_xzm/geany-1.25-i486-bundle.xzm
    /mnt/sda10/kd_xzm/gecko-mediaplayer-1.0.9.i686-pkg-1.xzm
    /mnt/sda10/kd_xzm/lt_040816.xzm
    /memory/copy2ram/nvidia-304.131_3.2.1-i586-2bp.xzm
    /mnt/sda10/kd_xzm/terminator-0.97-i486-1_slack.xzm

    ISO=/mnt/sda10/tmp/iso/3.2.1/i586/Porteus-KDE-v3.2.1-i586.iso

  2. Excepting mouse pointer, GUI with just Konsole open freezes up 5 minutes after launch:
    Code: Select all
    top - 14:59:03 up 5 min,  1 user,  load average: 6.33, 3.51, 1.54
    Tasks: 141 total,   5 running, 136 sleeping,   0 stopped,   0 zombie
    %Cpu(s):  0.3 us, 99.1 sy,  0.0 ni,  0.0 id,  0.0 wa,  0.0 hi,  0.6 si,  0.0 st
    KiB Mem :   900928 total,    62268 free,   680876 used,   157784 buff/cache
    KiB Swap:   530108 total,        0 free,   530108 used.    11336 avail Mem

      PID USER      PR  NI    VIRT    RES    SHR S %CPU %MEM     TIME+ COMMAND
     1390 guest     20   0  165080  24660    512 R 19.8  2.7   0:12.21 org_kde_pow+
     1282 guest     20   0  308976  57912   7224 R 19.5  6.4   0:27.37 kwin_x11
     1286 guest     20   0  564068 119448  30912 R 19.5 13.3   0:50.96 plasmashell
     1501 guest     20   0  163164  32408   1328 R 19.5  3.6   0:29.92 konsole
     1424 guest     20   0  187912  24464     76 S  6.2  2.7   0:06.71 kactivityma+
     1570 guest     20   0    4008    492      0 R  3.1  0.1   0:01.27 top
        7 root      20   0       0      0      0 S  2.5  0.0   0:03.90 rcu_preempt
       26 root      20   0       0      0      0 S  2.2  0.0   0:04.73 kswapd0
      907 polkitd   20   0   61532   1504      0 S  1.9  0.2   0:03.28 polkitd
      988 root      20   0    2512     44      0 S  1.9  0.0   0:00.44 gpm
       85 root      20   0       0      0      0 S  1.5  0.0   0:04.20 kworker/0:3
      987 root      20   0    2392     52      0 S  1.5  0.0   0:00.17 crond
      339 root       0 -20       0      0      0 S  0.6  0.0   0:01.26 loop4
      606 message+  20   0    3588    540      0 S  0.6  0.1   0:00.54 dbus-daemon
      319 root       0 -20       0      0      0 S  0.3  0.0   0:00.39 loop2
     1283 guest     39  19 1247380 108548     16 S  0.3 12.0   0:31.09 baloo_file

  3. After couple of minutes wait, returning to GUI with Alt+F7, still could not action anything. So back in console:
    Code: Select all
     top - 15:02:07 up 8 min,  2 users,  load average: 7.87, 5.50, 2.67
    Tasks: 140 total,   4 running, 136 sleeping,   0 stopped,   0 zombie
    %Cpu(s):  0.3 us, 99.1 sy,  0.0 ni,  0.0 id,  0.0 wa,  0.0 hi,  0.6 si,  0.0 st
    KiB Mem :   900928 total,    59880 free,   680844 used,   160204 buff/cache
    KiB Swap:   530108 total,        0 free,   530108 used.    10116 avail Mem

      PID USER      PR  NI    VIRT    RES    SHR S %CPU %MEM     TIME+ COMMAND
     1501 guest     20   0  163164  32528   1448 R 32.3  3.6   1:05.35 konsole
     1286 guest     20   0  565088 119008  30336 R 31.1 13.2   1:29.72 plasmashell
     1150 root      20   0   85576  23668   1200 S  8.3  2.6   0:27.69 Xorg
     1258 guest     20   0  216688   6028    364 D  5.5  0.7   0:13.66 kded5
     1424 guest     20   0  187912  24464     76 S  4.0  2.7   0:16.96 kactivityma+
      988 root      20   0    2512     44      0 S  2.8  0.0   0:00.71 gpm
        7 root      20   0       0      0      0 S  2.5  0.0   0:05.19 rcu_preempt
       26 root      20   0       0      0      0 S  2.5  0.0   0:09.15 kswapd0
     1307 guest     20   0    7180    384      0 S  2.5  0.0   0:00.99 gconfd-2
       85 root      20   0       0      0      0 S  1.8  0.0   0:08.85 kworker/0:3
     1487 guest     20   0  162432  24412     64 S  1.8  2.7   0:12.59 kdeconnectd
     1570 guest     20   0    4008    492      0 R  1.8  0.1   0:05.44 top
     1282 guest     20   0  303852  56832   6132 R  1.2  6.3   0:58.57 kwin_x11
     1283 guest     39  19 1247380 108520     16 S  0.9 12.0   0:31.80 baloo_file
    Still active baloo_file killed.
  4. Alt +F7 Returns to black screen
  5. Ctl+Alt+Backspace pops up dialog window with message that ksmserver could not be restarted
  6. Back In Console: init 3 followed by init 4 gets Wallpaper and blue progress bar, followed by entry into GUI.
  7. Ctl+Alt+F1 baloo_file is back:
    Code: Select all
     top - 15:11:49 up 18 min,  2 users,  load average: 2.02, 3.28, 3.33
    Tasks: 143 total,   3 running, 140 sleeping,   0 stopped,   0 zombie
    %Cpu(s):  4.1 us, 23.3 sy, 37.5 ni,  0.0 id, 34.5 wa,  0.0 hi,  0.7 si,  0.0 st
    KiB Mem :   900928 total,    64988 free,   600148 used,   235792 buff/cache
    KiB Swap:   530108 total,        0 free,   530108 used.    65584 avail Mem

      PID USER      PR  NI    VIRT    RES    SHR S %CPU %MEM     TIME+ COMMAND
     2122 guest     39  19 1196680  63840   4656 S 56.4  7.1   0:17.49 baloo_file
     2125 guest     20   0  526632 102796  26968 S  3.3 11.4   0:14.36 plasmashell
     1992 root      20   0   85164  27256   5412 S  1.7  3.0   0:03.88 Xorg
       26 root      20   0       0      0      0 S  1.0  0.0   0:13.16 kswapd0
     2118 guest     20   0  303408  63460  14400 R  0.7  7.0   0:04.59 kwin_x11
        7 root      20   0       0      0      0 R  0.3  0.0   0:08.04 rcu_preempt

  8. Still in Console:
    Code: Select all
    guest@porteus:~$ ps -e | grep baloo_file
     2122 ?        00:00:31 baloo_file
    guest@porteus:~$ kill 2122
    Alt+F7 finally good to go!
Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB
Bogomips
Full of knowledge
Full of knowledge
 
Posts: 2157
Joined: 25 Jun 2014, 16:21
Location: London
Distribution: 3.2.2 Cinnamon & KDE5

Re: Porteus-v3.2.1 bug reports

Postby brokenman » 09 Dec 2016, 19:30

Verdict, remove baloo?
How do i become super user?
Wear your underpants on the outside and put on a cape.
brokenman
Site Admin
Site Admin
 
Posts: 5333
Joined: 27 Dec 2010, 04:50
Location: Brazil
Distribution: Porteus v3.2rcX all desktops

Re: Porteus-v3.2.1 bug reports

Postby Ed_P » 09 Dec 2016, 20:55

Cinnamon 64-bit

On this netbook Cinnamon boots to a blank screen after displaying the standard text messages. alt+sysreq + reisub and ctl+alt+del have no effect, I have to power off to rebbot.

http://pastebin.ca/3745899

3.0.1 boots fine on it and is how I am able to post the pastebin link to the system dump it created.

-update-

The blank screen occurs not after displaying the standard Porteus text messages but rather after displaying the standard grub2 boot msgs. Similar grub2 code works for Porteus 3.5.

Code: Select all
menuentry "Porteus Cinnamon ISO - AF" --class slackware   --class icon-porteus  {
     echo Boot disk address is: $root
     echo Prefix is:            $prefix
     echo The boot mode is:     $grub2win_bootmode

     set iso=/ISOs/Porteus-CINNAMON-v3.2.1-x86_64.iso
     search -f $iso --set=root

     set linux_drv=/mnt/sda5/porteus3.2
     if [ -f (hd1,1)/USB_INSTALLATION.txt ]; then
         set linux_drv=/mnt/sdb1/porteus3.2
     fi
     echo ISO root is:          $root
     echo ISO is:               $iso

     echo Porteus extramods is: $linux_drv
     set porteus_parms="volume=33 reboot=cold"

     echo Porteus parms are:    $porteus_parms
     echo
     loopback loop $iso
     sleep -v -i 17
     echo "Loading Linux"
     linux (loop)/boot/syslinux/vmlinuz from=$iso $porteus_parms
     echo "Loading initrd"
     initrd (loop)/boot/syslinux/initrd.xz
}

menuentry "Porteus Nemesis 3.5 ISO" --class slackware   --class icon-linux  {
     echo Boot disk address is: $root
     echo Prefix is:            $prefix
     echo The boot mode is:     $grub2win_bootmode

     set iso=/ISOs/porteus-nemesis-v3.5-lxde-x86_64.iso

     search -f $iso --set=root
     echo ISO root is:          $root
     echo ISO is:               $iso
     if [ -f (hd1,1)/USB_INSTALLATION.txt ]; then
         set linux_drv=/mnt/sdb1/porteus3.x
     else
         set linux_drv=/mnt/sda5/porteus3.x
     fi

     set porteus_parms="changes=$linux_drv/porteussave.dat volume=33 reboot=cold 3"

     echo Porteus changes:      $linux_drv/porteussave.dat
     echo Porteus parms are:    $porteus_parms
     echo
     loopback loop $iso
     sleep -v -i 7
     echo "Loading Linux"
     linux (loop)/boot/syslinux/vmlinuz from=$iso $porteus_parms
     echo "Loading initrd"
     initrd (loop)/boot/syslinux/initrd.xz
}

Is the Cinnamon ISO set up differently? Not UEFI enable?
brokenman UEFI Boot Confusion [Solved] wrote:Be sure to select 64bit and the UEFI enabled.
Ed
User avatar
Ed_P
Contributor
Contributor
 
Posts: 2645
Joined: 06 Feb 2013, 23:12
Location: Western NY, USA
Distribution: Cinnamon 3.2.* 64-bit ISO

Re: Porteus-v3.2.1 bug reports

Postby fulalas » 10 Dec 2016, 04:01

Using vga_detect flag with a Nvidia card I get this message during boot, although everything goes well (i.e. Nvidia driver is loaded):

Code: Select all
linuxrc: cd: line 334: can't cd to /usr/share/pciids/NVIDIA


I checked and /usr/share/pciids doesn't exist.
fulalas
Contributor
Contributor
 
Posts: 270
Joined: 26 Oct 2016, 16:34
Location: Brazil
Distribution: Porteus

Re: Porteus-v3.2.1 bug reports: Rendering baloo ineffectual

Postby Bogomips » 11 Dec 2016, 03:02

brokenman wrote:Verdict, remove baloo?
It's not just me:
KDE5 correct way to disable baloo wrote:Square7 2016-06-30 15:39:34
Member
Registered: 2015-11-20
Posts: 5

The problem still persists on 3 of my Arch systems. They are all configured similar but are totaly independent. Baloo allways uses one entire core, which is why I disabled it again although I would really love to use it.


Here's the thing. There is 'updatedb' which normally paralyses the computer for a couple of minutes while it does it's thing. However this happens somewhere within the session, as opposed to baloo activity excluding starting the session. Being within the session one has a chance of finding out that it's slocate that has to be removed and to also see that find is not disadvantaged without 'updatedb' cron job. In the case of baloo however, certain users may not get chance of entering the DE, and may be put off by this.

Sorting out Baloo
  • Baloo so far:
    Code: Select all
    guest@porteus:~$ balooctl status
    Baloo File Indexer is not running
    Indexed 0 / 0 files
    Current size of index is 12.00 KiB

    guest@porteus:~$ cat .config/baloofilerc
    [General]
    dbVersion=2
    exclude filters=*.aux,CVS,*.moc,.xsession-errors*,*.orig,CMakeCache.txt,confdefs.h,.obj,lzo,config.status,_darcs,*.rej,*.gmo,*.part,libtool,lost+found,*.o,.uic,*.vm*,Makefile.am,.moc,cmake_install.cmake,moc_*.cpp,qrc_*.cpp,.hg,*.nvram,*.loT,conftest,autom4te,*.m4,*.rcore,*~,litmain.sh,*.csproj,CTestTestfile.cmake,*.pc,CMakeTmp,confstat,*.pyc,*.tmp,po,CMakeFiles,ui_*.h,*.la,*.class,core-dumps,.git,*.swap,*.po,__pycache__,.svn,*.omf,*.elc,.bzr,CMakeTmpQmake,.pch,.histfile.*,*.lo
    exclude filters version=2
    first run=true

  • guiexec
    Code: Select all
    guest@porteus:~$ cat /proc/cmdline
    quiet from=/dev/sda10/tmp/iso/3.2.1/i586/Porteus-KDE-v3.2.1-i586.iso copy2ram ramsize=25% noauto rootcopy=/dev/sda4/kd_rcp noload=1bp extramod=/dev/sda10/kd_xzm rammod=base;-2bp cliexec=mount~--bind~/home/guest/p9/tmp~/tmp guiexec=balooctl~disable

    guest@porteus:~$ balooctl status
    Baloo is currently disabled. To enable, please run "balooctl enable"
    Sorted. :)
    • xinitrc
      • balooctl disable
        Code: Select all
        quiet from=/dev/sda10/tmp/iso/3.2.1/i586/Porteus-KDE-v3.2.1-i586.iso copy2ram ramsize=25% noauto rootcopy=/dev/sda4/kd_rcp noload=1bp extramod=/dev/sda10/kd_xzm rammod=base;-2bp cliexec=mount~--bind~/home/guest/p9/tmp~/tmp guiexec=Prolog/pmx.sh 3
        INIT 3
        guest@porteus:~$ cat .xinitrc
        cat: .xinitrc: No such file or directory

        guest@porteus:~$ echo balooctl  disable >> .xinitrc
        guest@porteus:~$ cat .xinitrc
        balooctl disable

        INIT 4
        guest@porteus:~$ balooctl status
        Baloo File Indexer is running
        Indexer state: Idle
        Indexed 0 / 0 files
        Current size of index is 12.00 KiB

        guest@porteus:~$ balooctl disable
        inotify_add_watch("/etc/mtab") failed: "No space left on device"
        inotify_add_watch("/etc/fstab") failed: "No space left on device"
        Disabling the File Indexer

        guest@porteus:~$ balooctl status
        Baloo is currently disabled. To enable, please run "balooctl enable"

        guest@porteus:~$ ps -e | grep baloo
         1347 ?        00:00:27 baloo_file
        guest@porteus:~$ kill 1347
        guest@porteus:~$ ps -e | grep baloo
        Neutralised. :twisted: (Premature invocation of balooctl)
        • Indexing-Enabled=false (baloofilerc)
          Code: Select all
          INIT 3
          quiet from=/dev/sda10/tmp/iso/3.2.1/i586/Porteus-KDE-v3.2.1-i586.iso copy2ram ramsize=25% noauto rootcopy=/dev/sda4/kd_rcp noload=1bp extramod=/dev/sda10/kd_xzm rammod=base;-2bp cliexec=mount~--bind~/home/guest/p9/tmp~/tmp guiexec=Prolog/pmx.sh 3

          guest@porteus:~$ cat > .xinitrc
          echo [Basic Settings] >> ~/.config/baloofilerc
          echo Indexing-Enabled=false >> ~/.config/baloofilerc
          guest@porteus:~$ cat .xinitrc
          echo [Basic Settings] >> ~/.config/baloofilerc
          echo Indexing-Enabled=false >> ~/.config/baloofilerc

          INIT 4
          guest@porteus:~$ balooctl status
          Baloo File Indexer is running
          Indexer state: Initial Indexing
          Indexed 0 / 0 files
          Current size of index is 12.00 KiB

          guest@porteus:~$ balooctl disable
          Disabling the File Indexer
          guest@porteus:~$ pkill baloo

          guest@porteus:~$ cat .xinitrc
          echo [Basic Settings] >> ~/.config/baloofilerc
          echo Indexing-Enabled=false >> ~/.config/baloofilerc

          guest@porteus:~$ cat .config/baloofilerc
          [Basic Settings]
          Indexing-Enabled=false

          [General]
          dbVersion=2
          exclude filters=*.pc,*.csproj,*.loT,CMakeFiles,.histfile.*,CMakeTmp,confstat,core-dumps,*.la,.git,*~,*.po,.svn,config.status,*.pyc,*.tmp,.bzr,libtool,.pch,moc_*.cpp,*.lo,po,litmain.sh,_darcs,*.omf,__pycache__,CVS,CMakeTmpQmake,*.nvram,*.swap,*.elc,.xsession-errors*,.obj,CMakeCache.txt,*.aux,*.rcore,CTestTestfile.cmake,*.moc,lzo,lost+found,.uic,.moc,*.orig,*.o,*.class,*.rej,*.gmo,qrc_*.cpp,cmake_install.cmake,.hg,*.part,ui_*.h,conftest,*.m4,*.vm*,autom4te,confdefs.h,Makefile.am
          exclude filters version=2
          first run=true
          Neutralised. :twisted: (Appears to be too late in the game. Config file not consulted at this stage, just appended to.) :unknown:
        • Text Mode
          • Code: Select all
            INIT 3
            quiet from=/dev/sda10/tmp/iso/3.2.1/i586/Porteus-KDE-v3.2.1-i586.iso copy2ram ramsize=25% noauto rootcopy=/dev/sda4/kd_rcp noload=1bp extramod=/dev/sda10/kd_xzm rammod=base;-2bp cliexec=mount~--bind~/home/guest/p9/tmp~/tmp guiexec=Prolog/pmx.sh 3

            guest@porteus:~$ cat .config/baloofilerc
            cat: .config/baloofilerc: No such file or directory
            guest@porteus:~$ balooctl status
            Baloo Index could not be opened

            guest@porteus:~$ cat > .config/baloofilerc
            [Basic Settings]
            Indexing-Enabled=false

            guest@porteus:~$ cat .config/baloofilerc
            [Basic Settings]
            Indexing-Enabled=false

          • Code: Select all
            INIT 4
            guest
            @porteus:~$ balooctl status
            Baloo is currently disabled
            . To enable, please run "balooctl enable"

            guest@porteus:~$ cat .config/baloofilerc 
            [Basic Settings]
            Indexing-Enabled=false

            [General]
            exclude filters=.histfile.*,*.loT,.uic,*.nvram,litmain.sh,.moc,CTestTestfile.cmake,conftest,*.rcore,autom4te,CMakeFiles,ui_*.h,*.m4,*.pyc,*.csproj,*.tmp,core-dumps,CVS,*.swap,CMakeTmp,confstat,*.pc,CMakeTmpQmake,*.class,__pycache__,*.omf,Makefile.am,lzo,*.la,*.elc,.xsession-errors*,.git,moc_*.cpp,*.po,qrc_*.cpp,.svn,*.aux,*.moc,*.orig,.bzr,*~,*.o,.pch,config.status,confdefs.h,*.lo,CMakeCache.txt,_darcs,.hg,*.part,*.rej,*.gmo,po,lost+found,.obj,libtool,cmake_install.cmake,*.vm*
            exclude filters version=2
            Sorted. :Yahoo!:

        • Rootcopy
          • Code: Select all
            guest@porteus:~$ mkdir  /mnt/sda4/kd_rcp/home/guest/.config
            guest@porteus:~$ echo [Basic Settings] >> /mnt/sda4/kd_rcp/home/guest/.config/baloofilerc
            guest@porteus:~$ echo Indexing-Enabled=false >> /mnt/sda4/kd_rcp/home/guest/.config/baloofilerc
            guest@porteus:~$ cat  /mnt/sda4/kd_rcp/home/guest/.config/baloofilerc
            [Basic Settings]
            Indexing-Enabled=false

          • Code: Select all
            guest@porteus:~$ cat /proc/cmdline 
            quiet from
            =/dev/sda10/tmp/iso/3.2.1/i586/Porteus-KDE-v3.2.1-i586.iso copy2ram ramsize=25% noauto rootcopy=/dev/sda4/kd_rcp noload=1bp extramod=/dev/sda10/kd_xzm rammod=base;-2bp cliexec=mount~--bind~/home/guest/p9/tmp~/tmp guiexec=Prolog/pmx.sh

            guest
            @porteus:~$ tail -n 16 /var/log/porteus-livedbg 
            # Non standard /rootcopy dir:
            /dev/sda4/kd_rcp

            # Modules activated during boot time:
            /memory/copy2ram/000-kernel.xzm
            /memory/copy2ram/001-core.xzm
            /memory/copy2ram/002-xorg.xzm
            /memory/copy2ram/003-kde.xzm
            /mnt/sda10/kd_xzm/flashplayer-plugin-23.0.0.207-i586-1.xzm
            /mnt/sda10/kd_xzm/geany-1.25-i486-bundle.xzm
            /mnt/sda10/kd_xzm/gecko-mediaplayer-1.0.9.i686-pkg-1.xzm
            /mnt/sda10/kd_xzm/lt_040816.xzm
            /memory/copy2ram/nvidia-304.131_3.2.1-i586-2bp.xzm
            /mnt/sda10/kd_xzm/terminator-0.97-i486-1_slack.xzm

            ISO
            =/mnt/sda10/tmp/iso/3.2.1/i586/Porteus-KDE-v3.2.1-i586.iso

            guest
            @porteus:~$ balooctl status
            Baloo is currently disabled
            . To enable, please run "balooctl enable"

            guest@porteus:~$ cat .config/baloofilerc 
            [Basic Settings]
            Indexing-Enabled=false

            [General]
            exclude filters=*.csproj,.git,*~,*.po,.svn,_darcs,lzo,litmain.sh,__pycache__,*.part,*.class,*.pyc,.bzr,*.tmp,.pch,qrc_*.cpp,*.lo,CTestTestfile.cmake,.histfile.*,po,*.o,*.omf,core-dumps,*.elc,.hg,.obj,conftest,*.aux,*.moc,CMakeTmp,.uic,confstat,ui_*.h,.moc,moc_*.cpp,libtool,Makefile.am,CMakeTmpQmake,confdefs.h,*.swap,*.rej,*.gmo,CMakeFiles,CMakeCache.txt,*.m4,*.vm*,.xsession-errors*,*.nvram,lost+found,*.pc,*.loT,*.rcore,CVS,config.status,autom4te,*.orig,cmake_install.cmake,*.la
            exclude filters version
            =2
            Sorted. :Yahoo!:

        Hopefully of assistance in providing some pointer as to where an intervention would be effective.
        Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
        NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB
        Bogomips
        Full of knowledge
        Full of knowledge
         
        Posts: 2157
        Joined: 25 Jun 2014, 16:21
        Location: London
        Distribution: 3.2.2 Cinnamon & KDE5

        Re: Porteus-v3.2.1 bug reports

        Postby Jack » 11 Dec 2016, 04:08

        @Mate 64bit

        I downloaded video from youtube or from my Mobius 2 HD 1080p 60 or 30 fps video camera. When I play either of them the video don't match up with sound. What could the problem be and can it be fixed? When I play the same videos in Windows 7 they play OK with no problem's.
        Last edited by Jack on 11 Dec 2016, 15:35, edited 2 times in total.
        I just like Slackware because I think it teach you about Linux to build packages where Ubuntu is like Windows you just install programs you want.
        Jack
        Contributor
        Contributor
         
        Posts: 1063
        Joined: 09 Aug 2013, 15:25
        Location: Marysville, OHIO USA
        Distribution: Porteus 3.2.rc5 Mate 64 bit

        Re: Porteus-v3.2.1 bug reports

        Postby Jack » 11 Dec 2016, 15:15

        @Mate 64bit

        Why don't the Volume Properties change when you add files to the USB? I added a few youtube download and it stay the same. Here is a screen shot. This is before or after they are both the same.
        Image
        And a screen shot of how much is on the USB with GParted. And the same here.
        Image
        What could be wrong?
        I just like Slackware because I think it teach you about Linux to build packages where Ubuntu is like Windows you just install programs you want.
        Jack
        Contributor
        Contributor
         
        Posts: 1063
        Joined: 09 Aug 2013, 15:25
        Location: Marysville, OHIO USA
        Distribution: Porteus 3.2.rc5 Mate 64 bit

        Re: Porteus-v3.2.1 bug reports

        Postby Blaze » 11 Dec 2016, 18:36

        Cinnamon x86_64
        I tried to run VirtualBox but I stuck on the message
        Code: Select all
        Failed to load R0 module /opt/VirtualBox/VMMR0.r0: The owner is not root: '/opt' (VERR_SUPLIB_OWNER_NOT_ROOT).
        Failed to load VMMR0.r0 (VERR_SUPLIB_OWNER_NOT_ROOT).

        /opt folder have a bad owner and group - fixed via
        Code: Select all
        chown root:root /opt
        Linux porteus 4.9.12-porteus #1 SMP PREEMPT Sun Feb 26 13:48:34 BRT 2017 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
        MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16
        User avatar
        Blaze
        Warlord
        Warlord
         
        Posts: 1073
        Joined: 28 Dec 2010, 12:31
        Location: ☭ Russian Federation, Lipetsk region, Dankov
        Distribution: ⟰ Porteus 3.2 Cinnamon x86_64

        Re: Porteus-v3.2.1 bug reports: kde-baseapps

        Postby Bogomips » 12 Dec 2016, 19:29

        kde 32 bit: kde-baseapps omissions

        Code: Select all
        guest@porteus:~$ egrep "/konqueror$|libkonq.so.5" /var/log/packages/kde-baseapps-16.08.2-i486-1alien 
        usr
        /bin/konqueror
        usr
        /lib/libkonq.so.5.14.25

        guest
        @porteus:~$ egrep "/konqueror$|libkonq.so.5" /var/log/packages/kde-baseapps-16.08.2-i486-1alien | xargs -i ls -lh /{}
        ls: cannot access '/usr/bin/konqueror': No such file or directory
        ls
        : cannot access '/usr/lib/libkonq.so.5.14.25': No such file or directory
        Omission of libs and apps intentional?
        Linux porteus 4.4.0-porteus #3 SMP PREEMPT Sat Jan 23 07:01:55 UTC 2016 i686 AMD Sempron(tm) 140 Processor AuthenticAMD GNU/Linux
        NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2) MemTotal: 901760 kB MemFree: 66752 kB
        Bogomips
        Full of knowledge
        Full of knowledge
         
        Posts: 2157
        Joined: 25 Jun 2014, 16:21
        Location: London
        Distribution: 3.2.2 Cinnamon & KDE5

        Re: Porteus-v3.2.1 bug reports

        Postby brokenman » 12 Dec 2016, 21:02

        Yes. You can get them from alienbob's repository if you need them.
        How do i become super user?
        Wear your underpants on the outside and put on a cape.
        brokenman
        Site Admin
        Site Admin
         
        Posts: 5333
        Joined: 27 Dec 2010, 04:50
        Location: Brazil
        Distribution: Porteus v3.2rcX all desktops

        PreviousNext

        Return to Bug Reports



        Who is online

        Users browsing this forum: No registered users and 2 guests