USM bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
rych
Black ninja
Black ninja
Posts: 80
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 2.1 32-bit
Location: NZ

USM bug reports

Post#526 by rych » 15 Nov 2017, 05:41

The safm.sh stumbled too at some stage. I decided to delete /var/usm and /etc/usm, reboot, and start anew. Then usm eventually worked well. But before it did, it presented me with a different BUG:

As it resolves dependencies and downloads archives it doesn't seem to be checking for their integrity, and continues merrily to covert them to modules or bundles, which apparently install fine, except the application is broken. I went to the /tmp/usm and tried to open each archive and yes, one was corrupt.

Not sure if anyone is developing usm currently. For now I've decided that if anything goes wrong at all, any error message, I will be erasing /var/usm, /etc/usm, AND /tmp/usm. Then I must wait for a few days, unfortunately, before trying again. Only when everything looks smooth can I hope to have a successful installation.

User avatar
Ed_P
Contributor
Contributor
Posts: 3317
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

USM bug reports

Post#527 by Ed_P » 15 Nov 2017, 06:17

You will note from the distribution files that there are many mirrors. Some mirrors may have downloaded some corrupted files and some may not have. Using the scripts you have tried helps to get around the damaged mirrors. Starting from scratch repeatedly doesn't seem to be the fastest approach to a solution.
Ed

Post Reply