USM bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
Ed_P
Contributor
Contributor
Posts: 3316
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

USM bug reports

Post#511 by Ed_P » 16 Aug 2017, 14:53

donald wrote:
16 Aug 2017, 07:48
Ed, why you choose 0.4.4 newest one is 2.0.3
Well, it use to work for me with Porteus 3.0. (Re: Password Manager (Post by Ed_P #51937)). 0.4.3 actually. But 0.4.3 doesn't work with Porteus 3.2.2 and Porteus 3.0 doesn't work on my new notebook. :(
However, what i had to do to get keepassx running:
Link the missing files

Code: Select all

root@porteus:/usr/lib# ln -s /usr/share/copasi/lib/libQtXml.so.4 libQtXml.so.4
root@porteus:/usr/lib# ln -s /usr/share/copasi/lib/libQtGui.so.4 libQtGui.so.4
root@porteus:/usr/lib# ln -s /usr/share/copasi/lib/libQtCore.so.4 libQtCore.so.4
An excellent suggestion :worthy: donald. Especially after I ran this command:

Code: Select all

root@porteus:/home/guest# locate libQtXml
/usr/lib/libQtXml.so
/usr/lib/libQtXml.so.4
/usr/lib/libQtXml.so.4.8
/usr/lib/libQtXml.so.4.8.2
/usr/lib/libQtXml.so.4.8.5
/usr/lib/libQtXmlPatterns.so
/usr/lib/libQtXmlPatterns.so.4
/usr/lib/libQtXmlPatterns.so.4.8
/usr/lib/libQtXmlPatterns.so.4.8.2
/usr/lib/libQtXmlPatterns.so.4.8.5
/usr/lib/qt/lib/libQtXml.la
/usr/lib/qt/lib/libQtXml.prl
/usr/lib/qt/lib/libQtXml.so
/usr/lib/qt/lib/libQtXml.so.4
/usr/lib/qt/lib/libQtXml.so.4.8
/usr/lib/qt/lib/libQtXml.so.4.8.2
/usr/lib/qt/lib/libQtXml.so.4.8.5
/usr/lib/qt/lib/libQtXmlPatterns.la
/usr/lib/qt/lib/libQtXmlPatterns.prl
/usr/lib/qt/lib/libQtXmlPatterns.so
/usr/lib/qt/lib/libQtXmlPatterns.so.4
/usr/lib/qt/lib/libQtXmlPatterns.so.4.8
/usr/lib/qt/lib/libQtXmlPatterns.so.4.8.2
/usr/lib/qt/lib/libQtXmlPatterns.so.4.8.5
/usr/share/copasi/lib/libQtXmlPatterns.so.4
/usr/share/copasi/lib/libQtXml.so.4
Which could also explain why USM didn't include the missing file.
Ed

donald
Full of knowledge
Full of knowledge
Posts: 1217
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

USM bug reports

Post#512 by donald » 16 Aug 2017, 23:18


port
Samurai
Samurai
Posts: 135
Joined: 18 Feb 2016, 09:25
Distribution: Linux porteus 3.2.2 KDE
Location: Spain

USM bug reports

Post#513 by port » 21 Aug 2017, 08:44

Bogomips wrote:
09 Aug 2017, 21:39

Starting from scratch:

Code: Select all

root@porteus:/home/guest# cp $g/usm/funcpackageGet.hic  /usr/share/usm/funcpackageGet   

root@porteus:/home/guest# usm -g text2pdf

 The following items were found.
 Choose an number to confirm.
 ctrl+c to quit

1) text2pdf-1.1-x86_64-1_slonly.txz
#? 1

Processing:   text2pdf-1.1-x86_64-1_slonly.txz

=============
HEURISTIC USM
=============


 The following packages are required.
text2pdf-1.1-x86_64-1_slonly.txz [12K] [not installed]

Total size: 12 KB

 Press [r] to remove packages, [q] to quit, or enter to start downloading.
Downloading: text2pdf-1.1-x86_64-1_slonly.txz  DONE

root@porteus:/home/guest# ls -lh $u/usm/text2pdf-1.1-x86_64-1_slonly.txz
-rw-r--r-- 1 root root 8.5K Feb  6  2017 p10/Por/tmp64/usm/text2pdf-1.1-x86_64-1_slonly.txz
So far there is no problem to speak of. The contents of the file used to overwrite /usr/share/usm/funcpackageGet above, were those posted at the bottom of USM Skirting Sync Issue
I think there's something wrong with my system or something different to yours since we still have the error after downloading your funcpackageGet.hic at the bottom of USM Skirting Sync issue:

Code: Select all

#  funcpackageGet.hic  is the file with content copied from your post
root@porteus:/home/guest# mv funcpackageGet.hic /usr/share/usm/
root@porteus:/home/guest# ls -l /usr/share/usm/funcpackageGet
lrwxrwxrwx 1 root root 18 Aug 21 10:29 /usr/share/usm/funcpackageGet -> funcpackageGet.hic*
root@porteus:/home/guest# ls -l /usr/share/usm/funcpackageGet.hic
-rwxr--r-- 1 root root 19210 Aug 21 10:16 /usr/share/usm/funcpackageGet.hic*

root@porteus:/home/guest# usm -g text2pdf

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) text2pdf-1.1-x86_64-1_slonly.txz
#? 1

Processing:   text2pdf-1.1-x86_64-1_slonly.txz 

=============
HEURISTIC USM
=============

/usr/share/usm/funcpackageGet: line 126: declare: 12K: value too great for base (error token is "12K")


User avatar
Ed_P
Contributor
Contributor
Posts: 3316
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

USM bug reports

Post#514 by Ed_P » 21 Aug 2017, 13:19

Bogomips wrote:
09 Aug 2017, 21:39
Starting from scratch:

Code: Select all

root@porteus:/home/guest# cp $g/usm/funcpackageGet.hic  /usr/share/usm/funcpackageGet 
port wrote:
21 Aug 2017, 08:44

Code: Select all

root@porteus:/home/guest# mv funcpackageGet.hic      /usr/share/usm/
These two commands look the same to you? :no:
Ed

port
Samurai
Samurai
Posts: 135
Joined: 18 Feb 2016, 09:25
Distribution: Linux porteus 3.2.2 KDE
Location: Spain

USM bug reports

Post#515 by port » 21 Aug 2017, 14:18

Ed_P wrote:
21 Aug 2017, 13:19
Bogomips wrote:
09 Aug 2017, 21:39
Starting from scratch:

Code: Select all

root@porteus:/home/guest# cp $g/usm/funcpackageGet.hic  /usr/share/usm/funcpackageGet 
port wrote:
21 Aug 2017, 08:44

Code: Select all

root@porteus:/home/guest# mv funcpackageGet.hic      /usr/share/usm/
These two commands look the same to you? :no:
not really but if you pay attention to my code you will see actually both commands are the same ;-)

In /usr/share/usm/ I have funcpackageGet soft linked to funcpackageGet.hic so moving a new version of funcpackageGet.hic to /usr/share/usm is more or less the same to copying it to /usr/share/usm/funcpackageGet

User avatar
Ed_P
Contributor
Contributor
Posts: 3316
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

USM bug reports

Post#516 by Ed_P » 21 Aug 2017, 19:19

I don't have sufficient expertise to disagree with your approach port, but deleting the *.hic file in /usr/share/usm/ and using the command Bogomips said works only takes a minute to do and try. And eliminates one possible cause of your problem. :happy62:
Ed

port
Samurai
Samurai
Posts: 135
Joined: 18 Feb 2016, 09:25
Distribution: Linux porteus 3.2.2 KDE
Location: Spain

USM bug reports

Post#517 by port » 24 Aug 2017, 16:46

Ed_P wrote:
21 Aug 2017, 19:19
I don't have sufficient expertise to disagree with your approach port, but deleting the *.hic file in /usr/share/usm/ and using the command Bogomips said works only takes a minute to do and try. And eliminates one possible cause of your problem. :happy62:
:) What a lack of faith! ;) :angel:

here you are:

Code: Select all

# cp tmp/usm/funcpackageGet.hic /usr/share/usm/funcpackageGet 
# usm -g text2pdf

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) text2pdf-1.1-x86_64-1_slonly.txz
#? 1

Processing:   text2pdf-1.1-x86_64-1_slonly.txz 

=============
HEURISTIC USM
=============


 The following packages are required. 
text2pdf-1.1-x86_64-1_slonly.txz [12K] [not installed]

Total size: 12 KB
 Would you like to install the package/s? (custom paths are supported) [y/n]

 Press [r] to remove packages, [q] to quit, or enter to start downloading.

 Updates are available. 
 Program update:   not required 
 Database update:  available 
 Please run:  usm -u all  and/or  usm -u usm 
 This message can be disabled in /etc/usm/usm.conf
 ############################### 
Downloading: text2pdf-1.1-x86_64-1_slonly.txz  DONE

 Commencing package conversion ... 
Verifying package text2pdf-1.1-x86_64-1_slonly.txz.
Installing package text2pdf-1.1-x86_64-1_slonly.txz:
PACKAGE DESCRIPTION:
# text2pdf (Converts text files to PDF)
#
# text2pdf makes a 7-bit clean PDF file (version 1.1) from any input
# file. It reads from standard input or a named file, and writes the
# PDF file to standard output.
# You can specify the font, number of lines and columns, paper size
# and various other options from the command line. By default, long
# lines will be wrapped, and a formfeed character (^L) will cause a
# page break.
#
Package text2pdf-1.1-x86_64-1_slonly.txz installed.

Creating /tmp/usm/text2pdf-1.1-x86_64-1_slonly.xzm

Quiet mode: off
Updating shared library links:  /sbin/ldconfig
it works! and now, my style:

Code: Select all

root@porteus:/usr/share/usm# mv funcpackageGet funcpackageGet.hic
root@porteus:/usr/share/usm# ln -s funcpackageGet.hic funcpackageGet
root@porteus:~# usm -g text2pdf

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) text2pdf-1.1-x86_64-1_slonly.txz
#? 1

Processing:   text2pdf-1.1-x86_64-1_slonly.txz 

=============
HEURISTIC USM
=============


 The following packages are required. 
text2pdf-1.1-x86_64-1_slonly.txz [12K] [installed]

Total size: 12 KB
 Would you like to install the package/s? (custom paths are supported) [y/n]

 Press [r] to remove packages, [q] to quit, or enter to start downloading.

 Updates are available. 
 Program update:   not required 
 Database update:  available 
 Please run:  usm -u all  and/or  usm -u usm 
 This message can be disabled in /etc/usm/usm.conf
 ############################### 
Downloading: text2pdf-1.1-x86_64-1_slonly.txz  DONE

 Commencing package conversion ... 
Verifying package text2pdf-1.1-x86_64-1_slonly.txz.
Installing package text2pdf-1.1-x86_64-1_slonly.txz:
PACKAGE DESCRIPTION:
# text2pdf (Converts text files to PDF)
#
# text2pdf makes a 7-bit clean PDF file (version 1.1) from any input
# file. It reads from standard input or a named file, and writes the
# PDF file to standard output.
# You can specify the font, number of lines and columns, paper size
# and various other options from the command line. By default, long
# lines will be wrapped, and a formfeed character (^L) will cause a
# page break.
#
Package text2pdf-1.1-x86_64-1_slonly.txz installed.

Creating /tmp/usm/text2pdf-1.1-x86_64-1_slonly.xzm

Quiet mode: off
Updating shared library links:  /sbin/ldconfig
hey! it also works! ;)

Probably it would be an issue with repositories metadata which is now solved...

User avatar
Ed_P
Contributor
Contributor
Posts: 3316
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

USM bug reports

Post#518 by Ed_P » 25 Aug 2017, 15:12

port wrote:
24 Aug 2017, 16:46
:) What a lack of faith! ;) :angel:
But you got the results I was hoping for. :yahoo: Not based on my suggestion and that's not important, the important thing is you got the module you wanted.

And I've learned that links can be made to more than just executables. :)
Ed

port
Samurai
Samurai
Posts: 135
Joined: 18 Feb 2016, 09:25
Distribution: Linux porteus 3.2.2 KDE
Location: Spain

USM bug reports

Post#519 by port » 29 Aug 2017, 09:54

It seems this is a recurrent problem, probably it's only a problem with repositories metadata since this time I solved the issue with an usm repostory update (usm -u allI but I don't know if it's only due to metadata errors in repositories or there'is also a kind of bug in funcpackageGet.hic so I light a yellow warning led here if it is somehow useful ;-)

Code: Select all

root@porteus:/home/guest# usm -g nvidia

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) nvidia-cg-toolkit-3.1_April2012-x86_64-2_slonly.txz
2) nvidia-driver-375.39-x86_64-4_slonly.txz
3) nvidia-firmware-325.15-noarch-1_slonly.txz
4) nvidia-kernel-375.39_4.4.38-x86_64-1_slonly.txz
5) nvidia-legacy304-driver-304.135-x86_64-1_slonly.txz
6) nvidia-legacy304-kernel-304.135_4.4.38-x86_64-1_slonly.txz
7) nvidia-legacy340-driver-340.102-x86_64-1_slonly.txz
8) nvidia-legacy340-kernel-340.102_4.4.38-x86_64-1_slonly.txz
#? 4

Processing:   nvidia-kernel-375.39_4.4.38-x86_64-1_slonly.txz 

=============
HEURISTIC USM
=============

nvidia-kernel-375.39_4.4.38-x86_64-1_slonly.txz superseded by nvidia-kernel-375.39_4.4.38-x86_64-2_slonly.txz
/usr/share/usm/funcpackageGet: line 126: declare: 5780K: value too great for base (error token is "5780K")

rych
Black ninja
Black ninja
Posts: 78
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 2.1 32-bit
Location: NZ

USM bug reports

Post#520 by rych » 01 Nov 2017, 05:56

(porteus 3.2.2 64 LXDE)

Second day in a row I'm receiving the same error when using

after

Code: Select all

# proxySet
# usm -u usm
# usm -u all
... all databases appear to update okay
# usmgui
trying to install Lyx, for example, of djview, two message boxes appear eventually:
Fatal error
LIBS.TXT
and
Please wait 6 hours for the next database update. Could not find LIBS.TXT
However all subfolders in /var/usm contain non-empty LIBS.TXT.

So what's going on and how to fix, please?

User avatar
Ed_P
Contributor
Contributor
Posts: 3316
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

USM bug reports

Post#521 by Ed_P » 01 Nov 2017, 06:16

I recommend updating the distro mirrors lists. And the easiest way is to run the sesm.sh script in this posting: [INFO & SCRIPT] Slackware Mirror Settings for USM
Ed

apollo
White ninja
White ninja
Posts: 9
Joined: 28 Oct 2017, 13:40
Distribution: 3.2.2 XFCE @ Kernel 4.13.5
Location: .bay,de

USM bug reports

Post#522 by apollo » 01 Nov 2017, 09:16

@rych
same here, update tells me everything is fine but when i try to download some modules the mentioned error appears. Nevertheless some modules can be downloaded successfully.

I haven´t tried the script mentioned by Ed_P yet...

rych
Black ninja
Black ninja
Posts: 78
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 2.1 32-bit
Location: NZ

USM bug reports

Post#523 by rych » 07 Nov 2017, 05:42

It's getting worse:

Code: Select all

# usm -u usm
Downloading: vercheck.txt  DONE

/usr/share/usm/funcupdateDatabase: line 404: [: -gt: unary operator expected
/usr/share/usm/funcupdateDatabase: line 410: [: -gt: unary operator expected
You have the current USM version.

# usm -u all
 Starting slackware database update 
Downloading: vercheck.txt  DONE
Downloading: CHECKSUMS.md5  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT  DONE
Downloading: LIBS.TXT.gz  DONE
File verification was good.

gzip: /var/usm/slackware/LIBS.TXT.gz: unexpected end of file
          

==============================================================================
WARNING!        WARNING!        WARNING!        WARNING!        WARNING!
==============================================================================
One or more errors occurred while usm was running:                       
 
FATAL ERROR!
usm update_database 309
Could not decompress: LIBS.TXT.gz

rych
Black ninja
Black ninja
Posts: 78
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 2.1 32-bit
Location: NZ

USM bug reports

Post#524 by rych » 08 Nov 2017, 05:50

today I've tried to use the script linked above, the `sesm.sh`. Now the errors look as follows

Code: Select all

# usm -u usm
Downloading: vercheck.txt  DONE

 An update is available for the usm database files.
 Please run:  usm -u all 

You have the current USM version.

# usm -u all
 Starting slackware database update 
Downloading: vercheck.txt  DONE
Downloading: CHECKSUMS.md5  DONE
Downloading: MANIFEST.bz2  DONE
Downloading: PACKAGES.TXT  DONE
Downloading: LIBS.TXT.gz  DONE
 There was a problem downloading the file: 

#usmgui
GUI Message: Missing database files.

User avatar
Ed_P
Contributor
Contributor
Posts: 3316
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 3.2.2 64-bit ISO
Location: Western NY, USA

USM bug reports

Post#525 by Ed_P » 08 Nov 2017, 13:55

Now try step 3, the safm.sh script.
Ed

Post Reply